summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--80-irmp.rules1
-rw-r--r--PKGBUILD46
-rw-r--r--irmplircd.install7
-rw-r--r--irmplircd.service12
-rw-r--r--irmplircd.tmpfiles1
6 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..68df236f4c3f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = irmplircd
+ pkgdesc = zeroconf LIRC daemon that reads IRMP events from the USB IR Remote Receiver
+ pkgver = 20141124
+ pkgrel = 2
+ url = https://github.com/realglotzi/irmplircd
+ install = irmplircd.install
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ license = GPL2
+ makedepends = git
+ depends = gcc-libs
+ backup = etc/irmp_stm32.map
+ source = git+https://github.com/realglotzi/irmplircd.git#commit=98d9b36ee6037ff41919b43e2127a041a8d02695
+ source = irmplircd.tmpfiles
+ source = irmplircd.service
+ source = 80-irmp.rules
+ md5sums = SKIP
+ md5sums = febf25c154a7d36f01159e84f26c2d9a
+ md5sums = cfa3ab62473580d8f12aa1eea751ef19
+ md5sums = 6d88605403574e3f3e74cca885b531f0
+
+pkgname = irmplircd
+
diff --git a/80-irmp.rules b/80-irmp.rules
new file mode 100644
index 000000000000..3dc01164f4da
--- /dev/null
+++ b/80-irmp.rules
@@ -0,0 +1 @@
+KERNEL=="hidraw*", ATTRS{idVendor}=="0483", ATTRS{idProduct}=="5750", SYMLINK+="irmp_stm32", TAG+="systemd"
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a423c75b268b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# This PKGBUILD is part of the VDR4Arch project [https://github.com/vdr4arch]
+
+# Maintainer: Manuel Reimer <manuel.reimer@gmx.de>
+pkgname=irmplircd
+pkgver=20141124
+_gitver=98d9b36ee6037ff41919b43e2127a041a8d02695
+pkgrel=2
+pkgdesc="zeroconf LIRC daemon that reads IRMP events from the USB IR Remote Receiver"
+url="https://github.com/realglotzi/irmplircd"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
+license=('GPL2')
+depends=('gcc-libs')
+makedepends=('git')
+backup=("etc/irmp_stm32.map")
+install=irmplircd.install
+source=("git+https://github.com/realglotzi/irmplircd.git#commit=$_gitver"
+ 'irmplircd.tmpfiles'
+ 'irmplircd.service'
+ '80-irmp.rules')
+md5sums=('SKIP'
+ 'febf25c154a7d36f01159e84f26c2d9a'
+ 'cfa3ab62473580d8f12aa1eea751ef19'
+ '6d88605403574e3f3e74cca885b531f0')
+
+pkgver() {
+ cd "${srcdir}/irmplircd"
+ git log -1 --pretty=format:%ad --date=short | sed 's/-//g'
+}
+
+build() {
+ cd "${srcdir}/irmplircd"
+ CFLAGS+=" -Ic_hashmap"
+ make
+}
+
+package() {
+ cd "${srcdir}/irmplircd"
+ make BINDIR="${pkgdir}/usr/bin" SHAREDIR="${pkgdir}/usr/share" install
+
+ install -Dm644 "${srcdir}/irmplircd.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/irmplircd.conf"
+ install -Dm644 "${srcdir}/80-irmp.rules" "$pkgdir/usr/lib/udev/rules.d/80-irmp.rules"
+ install -Dm644 "${srcdir}/irmplircd.service" "$pkgdir/usr/lib/systemd/system/irmplircd.service"
+
+ mkdir -p "${pkgdir}/etc"
+ echo -n > "${pkgdir}/etc/irmp_stm32.map"
+}
diff --git a/irmplircd.install b/irmplircd.install
new file mode 100644
index 000000000000..6664234eb181
--- /dev/null
+++ b/irmplircd.install
@@ -0,0 +1,7 @@
+post_install() {
+ systemd-tmpfiles --create irmplircd.conf
+}
+
+post_upgrade() {
+ post_install
+}
diff --git a/irmplircd.service b/irmplircd.service
new file mode 100644
index 000000000000..bd14be54584f
--- /dev/null
+++ b/irmplircd.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Start irmplircd on irmp_stm32 device
+BindsTo=dev-irmp_stm32.device
+#Wants=dev-irmp_stm32.device
+After=dev-irmp_stm32.device
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/irmplircd -t /etc/irmp_stm32.map /dev/irmp_stm32 -f
+
+[Install]
+WantedBy=dev-irmp_stm32.device
diff --git a/irmplircd.tmpfiles b/irmplircd.tmpfiles
new file mode 100644
index 000000000000..0b80e2e479b2
--- /dev/null
+++ b/irmplircd.tmpfiles
@@ -0,0 +1 @@
+d /run/lirc 0755 root root -