summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
2 files changed, 13 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b018b60c55a3..ae94d684a294 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,17 @@
# Generated by mksrcinfo v8
-# Wed Nov 1 18:31:53 UTC 2017
+# Sun Aug 12 17:55:33 UTC 2018
pkgbase = iscan-plugin-gt-s650
pkgdesc = EPSON Image Scan! plugin for Epson scanners (DS, EP, ES, ET, EW, L, LX, PX, WF, XP Series, FF-640, GT-S650, Perfection V19, Perfection V39)
- pkgver = 1.3.22
- pkgrel = 2
+ pkgver = 1.3.23
+ pkgrel = 1
url = http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX
install = iscan-plugin-gt-s650.install
- arch = i686
arch = x86_64
license = custom:AVASYSPL
depends = iscan
depends = iscan-data
- source_i686 = https://download2.ebz.epson.net/iscan/plugin/gt-s650/deb/x86/iscan-gt-s650-bundle-1.0.0.x86.deb.tar.gz
- sha256sums_i686 = 6f12a5d7b3c1a08a6c5f8762e1cff7ee89063eb73ec723f1822d3fa10c5b50f9
- source_x86_64 = https://download2.ebz.epson.net/iscan/plugin/gt-s650/deb/x64/iscan-gt-s650-bundle-1.0.0.x64.deb.tar.gz
- sha256sums_x86_64 = d27e55652942f7c6e5f7f1b09296b742751c872e3963f8167e1f66fe360d9226
+ source = https://download2.ebz.epson.net/iscan/plugin/gt-s650/deb/x64/iscan-gt-s650-bundle-1.0.0.x64.deb.tar.gz
+ sha256sums = d27e55652942f7c6e5f7f1b09296b742751c872e3963f8167e1f66fe360d9226
pkgname = iscan-plugin-gt-s650
diff --git a/PKGBUILD b/PKGBUILD
index 0bb56300573a..577be5915d97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Muflone http://www.muflone.com/contacts/english/
pkgname=iscan-plugin-gt-s650
-pkgver=1.3.22
-pkgrel=2
+pkgver=1.3.23
+pkgrel=1
pkgdesc="EPSON Image Scan! plugin for Epson scanners (DS, EP, ES, ET, EW, L, LX, PX, WF, XP Series, FF-640, GT-S650, Perfection V19, Perfection V39)"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
license=('custom:AVASYSPL')
depends=('iscan' 'iscan-data')
@@ -12,30 +12,19 @@ _plugin=${pkgname/iscan-plugin-/}
_iscan_ver=1.0.0
_plugin_rel=2
_file_ver=1.1.0
-source_i686=("https://download2.ebz.epson.net/iscan/plugin/${_plugin}/deb/x86/iscan-${_plugin}-bundle-${_iscan_ver}.x86.deb.tar.gz")
-source_x86_64=("https://download2.ebz.epson.net/iscan/plugin/${_plugin}/deb/x64/iscan-${_plugin}-bundle-${_iscan_ver}.x64.deb.tar.gz")
-sha256sums_i686=('6f12a5d7b3c1a08a6c5f8762e1cff7ee89063eb73ec723f1822d3fa10c5b50f9')
-sha256sums_x86_64=('d27e55652942f7c6e5f7f1b09296b742751c872e3963f8167e1f66fe360d9226')
+source=("https://download2.ebz.epson.net/iscan/plugin/${_plugin}/deb/x64/iscan-${_plugin}-bundle-${_iscan_ver}.x64.deb.tar.gz")
+sha256sums=('d27e55652942f7c6e5f7f1b09296b742751c872e3963f8167e1f66fe360d9226')
install="${pkgname}.install"
-if [ "$CARCH" = 'x86_64' ]
-then
- _filearch=x64
- _debarch=amd64
-else
- _filearch=x86
- _debarch=i386
-fi
-
build() {
- cd "iscan-${_plugin}-bundle-${_iscan_ver}.${_filearch}.deb/plugins"
- bsdtar -xf "${pkgname}_${_file_ver}-${_plugin_rel}_${_debarch}.deb"
+ cd "iscan-${_plugin}-bundle-${_iscan_ver}.x64.deb/plugins"
+ bsdtar -xf "${pkgname}_${_file_ver}-${_plugin_rel}_amd64.deb"
bsdtar -xf data.tar.gz
gzip -fkd "usr/share/doc/${pkgname}/NEWS.gz"
}
package() {
- cd "iscan-${_plugin}-bundle-${_iscan_ver}.${_filearch}.deb/plugins/usr"
+ cd "iscan-${_plugin}-bundle-${_iscan_ver}.x64.deb/plugins/usr"
# Install plugins
install -m 755 -d "${pkgdir}/usr/lib/iscan"
install -m 644 -t "${pkgdir}/usr/lib/iscan" "lib/iscan/lib${pkgname}.so.0.0.0"