summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD78
3 files changed, 72 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff7d40747c40..77aff53ba26c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = iscan-plugin-gt-s80
- pkgdesc = iscan plugin for Epson GT-S50 and GT-S80 scanner.
- pkgver = 0.2.1
- pkgrel = 2
+ pkgdesc = iscan plugin for Epson GT-S50 and GT-S80 scanners
+ pkgver = 1.0.1
+ pkgrel = 1
url = http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX
install = gt-s80.install
arch = i686
arch = x86_64
license = custom
- makedepends = deb2targz
- depends = iscan
- depends = iscan-data
- optdepends = iscan-plugin-esdip: provides auto-crop and deskew function
- source = http://a1227.g.akamai.net/f/1227/40484/7d/download.ebz.epson.net/dsc/f/01/00/01/79/56/4ba44418d108b168a9416282fb7fab4eea801e8d//esci-interpreter-gt-s80_0.2.1-1_i386.deb
- md5sums = 678c3ca4a1ae769fff9cbf466646cd86
+ noextract = iscan-gt-s80-bundle-2.30.4.x86.deb.tar.gz
+ noextract = iscan-gt-s80-bundle-2.30.4.x64.deb.tar.gz
+ source_i686 = https://download2.ebz.epson.net/iscan/plugin/gt-s80/deb/x86/iscan-gt-s80-bundle-2.30.4.x86.deb.tar.gz
+ sha256sums_i686 = ad619ff37b165dadce3efd89559e2bc9a7b4596c5fc223378ef66af53314ca20
+ source_x86_64 = https://download2.ebz.epson.net/iscan/plugin/gt-s80/deb/x64/iscan-gt-s80-bundle-2.30.4.x64.deb.tar.gz
+ sha256sums_x86_64 = 082b34012024b501161d93991d6b3cb4ffc8ddcb71ec485ad8683f98237d47d9
pkgname = iscan-plugin-gt-s80
-
+ depends = iscan
+ depends = iscan-data
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index ea94d89a5714..c3f32364c477 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,65 @@
-# Maintainer: Thiago Almeida <thiagoalmeidasa at gmail dot com>
+# Maintainer:
+# Contributor: Thiago Almeida <thiagoalmeidasa at gmail dot com>
# Contributor: Christopher Heien <chris.h.heien@gmail.com>
# Contributor: Stéphane Brunet <stephane at stephanebrunet dot net>
-pkgname=iscan-plugin-gt-s80
-pkgver=0.2.1
-pkgrel=2
-pkgdesc="iscan plugin for Epson GT-S50 and GT-S80 scanner."
-arch=('i686' 'x86_64')
+_pkgname="iscan-plugin-gt-s80"
+pkgname="$_pkgname"
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="iscan plugin for Epson GT-S50 and GT-S80 scanners"
url="http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
+arch=('i686' 'x86_64')
license=('custom')
-depends=('iscan' 'iscan-data')
-optdepends=('iscan-plugin-esdip: provides auto-crop and deskew function')
-makedepends=('deb2targz')
+
+#optdepends=('iscan-plugin-esdip: provides auto-crop and deskew function')
+
install=gt-s80.install
-source=(http://a1227.g.akamai.net/f/1227/40484/7d/download.ebz.epson.net/dsc/f/01/00/01/79/56/4ba44418d108b168a9416282fb7fab4eea801e8d//esci-interpreter-gt-s80_${pkgver}-1_i386.deb)
-[[ $CARCH == "x86_64" ]] && \
-source=(http://a1227.g.akamai.net/f/1227/40484/7d/download.ebz.epson.net/dsc/f/01/00/01/79/56/44ac63b545bcd7fc7fd12ae05b605b0d3c85ea72/esci-interpreter-gt-s80_${pkgver}-1_amd64.deb)
-md5sums=('678c3ca4a1ae769fff9cbf466646cd86')
-[[ $CARCH == "x86_64" ]] && md5sums=('fe4ef040c8a6e48a8aeafd845288f7bd')
+
+noextract=(
+ iscan-gt-s80-bundle-2.30.4.x86.deb.tar.gz
+ iscan-gt-s80-bundle-2.30.4.x64.deb.tar.gz
+)
+
+source_i686=(https://download2.ebz.epson.net/iscan/plugin/gt-s80/deb/x86/iscan-gt-s80-bundle-2.30.4.x86.deb.tar.gz)
+sha256sums_i686=('ad619ff37b165dadce3efd89559e2bc9a7b4596c5fc223378ef66af53314ca20')
+
+source_x86_64=(https://download2.ebz.epson.net/iscan/plugin/gt-s80/deb/x64/iscan-gt-s80-bundle-2.30.4.x64.deb.tar.gz)
+sha256sums_x86_64=('082b34012024b501161d93991d6b3cb4ffc8ddcb71ec485ad8683f98237d47d9')
+
+prepare() {
+ case "$CARCH" in
+ x86_64)
+ _filename="iscan-gt-s80-bundle-2.30.4.x64.deb.tar.gz"
+ _deb_arch="amd64"
+ ;;
+ i686)
+ _filename="iscan-gt-s80-bundle-2.30.4.x86.deb.tar.gz"
+ _deb_arch="i386"
+ ;;
+ esac
+
+ bsdtar -xf "$_filename" --strip-components 1 */plugins/*
+
+ mkdir -p esci-interpreter iscan-plugin-esdip prepare
+
+ bsdtar -C esci-interpreter -xf "plugins/esci-interpreter-gt-s80_1.0.0-1_$_deb_arch.deb"
+ bsdtar -C iscan-plugin-esdip -xf "plugins/iscan-plugin-esdip_1.0.1-1.ltdl7_$_deb_arch.deb"
+
+ bsdtar -C prepare -xf esci-interpreter/data.tar.gz
+ bsdtar -C prepare -xf iscan-plugin-esdip/data.tar.gz
+}
+
package() {
- cd $srcdir
- deb2targz $(basename ${source[0]})
- tar -xf $(basename ${source[0]//.deb/.tar.gz})
- mv usr ${pkgdir}/
- mkdir $pkgdir/usr/share/licences
- mv ${pkgdir}/usr/share/doc/* $pkgdir/usr/share/licences/
- rmdir $pkgdir/usr/share/doc
+ depends=(
+ 'iscan'
+ 'iscan-data'
+ )
+
+ install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
+ cp --reflink=auto -r prepare/usr/lib "$pkgdir/usr/"
+ cp --reflink=auto -r prepare/usr/share/iscan "$pkgdir/usr/share/"
+
+ gzip -dc prepare/usr/share/doc/esci-interpreter-gt-s80/COPYING.EPSON.en.txt.gz > "$pkgdir/usr/share/licenses//$pkgname/COPYING.EPSON.en.txt"
+ gzip -dc prepare/usr/share/doc/esci-interpreter-gt-s80/COPYING.EPSON.ja.txt.gz > "$pkgdir/usr/share/licenses//$pkgname/COPYING.EPSON.ja.txt"
}