summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD46
-rw-r--r--isso.conf6
-rw-r--r--isso.install10
-rw-r--r--isso.service5
6 files changed, 41 insertions, 71 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2409f04c2a88..f0326229f454 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = isso
- pkgdesc = A commenting python server similar to disqus
- pkgver = 0.9.9
+ pkgdesc = A commenting python server similar to Disqus
+ pkgver = 0.10.4
pkgrel = 1
url = http://posativ.org/isso/
install = isso.install
@@ -10,22 +10,20 @@ pkgbase = isso
makedepends = python
depends = python-werkzeug
depends = python-html5lib
- depends = python-misaka
+ depends = python-misaka-v1
depends = python-itsdangerous
depends = python-six
depends = sqlite
depends = python-setuptools
- backup = etc/conf.d/isso
- source = https://pypi.python.org/packages/source/i/isso/isso-0.9.9.tar.gz
- source = https://pypi.python.org/packages/source/i/isso/isso-0.9.9.tar.gz.asc
+ backup = etc/isso.conf
+ source = https://pypi.python.org/packages/source/i/isso/isso-0.10.4.tar.gz
+ source = https://pypi.python.org/packages/source/i/isso/isso-0.10.4.tar.gz.asc
+ source = https://raw.githubusercontent.com/posativ/isso/master/LICENSE
source = isso.service
- source = isso.conf
- source = LICENSE
- sha1sums = b6fa8b1c05e1edcd2089c1512ce6f8e0cd2acdaa
- sha1sums = SKIP
- sha1sums = f3ca306eee19b55b14b791c728e4c57d6fd4a970
- sha1sums = aed76333e2abcfe6e977965444de8f23596d533d
- sha1sums = 71e993a27a10d294a2c0bef68eaba039e1d46916
+ sha256sums = 8666b7339605baf40be9e5dce7a7c772d3acf2b27c47c39ba76ab40a5500eaef
+ sha256sums = SKIP
+ sha256sums = d909d060d71c4d9ce92102fa68aa53c963db9b4b6ca315fa0817eafb07651fe2
+ sha256sums = dfcf54f32094238c7e5344b2dc602925365c8eb0a58c03a922526461b894eba0
pkgname = isso
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index 1045e5bcbefc..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,21 +0,0 @@
-The MIT License (MIT)
-
-Copyright (c) 2012-2013 Martin Zimmermann.
-
-Permission is hereby granted, free of charge, to any person obtaining a copy
-of this software and associated documentation files (the "Software"), to deal
-in the Software without restriction, including without limitation the rights
-to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-copies of the Software, and to permit persons to whom the Software is
-furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in
-all copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
-THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 14dffd566b98..737dc616b234 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,42 @@
-# Maintainer: Reventlov <contact+aur@volcanis.me>
+# Maintainer: yhaupenthal <y dot h plus aur at posteo dot de>
+# Contributor: Brice Waegeneire <brice dot wge at gmail dot com>
+# Contributor: Reventlov <contact+aur@volcanis.me>
pkgname=isso
-pkgver=0.9.9
+pkgver=0.10.4
pkgrel=1
-pkgdesc="A commenting python server similar to disqus"
+pkgdesc="A commenting python server similar to Disqus"
arch=('any')
url="http://posativ.org/isso/"
license=('MIT')
-depends=('python-werkzeug' 'python-html5lib' 'python-misaka' 'python-itsdangerous' 'python-six' 'sqlite' 'python-setuptools')
+depends=('python-werkzeug' 'python-html5lib' 'python-misaka-v1' 'python-itsdangerous' 'python-six' 'sqlite' 'python-setuptools')
makedepends=('git' 'python')
-backup=('etc/conf.d/isso')
+backup=('etc/isso.conf')
source=("https://pypi.python.org/packages/source/i/isso/isso-$pkgver.tar.gz"
-"https://pypi.python.org/packages/source/i/isso/isso-$pkgver.tar.gz.asc"
-"isso.service"
-"isso.conf"
-"LICENSE")
+ "https://pypi.python.org/packages/source/i/isso/isso-$pkgver.tar.gz.asc"
+ "https://raw.githubusercontent.com/posativ/isso/master/LICENSE"
+ "isso.service")
install=$pkgname.install
+sha256sums=('8666b7339605baf40be9e5dce7a7c772d3acf2b27c47c39ba76ab40a5500eaef'
+ 'SKIP'
+ 'd909d060d71c4d9ce92102fa68aa53c963db9b4b6ca315fa0817eafb07651fe2'
+ 'dfcf54f32094238c7e5344b2dc602925365c8eb0a58c03a922526461b894eba0')
validpgpkeys=("7757B21C0C6E5AE4BC6F6462FD1BA15E0E87FE5C")
-noextract=()
-sha1sums=('b6fa8b1c05e1edcd2089c1512ce6f8e0cd2acdaa'
- 'SKIP'
- 'f3ca306eee19b55b14b791c728e4c57d6fd4a970'
- 'aed76333e2abcfe6e977965444de8f23596d533d'
- '71e993a27a10d294a2c0bef68eaba039e1d46916')
package() {
+ cd "${srcdir}"
+ # License
+ install -D -m 644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
msg "Starting build..."
- cd "$srcdir/$pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
- install -d -g 1337 -o 1337 "${pkgdir}"/var/lib/isso
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
# ... systemd
- install -D -m 644 "${srcdir}"/isso.service "${pkgdir}"/usr/lib/systemd/system/isso.service
+ install -D -m 644 "${srcdir}/isso.service" "${pkgdir}/usr/lib/systemd/system/isso.service"
# ... common config
- install -D -m 644 "${srcdir}"/isso.conf "${pkgdir}"/etc/conf.d/isso
-
+ install -D -m 644 "${srcdir}/${pkgname}-${pkgver}/share/isso.conf" "${pkgdir}/etc/isso.conf"
+ # ... man pages
+ install -D -m 644 "${srcdir}/${pkgname}-${pkgver}/man/man1/isso.1" "${pkgdir}/usr/share/man/man1/isso.1"
+ install -D -m 644 "${srcdir}/${pkgname}-${pkgver}/man/man5/isso.conf.5" "${pkgdir}/usr/share/man/man5/isso.conf.5"
}
# vim:set ts=2 sw=2 et:
diff --git a/isso.conf b/isso.conf
deleted file mode 100644
index e0d88f1ee9f4..000000000000
--- a/isso.conf
+++ /dev/null
@@ -1,6 +0,0 @@
-#
-# Configuration file of isso
-#
-
-#ISSO_CONF="/etc/isso.cfg"
-#See http://posativ.org/isso/docs/configuration/server/
diff --git a/isso.install b/isso.install
index 56ab0609b616..386b5b1ee07f 100644
--- a/isso.install
+++ b/isso.install
@@ -1,10 +1,6 @@
post_install() {
- getent group isso &>/dev/null || groupadd -r -g 1337 isso >/dev/null
- getent passwd isso &>/dev/null || useradd -r -u 1337 -g isso -d /var/lib/isso -s /bin/false isso >/dev/null
-}
+ echo "By default the database is located in the temporary location
+/tmp/comments.db and the default interface is http://localhost:8080
-post_remove() {
- getent passwd isso &>/dev/null && userdel isso >/dev/null
- getent group isso &>/dev/null && groupdel isso >/dev/null
- true
+To change this, edit /etc/isso.conf"
}
diff --git a/isso.service b/isso.service
index 316c5c00d606..e76d777fd45e 100644
--- a/isso.service
+++ b/isso.service
@@ -2,9 +2,8 @@
Description=Isso Comment Server
[Service]
-EnvironmentFile=/etc/conf.d/isso
-ExecStart=/usr/bin/isso -c $ISSO_CONF
+Environment="ISSO_SETTINGS=/etc/isso.conf"
+ExecStart=/usr/bin/isso run
[Install]
WantedBy=multi-user.target
-