summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD29
3 files changed, 28 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e6d7a1eb23a..77c8404d067a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,22 @@
pkgbase = itch
pkgdesc = The best way to play itch.io games.
- pkgver = 1.14.0
+ pkgver = 1.26.0
pkgrel = 2
+ epoch = 1
url = https://github.com/itchio/itch
install = itch.install
arch = i686
arch = x86_64
license = MIT
- makedepends = curl
- depends = alsa-lib
depends = libnotify
depends = nss
- depends = gconf
- depends = gtk2
- depends = libxtst
- depends = desktop-file-utils
- depends = gtk-update-icon-cache
depends = libxss
depends = gtk3
+ optdepends = wine: launch windows games
options = !strip
- source = https://github.com/itchio/itch/archive/v25.4.0.tar.gz
- sha256sums = e86c70044c7d02754c6e52fb428d1278678d729c77b8359b5d82198595da1351
+ source = https://github.com/itchio/itch/archive/v25.5.1.tar.gz
+ source = itch-setup::https://broth.itch.ovh/itch-setup/linux-amd64/1.26.0/unpacked/default
+ sha256sums = 0a7094bff90992e3788fd9f9df43a4a3c9233bfcf0f5da037e59af6b365a3249
+ sha256sums = c7a13db7234ca908bcfb60ed5369b5c02b0a795e5e5490f68eeacb5a637a2162
pkgname = itch
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..020f1e2e1050
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!itch.install
diff --git a/PKGBUILD b/PKGBUILD
index 4bce22095796..896a8bc289f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,38 @@
-# Maintainer: Amos Wenger <amos@itch.io>
+# Maintainer: Paragoumba <paragoumba@protonmail.com>
+# Contributor: Amos Wenger <amos@itch.io>
pkgname=itch
-pkgver=1.14.0
+pkgver=1.26.0
pkgrel=2
+epoch=1
pkgdesc="The best way to play itch.io games."
arch=('i686' 'x86_64')
url="https://github.com/itchio/itch"
license=('MIT')
-depends=('alsa-lib' 'libnotify' 'nss' 'gconf' 'gtk2' 'libxtst' 'desktop-file-utils' 'gtk-update-icon-cache' 'libxss' 'gtk3')
-makedepends=('curl')
+depends=('libnotify' 'nss' 'libxss' 'gtk3')
+optdepends=('wine: launch windows games')
options=('!strip')
install="itch.install"
+_ITCH_VER=25.5.1
+
[ "$CARCH" = "i686" ] && _ITCH_ARCH=386;
[ "$CARCH" = "x86_64" ] && _ITCH_ARCH=amd64;
-source=("https://github.com/itchio/itch/archive/v25.4.0.tar.gz")
-sha256sums=('e86c70044c7d02754c6e52fb428d1278678d729c77b8359b5d82198595da1351')
-
-prepare() {
- curl --fail --location --output itch-setup "https://broth.itch.ovh/itch-setup/linux-${_ITCH_ARCH}/${pkgver}/unpacked/default"
-}
+source=(
+ "https://github.com/itchio/itch/archive/v${_ITCH_VER}.tar.gz"
+ "itch-setup::https://broth.itch.ovh/itch-setup/linux-${_ITCH_ARCH}/${pkgver}/unpacked/default")
+sha256sums=('0a7094bff90992e3788fd9f9df43a4a3c9233bfcf0f5da037e59af6b365a3249'
+ 'c7a13db7234ca908bcfb60ed5369b5c02b0a795e5e5490f68eeacb5a637a2162')
package() {
install -Dm755 itch-setup "${pkgdir}/usr/bin/itch-setup"
- cat << BE_KIND > itch
+ cat << 'BE_KIND' > itch
#!/bin/sh
-itch-setup --prefer-launch -- "@$"
+itch-setup --prefer-launch -- "$@"
BE_KIND
install -Dm755 itch "${pkgdir}/usr/bin/itch"
@@ -48,7 +51,7 @@ Comment=Install and play itch.io games easily
BE_PATIENT
install -Dm644 io.itch.itch.desktop "${pkgdir}/usr/share/applications/io.itch.itch.desktop"
- cd "${srcdir}/itch-25.4.0"
+ cd "${srcdir}/itch-${_ITCH_VER}"
for icon in release/images/itch-icons/icon*.png
do