summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD22
2 files changed, 17 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bbd43b7f57d2..44faebe12440 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,24 @@
-# Generated by mksrcinfo v8
-# Mon May 2 11:05:20 UTC 2016
pkgbase = itk-git
pkgdesc = Open-source, cross-platform C++ toolkit for segmentation and registration
- pkgver = 4.9.1.511.gf3ac5ea
+ pkgver = 5.3rc02.220.g6682f865b3
pkgrel = 1
- url = http://www.itk.org
+ url = https://www.itk.org
arch = i686
arch = x86_64
license = Apache
makedepends = git
makedepends = cmake
- makedepends = python
- makedepends = swig
- depends = hdf5-cpp-fortran
- depends = gdcm
- depends = libjpeg-turbo
- depends = libpng
- depends = libtiff
+ depends = eigen
+ depends = gdcm-git
+ depends = gtest
+ depends = hdf5-openmpi
provides = itk
provides = insight-toolkit
provides = insight-toolkit-git
conflicts = itk
conflicts = insight-toolkit
conflicts = insight-toolkit-git
- source = itk::git://git.code.sf.net/p/itk/code
+ source = git+https://github.com/insightsoftwareconsortium/itk.git
sha256sums = SKIP
pkgname = itk-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 4fbd617503ac..a1db24b1f2f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
_pkgname=itk
pkgname=$_pkgname-git
-pkgver=4.9.1.511.gf3ac5ea
+pkgver=5.3rc02.220.g6682f865b3
pkgrel=1
pkgdesc='Open-source, cross-platform C++ toolkit for segmentation and registration'
arch=('i686' 'x86_64')
-url='http://www.itk.org'
+url='https://www.itk.org'
license=('Apache')
-depends=('hdf5-cpp-fortran' 'gdcm' 'libjpeg-turbo' 'libpng' 'libtiff')
-makedepends=('git' 'cmake' 'python' 'swig')
-provides=("$_pkgname" "insight-toolkit" "insight-toolkit-git")
-conflicts=("$_pkgname" "insight-toolkit" "insight-toolkit-git")
-source=("$_pkgname::git://git.code.sf.net/p/itk/code")
+depends=('eigen' 'gdcm-git' 'gtest' 'hdf5-openmpi')
+makedepends=('git' 'cmake')
+provides=("$_pkgname" "insight-toolkit"{,-git})
+conflicts=("$_pkgname" "insight-toolkit"{,-git})
+source=("git+https://github.com/insightsoftwareconsortium/itk.git")
sha256sums=("SKIP")
pkgver() {
@@ -21,14 +21,12 @@ pkgver() {
}
build() {
- mkdir -p build ; cd build
-
- # All bindings are triggering failure of CMake or make right now, thus temporarily disabling
-
+ rm -Rf build && mkdir build
+ cd build
cmake $srcdir/$_pkgname \
+ -DCMAKE_INSTALL_PREFIX=/usr \
-DBUILD_SHARED_LIBS=ON \
-DBUILD_TESTING=OFF \
- -DCMAKE_INSTALL_PREFIX=/usr \
-DITK_USE_SYSTEM_LIBRARIES=ON \
-DITK_USE_SYSTEM_GDCM=ON \
-DITK_WRAP_JAVA=OFF \