summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--J7Z.install58
-rw-r--r--PKGBUILD46
3 files changed, 130 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6cf37ee9d43c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = j7z-svn
+ pkgdesc = An alternative 7-Zip GUI
+ pkgver = r145
+ pkgrel = 1
+ url = https://sourceforge.net/projects/k7z/
+ install = J7Z.install
+ arch = any
+ license = LGPL3
+ makedepends = apache-ant
+ makedepends = java-environment>=7
+ depends = java-runtime>=7
+ depends = p7zip
+ optdepends = gtk-kde4: KDE style support
+ optdepends = oxygen-gtk: Native 'Oxygen' style
+ optdepends = tar: Supports POSIX attributes
+ optdepends = gzip: Supports GZip archives
+ optdepends = bzip2: Supports BZip2 archives
+ optdepends = xz: Supports XZ archives
+ conflicts = j7z
+ conflicts = q7z
+ conflicts = k7z
+ source = https://sourceforge.net/code-snapshots/svn/k/k7/k7z/code/k7z-code-145-trunk.zip
+ sha1sums = SKIP
+
+pkgname = j7z-svn
+
diff --git a/J7Z.install b/J7Z.install
new file mode 100644
index 000000000000..ebc9f0d6bbeb
--- /dev/null
+++ b/J7Z.install
@@ -0,0 +1,58 @@
+# J7Z: Installer: Arch
+# Contributor: Xavion <Xavion (dot) 0 (at) Gmail (dot) com>
+
+post_install() {
+ # Change file permissions
+ #chmod 777 /usr/share/J7Z/Source/
+
+ # Remove old files
+ user_remove
+
+ #/bin/true
+}
+
+post_upgrade() {
+ post_install
+ #/bin/true
+}
+
+pre_remove() {
+ /bin/true
+}
+
+user_remove() {
+ # User
+ if [ ${USER} ]; then
+ export USER=${LOGNAME}
+ fi
+
+ # Home
+ if [ ${SUDO_USER} ]; then
+ export HOME=/home/${SUDO_USER}
+ else
+ export HOME=/home/${USER}
+ fi
+
+ # KDE
+ rm -f ${HOME}/.kde*/share/kde4/services/ServiceMenus/?7Z*
+ rm -f ${HOME}/.kde*/share/apps/konqueror/servicemenus/?7Z*
+
+ # Gnome
+ rm -rf ${HOME}/.gnome2/nautilus-scripts/?7Z*
+
+ # Xfce
+ rm -f ${HOME}/.config/Thunar/uca.xml.?7Z
+}
+
+post_remove() {
+ #rm -rf /usr/share/J7Z/
+
+ user_remove
+
+ #/bin/true
+}
+
+op=$1
+shift
+
+$op "$@"
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4fc6657b367a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Liviu Cristian Mirea-Ghiban <liviu dot mirea at wecodepixels dot com>
+# Based on the J7Z AUR package by Xavion <Xavion (dot) 0 (at) Gmail (dot) com>
+
+pkgname=j7z-svn
+_filename_=J7Z
+_revision_=145
+pkgver=r${_revision_}
+pkgrel=1
+pkgdesc="An alternative 7-Zip GUI"
+arch=("any")
+url="https://sourceforge.net/projects/k7z/"
+license=("LGPL3")
+depends=("java-runtime>=7" "p7zip")
+makedepends=("apache-ant" "java-environment>=7")
+optdepends=("gtk-kde4: KDE style support"
+ "oxygen-gtk: Native 'Oxygen' style"
+ "tar: Supports POSIX attributes"
+ "gzip: Supports GZip archives"
+ "bzip2: Supports BZip2 archives"
+ "xz: Supports XZ archives")
+conflicts=("j7z" "q7z" "k7z")
+install="${_filename_}.install"
+source=(https://sourceforge.net/code-snapshots/svn/k/k7/k7z/code/k7z-code-${_revision_}-trunk.zip)
+
+build() {
+ cd "${srcdir}"/k7z-code-${_revision_}-trunk/${_filename_}/Linux/Build
+
+ # Environment
+ source /etc/profile.d/jre.sh || source /etc/profile.d/jdk.sh
+ #source /etc/profile.d/apache-ant.sh
+
+ #make uninstall
+ #make clean
+ make
+}
+
+package() {
+ cd "${srcdir}"/k7z-code-${_revision_}-trunk/${_filename_}/Linux/Build
+
+ make Packaging=1 DESTDIR="${pkgdir}" install
+
+ # Messages
+ msg "Seek further information or send feedback via the 'Help' menu."
+}
+
+sha1sums=('SKIP')