summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore9
-rw-r--r--.nvchecker.toml6
-rw-r--r--PKGBUILD18
-rw-r--r--jackett.service30
-rw-r--r--jackett.sysusers2
6 files changed, 60 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ddb5d2d6ab1..07ffad3480f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,27 @@
pkgbase = jackett
pkgdesc = Use many torrent trackers with software that supports torznab/potato feeds.
- pkgver = 0.21.2586
+ pkgver = 0.22.71
pkgrel = 1
url = https://github.com/Jackett/Jackett
arch = x86_64
arch = aarch64
arch = armv7h
- license = GPL
- makedepends = dotnet-sdk-6.0
- depends = aspnet-runtime-6.0
+ license = GPL-2.0-or-later
+ makedepends = dotnet-sdk-8.0
+ depends = aspnet-runtime-8.0
+ depends = glibc
+ depends = gcc-libs
optdepends = flaresolverr: A proxy server to bypass Cloudflare protection
options = !strip
options = staticlibs
- source = jackett-0.21.2586.tar.gz::https://github.com/Jackett/Jackett/archive/v0.21.2586.tar.gz
+ options = !debug
+ source = jackett-0.22.71.tar.gz::https://github.com/Jackett/Jackett/archive/v0.22.71.tar.gz
source = jackett.service
source = jackett.sysusers
source = jackett.tmpfiles
- sha256sums = dfbb550306aa995778c9967902ea5dc19868a3118c2560045f1f95d768432a04
- sha256sums = 9d8f9d73e5fa2b2877dde010c0d8ca6fbf47f03eb1f01b02f846026a949a0dcf
- sha256sums = d005fcd009ec5404e1ec88246c31e664167f5551d6cabc35f68eb41750bfe590
+ sha256sums = 3636f73948e06d152033de839e3835467e59a919a3a7dd959d572c8304d9550a
+ sha256sums = 41fbd667538c84662757f923b440d8b250ee3819cd333bd5dd561094d4ef5c3c
+ sha256sums = f865c06ffd21a12d37bf05953d9b483819c0f4e43d243a56db33986113fc40e4
sha256sums = 64022e15565a609f449090f02d53ee90ef95cffec52ae14f99e4e2132b6cffe1
pkgname = jackett
diff --git a/.gitignore b/.gitignore
index 4c1355bd5ea4..bf8523288265 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,5 @@
+pkg/
+src/
+
*.tar.zst
-*.xz
-*.gz
-*.log
-/src/
-/pkg/
+*.tar.gz
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..7403e01b3ed8
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,6 @@
+[jackett]
+source = "github"
+github = "Jackett/Jackett"
+prefix = "v"
+include_regex = "v\\d\\.\\d+\\.\\d+"
+use_max_tag = true
diff --git a/PKGBUILD b/PKGBUILD
index e8a5bd82fab1..5f4561e817b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,18 @@
# Contributor: Donald Webster <fryfrog@gmail.com>
pkgname=jackett
-pkgver=0.21.2586
+pkgver=0.22.71
pkgrel=1
pkgdesc='Use many torrent trackers with software that supports torznab/potato feeds.'
arch=('x86_64' 'aarch64' 'armv7h')
-license=('GPL')
+license=('GPL-2.0-or-later')
url='https://github.com/Jackett/Jackett'
-depends=('aspnet-runtime-6.0')
+depends=('aspnet-runtime-8.0' 'glibc' 'gcc-libs')
optdepends=(
'flaresolverr: A proxy server to bypass Cloudflare protection'
)
-makedepends=('dotnet-sdk-6.0')
-options=('!strip' 'staticlibs')
+makedepends=('dotnet-sdk-8.0')
+options=('!strip' 'staticlibs' '!debug')
source=(
"${pkgname}-${pkgver}.tar.gz::https://github.com/Jackett/Jackett/archive/v${pkgver}.tar.gz"
@@ -23,9 +23,9 @@ source=(
'jackett.tmpfiles'
)
-sha256sums=('dfbb550306aa995778c9967902ea5dc19868a3118c2560045f1f95d768432a04'
- '9d8f9d73e5fa2b2877dde010c0d8ca6fbf47f03eb1f01b02f846026a949a0dcf'
- 'd005fcd009ec5404e1ec88246c31e664167f5551d6cabc35f68eb41750bfe590'
+sha256sums=('3636f73948e06d152033de839e3835467e59a919a3a7dd959d572c8304d9550a'
+ '41fbd667538c84662757f923b440d8b250ee3819cd333bd5dd561094d4ef5c3c'
+ 'f865c06ffd21a12d37bf05953d9b483819c0f4e43d243a56db33986113fc40e4'
'64022e15565a609f449090f02d53ee90ef95cffec52ae14f99e4e2132b6cffe1')
build() {
@@ -38,7 +38,7 @@ build() {
esac
export DOTNET_CLI_TELEMETRY_OPTOUT=1
- dotnet publish src/Jackett.Server -f net6.0 --no-self-contained -r linux-${_CARCH} -c Release -o build/ /p:AssemblyVersion=${pkgver} /p:FileVersion=${pkgver} /p:InformationalVersion=${pkgver} /p:Version=${pkgver}
+ dotnet publish src/Jackett.Server -f net8.0 --no-self-contained -r linux-${_CARCH} -c Release -o build/ /p:AssemblyVersion=${pkgver} /p:FileVersion=${pkgver} /p:InformationalVersion=${pkgver} /p:Version=${pkgver}
# This is required because dotnet build servers do not terminate even after the parent process does
dotnet build-server shutdown
}
diff --git a/jackett.service b/jackett.service
index ed8570078acc..e3703fce6dec 100644
--- a/jackett.service
+++ b/jackett.service
@@ -1,16 +1,44 @@
[Unit]
-Description=Jackett Service
+Description=Jackett Daemon
After=network.target
[Service]
User=jackett
Group=jackett
+SyslogIdentifier=jackett
Restart=always
RestartSec=5
Type=simple
Environment=XDG_CONFIG_HOME=/var/lib/jackett
+WorkingDirectory=/usr/lib/jackett
ExecStart=/usr/lib/jackett/jackett --NoRestart --NoUpdates --DataFolder /var/lib/jackett
TimeoutStopSec=20
+CapabilityBoundingSet=
+LockPersonality=true
+NoNewPrivileges=true
+PrivateDevices=true
+PrivateNetwork=false
+PrivateTmp=true
+PrivateUsers=true
+ProcSubset=pid
+ProtectClock=true
+ProtectControlGroups=true
+ProtectHome=true
+ProtectHostname=true
+ProtectKernelLogs=true
+ProtectKernelModules=true
+ProtectKernelTunables=true
+ProtectProc=invisible
+ProtectSystem=full
+RemoveIPC=true
+RestrictAddressFamilies=AF_INET AF_INET6
+RestrictNamespaces=true
+RestrictRealtime=true
+RestrictSUIDSGID=true
+SocketBindDeny=udp
+SystemCallArchitectures=native
+SystemCallErrorNumber=EPERM
+SystemCallFilter=@basic-io @file-system @io-event @ipc @network-io @process @resources @signal @sync uname
[Install]
WantedBy=multi-user.target
diff --git a/jackett.sysusers b/jackett.sysusers
index b12f617e206d..11c614ceb4b7 100644
--- a/jackett.sysusers
+++ b/jackett.sysusers
@@ -1 +1 @@
-u jackett - "Jackett daemon" /var/lib/jackett
+u jackett - "Jackett Daemon" /var/lib/jackett