summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD55
-rw-r--r--jag-0.3.2-dirs.patch48
-rw-r--r--jag-level-editor.desktop13
-rw-r--r--jag-leveleditor.pngbin0 -> 16923 bytes
-rw-r--r--jag.desktop14
-rw-r--r--jag.pngbin0 -> 8288 bytes
7 files changed, 159 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..69d761a7ca9e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+# Generated by mksrcinfo v8
+# Fri Apr 1 19:23:10 UTC 2016
+pkgbase = jag
+ pkgdesc = A free arcade-puzzle 2D game in which you have to break all the target pieces
+ pkgver = 0.3.2
+ pkgrel = 3
+ url = http://jag.xlabsoft.com/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = qt4
+ depends = sdl_mixer
+ source = http://jag.xlabsoft.com/files/jag-0.3.2-src.zip
+ source = http://jag.xlabsoft.com/files/jag-0.3.2-data.zip
+ source = jag.desktop
+ source = jag.png
+ source = jag-level-editor.desktop
+ source = jag-leveleditor.png
+ source = jag-0.3.2-dirs.patch
+ md5sums = ed4313f2cf57cfc130700e8d91365faa
+ md5sums = 21a1a36f348f866a0a43cb1a8adf4e2f
+ md5sums = 89494a96f138793852744484a05f62d2
+ md5sums = 75bad1a145baa8a9b3fb79b65c959ae6
+ md5sums = 60a2470557e66eed3317d93cf47f4fdd
+ md5sums = 6a733b853844f834efcd182a9182aba6
+ md5sums = 5dce2d642a61b1788670be12dd7363c7
+
+pkgname = jag
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6602a5632721
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Simone Sclavi 'Ito' <darkhado@gmail.com>
+# Contributor: Leonardo Miliani <leonardo@leonardomiliani.com>
+
+pkgname=jag
+pkgver=0.3.2
+pkgrel=3
+pkgdesc="A free arcade-puzzle 2D game in which you have to break all the target pieces"
+arch=('i686' 'x86_64')
+url="http://jag.xlabsoft.com/"
+depends=('qt4' 'sdl_mixer')
+#optdepends=('jag-themes: for additional graphic themes')
+license=('GPL3')
+source=(http://jag.xlabsoft.com/files/$pkgname-$pkgver-src.zip
+ http://jag.xlabsoft.com/files/$pkgname-$pkgver-data.zip
+ 'jag.desktop' 'jag.png'
+ 'jag-level-editor.desktop' 'jag-leveleditor.png'
+ 'jag-0.3.2-dirs.patch')
+
+md5sums=('ed4313f2cf57cfc130700e8d91365faa'
+ '21a1a36f348f866a0a43cb1a8adf4e2f'
+ '89494a96f138793852744484a05f62d2'
+ '75bad1a145baa8a9b3fb79b65c959ae6'
+ '60a2470557e66eed3317d93cf47f4fdd'
+ '6a733b853844f834efcd182a9182aba6'
+ '5dce2d642a61b1788670be12dd7363c7')
+
+build() {
+ mv $pkgname-$pkgver-data/data $pkgname-$pkgver-src
+ cd $pkgname-$pkgver-src
+ patch -Np1 -i ../jag-0.3.2-dirs.patch
+ ## building game
+ qmake-qt4
+ make
+
+ ## building level editor
+ cd editor
+ qmake-qt4
+ make
+}
+package() {
+ ## installing game
+ cd $pkgname-$pkgver-src
+ make INSTALL_ROOT=${pkgdir} install
+ install -D -m644 ../jag.png ${pkgdir}/usr/share/pixmaps/jag.png
+ install -D -m644 ../jag.desktop ${pkgdir}/usr/share/applications/jag.desktop
+
+ ## installing level editor
+ cd editor
+ make INSTALL_ROOT=${pkgdir} install
+ install -D -m644 ${srcdir}/jag-leveleditor.png ${pkgdir}/usr/share/pixmaps/jag-leveleditor.png
+ install -D -m644 ${srcdir}/jag-level-editor.desktop ${pkgdir}/usr/share/applications/jag-level-editor.desktop
+ ## fixing permissions
+ find ${pkgdir}/usr/share -type d -execdir chmod o+rx {} \;
+ find ${pkgdir}/usr/share -type f -execdir chmod o+r {} \;
+}
diff --git a/jag-0.3.2-dirs.patch b/jag-0.3.2-dirs.patch
new file mode 100644
index 000000000000..2f76b63c6919
--- /dev/null
+++ b/jag-0.3.2-dirs.patch
@@ -0,0 +1,48 @@
+diff -u -r ../jag-0.3.2-src.orig/Game.pro ./Game.pro
+--- ../jag-0.3.2-src.orig/Game.pro 2012-03-02 23:50:16.000000000 +0100
++++ ./Game.pro 2013-02-09 22:49:25.860349664 +0100
+@@ -5,9 +5,9 @@
+ opengl
+ unix: {
+ TARGET = ./bin/jag
+- target.path = /usr/local/bin/
++ target.path = /usr/bin/
+ INSTALLS += target
+- datas.path = /usr/local/games/jag
++ datas.path = /usr/share/jag
+ datas.files = data
+ INSTALLS += datas
+ LIBS += -lXrandr
+@@ -22,7 +22,7 @@
+ -lSDL.dll
+ RC_FILE = res.rc
+ }
+-LIBS += -lSDLmain \
++LIBS += -lSDL -lX11 \
+ -lSDL \
+ -lSDL_mixer
+ TEMPLATE = app
+diff -u -r ../jag-0.3.2-src.orig/editor/editor.pro ./editor/editor.pro
+--- ../jag-0.3.2-src.orig/editor/editor.pro 2009-12-14 22:20:12.000000000 +0100
++++ ./editor/editor.pro 2013-02-09 22:49:25.862349666 +0100
+@@ -4,7 +4,7 @@
+
+ unix: {
+ TARGET = ./bin/jag-editor
+- target.path = /usr/local/bin/
++ target.path = /usr/bin/
+ INSTALLS += target
+ }
+ win32: {
+diff -u -r ../jag-0.3.2-src.orig/main.cpp ./main.cpp
+--- ../jag-0.3.2-src.orig/main.cpp 2012-03-03 16:19:11.000000000 +0100
++++ ./main.cpp 2013-02-09 22:49:25.861349662 +0100
+@@ -37,7 +37,7 @@
+ // on X11, we'll check if data directory exists locally first
+ #ifdef Q_WS_X11
+ if (!QDir(resourcePath).exists())
+- resourcePath = "/usr/local/games/jag/data/";
++ resourcePath = "/usr/share/jag/data/";
+ #endif
+
+ if (!QDir(resourcePath).exists()) {
diff --git a/jag-level-editor.desktop b/jag-level-editor.desktop
new file mode 100644
index 000000000000..b0d9e22603db
--- /dev/null
+++ b/jag-level-editor.desktop
@@ -0,0 +1,13 @@
+
+[Desktop Entry]
+Name=Jag level editor
+Exec=jag-editor
+Icon=/usr/share/pixmaps/jag-leveleditor.png
+Comment=Level editor for Jag game
+Exec=jag-editor
+Terminal=false
+X-MultipleArgs=false
+Type=Application
+Categories=GNOME;GTK;Game;LogicGame;
+Encoding=UTF-8
+StartupNotify=true
diff --git a/jag-leveleditor.png b/jag-leveleditor.png
new file mode 100644
index 000000000000..78775744cb0f
--- /dev/null
+++ b/jag-leveleditor.png
Binary files differ
diff --git a/jag.desktop b/jag.desktop
new file mode 100644
index 000000000000..1b4a3dff3c7d
--- /dev/null
+++ b/jag.desktop
@@ -0,0 +1,14 @@
+
+[Desktop Entry]
+Name=Jag
+Exec=jag
+Icon=/usr/share/pixmaps/jag.png
+Comment=Break all the target pieces
+Exec=jag
+Terminal=false
+X-MultipleArgs=false
+Type=Application
+Categories=GNOME;GTK;Game;LogicGame;
+Encoding=UTF-8
+StartupNotify=true
+
diff --git a/jag.png b/jag.png
new file mode 100644
index 000000000000..acb0ddce6660
--- /dev/null
+++ b/jag.png
Binary files differ