summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
-rw-r--r--jagged-alliance-deadly-games-gog.sh6
3 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 246cc7d01c7b..536ae13950d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = jagged-alliance-deadly-games-gog
pkgdesc = A turn-based tactics game developed as a sequel of Jagged Alliance and features new missions and a multiplayer mode.
pkgver = 1.13
- pkgrel = 1
+ pkgrel = 3
url = https://www.gog.com/game/jagged_alliance_deadly_games
install = jagged-alliance-deadly-games-gog.install
arch = any
groups = games
license = custom:eula
- makedepends = innoextract-git
+ makedepends = innoextract
makedepends = icoutils
depends = dosbox
optdepends = unionfs-fuse: mounting game folder to home for savegames and settings
@@ -22,7 +22,7 @@ pkgbase = jagged-alliance-deadly-games-gog
source = dosbox_ipx.conf
source = fix-permissions.sh
sha256sums = 9a0ea3c3eaacefdfe8a85e3fb29e6e5377e0d667143a4ca68ca8fea9b1d946f7
- sha256sums = c82f0f84ff1af66da90182e11c3ce39c2b32ff8d8eb52d4a8b98073e52b92a9a
+ sha256sums = 6c737cd1d3ecab4b4e2e631c6cea2025e77ea0d96b73c95af400826ec6561c2f
sha256sums = a036530c481cb7763ed778366d046636ca1695f8da1d518e98a72a4f86b4dc14
sha256sums = 39bc6cb3a8dedb823bc2a789984d74773fcf684dff1a82b839007a4aac3d8926
sha256sums = c7cfa75590d3845f7c8fc05098e34f4a5a7183a755199dfbeb9c695aeef63ec1
@@ -33,4 +33,3 @@ pkgbase = jagged-alliance-deadly-games-gog
sha256sums = 5bd5ad321e40676448871190cfe55294279c3bf0703e71e97a28c138ebe44937
pkgname = jagged-alliance-deadly-games-gog
-
diff --git a/PKGBUILD b/PKGBUILD
index 6b4b8ae67c4f..861c20e7279e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=jagged-alliance-deadly-games-gog
pkgver=1.13
-pkgrel=1
+pkgrel=3
pkgdesc="A turn-based tactics game developed as a sequel of Jagged Alliance and features new missions and a multiplayer mode."
url="https://www.gog.com/game/jagged_alliance_deadly_games"
license=('custom:eula')
groups=('games')
arch=('any')
-makedepends=('innoextract-git' 'icoutils')
+makedepends=('innoextract' 'icoutils')
depends=('dosbox')
optdepends=('unionfs-fuse: mounting game folder to home for savegames and settings')
install=$pkgname.install
@@ -25,7 +25,7 @@ source=("setup_jagged_alliance_-_deadly_games_${pkgver}_(28044).exe"::"gogdownlo
"fix-permissions.sh")
sha256sums=('9a0ea3c3eaacefdfe8a85e3fb29e6e5377e0d667143a4ca68ca8fea9b1d946f7'
- 'c82f0f84ff1af66da90182e11c3ce39c2b32ff8d8eb52d4a8b98073e52b92a9a'
+ '6c737cd1d3ecab4b4e2e631c6cea2025e77ea0d96b73c95af400826ec6561c2f'
'a036530c481cb7763ed778366d046636ca1695f8da1d518e98a72a4f86b4dc14'
'39bc6cb3a8dedb823bc2a789984d74773fcf684dff1a82b839007a4aac3d8926'
'c7cfa75590d3845f7c8fc05098e34f4a5a7183a755199dfbeb9c695aeef63ec1'
diff --git a/jagged-alliance-deadly-games-gog.sh b/jagged-alliance-deadly-games-gog.sh
index 42df4f373d7a..4198d6206bbd 100644
--- a/jagged-alliance-deadly-games-gog.sh
+++ b/jagged-alliance-deadly-games-gog.sh
@@ -14,6 +14,7 @@ cat <<EOF
$script --windowed
$script --client --windowed
$script --settings
+ DOSBOX_CMD=dosbox-x $script
EOF
exit 0
}
@@ -23,6 +24,7 @@ popd() { builtin popd > /dev/null; }
INSTALL_DIR=/opt/jagged-alliance-deadly-games
HOME_DIR="$HOME"/.gog/jagged-alliance-deadly-games
+DOSBOX_CMD=${DOSBOX_CMD:-dosbox}
if which unionfs &> /dev/null; then
USE_UNIONFS=1
@@ -83,9 +85,9 @@ if [ "$USE_UNIONFS" ]; then
unionfs -o cow,relaxed_permissions "$UPPER_DIR=RW:$LOWER_DIR=RO" "$UNION_DIR"
echo "Launching game within $UNION_DIR"
- pushd "$UNION_DIR" && dosbox "${configs[@]}"
+ pushd "$UNION_DIR" && "$DOSBOX_CMD" "${configs[@]}"
popd && fusermount -u "$UNION_DIR"
else
echo "Launching game within $INSTALL_DIR"
- cd $INSTALL_DIR && dosbox "${configs[@]}"
+ cd $INSTALL_DIR && "$DOSBOX_CMD" "${configs[@]}"
fi