summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--jagged-alliance-gog.sh6
3 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 33abe9aee1bc..a88a1fcdc9b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = jagged-alliance-gog
pkgdesc = A turn-based tactics game that takes place on the fictional South Atlantic island of Metavira.
pkgver = 1.13
- pkgrel = 2
+ pkgrel = 3
url = https://www.gog.com/game/jagged_alliance
install = jagged-alliance-gog.install
arch = any
@@ -19,7 +19,7 @@ pkgbase = jagged-alliance-gog
source = dosbox_windowed.conf
source = fix-permissions.sh
sha256sums = 03b2652cc2352fd84e98344e019503aa33ef7eb8a884112a5c219f07c6366aa6
- sha256sums = 0859a50cc4aaa025bbb4211f3b80ea11e997f6da12408c23c9a3f7b1cc9af03c
+ sha256sums = 1e60766a62965cb1fa816f221f597afa4070949e3440f5152374a63cb7bbf1ff
sha256sums = ea3f11dce620e6f1f9c2d6712c9168fe3216e6df5751f01f2ead022e1e746874
sha256sums = d6ba58df35379ce0662f73ecdf0e5b45b28950b1584f55c2dcfa675a4c432389
sha256sums = aaa680209f8f979e8250983c621268a30bfac3ca551f4dee50e88704bffb8059
diff --git a/PKGBUILD b/PKGBUILD
index f8da557a616c..9313ee6c2da1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=jagged-alliance-gog
pkgver=1.13
-pkgrel=2
+pkgrel=3
pkgdesc="A turn-based tactics game that takes place on the fictional South Atlantic island of Metavira."
url="https://www.gog.com/game/jagged_alliance"
license=('custom:eula')
@@ -22,7 +22,7 @@ source=("setup_jagged_alliance_${pkgver}_(28044).exe"::"gogdownloader://jagged_a
"fix-permissions.sh")
sha256sums=('03b2652cc2352fd84e98344e019503aa33ef7eb8a884112a5c219f07c6366aa6'
- '0859a50cc4aaa025bbb4211f3b80ea11e997f6da12408c23c9a3f7b1cc9af03c'
+ '1e60766a62965cb1fa816f221f597afa4070949e3440f5152374a63cb7bbf1ff'
'ea3f11dce620e6f1f9c2d6712c9168fe3216e6df5751f01f2ead022e1e746874'
'd6ba58df35379ce0662f73ecdf0e5b45b28950b1584f55c2dcfa675a4c432389'
'aaa680209f8f979e8250983c621268a30bfac3ca551f4dee50e88704bffb8059'
diff --git a/jagged-alliance-gog.sh b/jagged-alliance-gog.sh
index ff7ccff73f28..31d47101742f 100644
--- a/jagged-alliance-gog.sh
+++ b/jagged-alliance-gog.sh
@@ -11,6 +11,7 @@ cat <<EOF
$script --windowed
$script --settings
+ DOSBOX_CMD=dosbox-x $script
EOF
exit 0
}
@@ -20,6 +21,7 @@ popd() { builtin popd > /dev/null; }
INSTALL_DIR=/opt/jagged-alliance
HOME_DIR="$HOME"/.gog/jagged-alliance
+DOSBOX_CMD=${DOSBOX_CMD:-dosbox}
if which unionfs &> /dev/null; then
USE_UNIONFS=1
@@ -63,9 +65,9 @@ if [ "$USE_UNIONFS" ]; then
unionfs -o cow,relaxed_permissions "$UPPER_DIR=RW:$LOWER_DIR=RO" "$UNION_DIR"
echo "Launching game within $UNION_DIR"
- pushd "$UNION_DIR" && dosbox "${configs[@]}"
+ pushd "$UNION_DIR" && "$DOSBOX_CMD" "${configs[@]}"
popd && fusermount -u "$UNION_DIR"
else
echo "Launching game within $INSTALL_DIR"
- cd $INSTALL_DIR && dosbox "${configs[@]}"
+ cd $INSTALL_DIR && "$DOSBOX_CMD" "${configs[@]}"
fi