summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD3
-rw-r--r--jameica-start-script.patch35
3 files changed, 18 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e68db3bb33b..80955c577ed9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,3 @@
-# Generated by mksrcinfo v8
-# Tue Jul 11 22:43:11 UTC 2017
pkgbase = jameica
pkgdesc = free runtime environment for java applications
pkgver = 2.6.6
@@ -13,6 +11,7 @@ pkgbase = jameica
depends = java-runtime>=8
depends = java-environment
depends = swt
+ depends = gtk2
optdepends = java-jce_ustrength: Required for mashup plugin used as new scripting platform for non-HBCI accounts (credit cards etc)
source = jameica-start-script.patch
source = jameicaserver-start-script.patch
diff --git a/PKGBUILD b/PKGBUILD
index ae0d48db5402..a82e7409996b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgdesc="free runtime environment for java applications"
arch=('i686' 'x86_64')
url="https://www.willuhn.de/products/jameica/"
license=("GPL2")
-depends=('java-runtime>=8' 'java-environment' 'swt')
+depends=('java-runtime>=8' 'java-environment' 'swt' 'gtk2')
optdepends=('java-jce_ustrength: Required for mashup plugin used as new scripting platform for non-HBCI accounts (credit cards etc)')
makedepends=('unzip')
install="jameica.install"
@@ -24,6 +24,7 @@ source=("jameica-start-script.patch"
"jameica.install")
prepare() {
+ false
patch jameica/jameica.sh jameica-start-script.patch
patch jameica/jameicaserver.sh jameicaserver-start-script.patch
}
diff --git a/jameica-start-script.patch b/jameica-start-script.patch
index 1b15af5f90ad..2f09addabdc2 100644
--- a/jameica-start-script.patch
+++ b/jameica-start-script.patch
@@ -1,20 +1,15 @@
-diff --git a/jameica.sh b/jameica.sh
-index 589e3dd..347922e 100755
---- a/jameica.sh
-+++ b/jameica.sh
-@@ -3,14 +3,7 @@
- # Linux Start-Script fuer regulaeren Standalone-Betrieb.
- # Jameica wird hierbei mit GUI gestartet.
-
--#_JCONSOLE="-Dcom.sun.management.jmxremote"
--
--# https://www.willuhn.de/bugzilla/show_bug.cgi?id=774
--# https://www.willuhn.de/bugzilla/show_bug.cgi?id=798
--
--link=$(readlink -f "$0")
--dir=$(dirname "$link")
--cd "$dir"
-+cd /opt/jameica
-
- if uname -m |grep -q 64; then
- archsuffix="64"
+6,13c6
+< #_JCONSOLE="-Dcom.sun.management.jmxremote"
+<
+< # https://www.willuhn.de/bugzilla/show_bug.cgi?id=774
+< # https://www.willuhn.de/bugzilla/show_bug.cgi?id=798
+<
+< link=$(readlink -f "$0")
+< dir=$(dirname "$link")
+< cd "$dir"
+---
+> cd /opt/jameica
+19a13,15
+>
+> # fix for java9, see https://willuhn.de/blog/index.php?/archives/766-Stolpersteine-unter-Java-9,-Teil-1.html for details
+> export JDK_JAVA_OPTIONS='--add-modules=java.se.ee'