summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD15
-rw-r--r--gcc13.patch11
4 files changed, 25 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f670dd09f266..952dd03aa37f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = jamesdsp
pkgdesc = An audio effect processor for PipeWire clients
pkgver = 2.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Audio4Linux/JDSP4Linux
arch = x86_64
license = GPL3
@@ -21,11 +21,13 @@ pkgbase = jamesdsp
source = git+https://github.com/ThePBone/FlatTabWidget.git
source = git+https://github.com/ThePBone/LiquidEqualizerWidget.git
source = jamesdsp.desktop
+ source = gcc13.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = c6496e6981471aa3f8d1593673991e422d243ff3efe595b3230de713588599c3
+ sha256sums = 55588ee09012aeb3def9f32265b78570a2ffbcbba4a975d43b8d94673ecfb285
pkgname = jamesdsp
diff --git a/.gitignore b/.gitignore
index 4b4ed6a50960..0b643771605d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -6,3 +6,4 @@
!PKGBUILD
!.SRCINFO
!jamesdsp.desktop
+!gcc13.patch
diff --git a/PKGBUILD b/PKGBUILD
index 8ab1e5a9fdf6..10575a09ff94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=jamesdsp
pkgver=2.4
-pkgrel=1
+pkgrel=2
pkgdesc="An audio effect processor for PipeWire clients"
arch=('x86_64')
url="https://github.com/Audio4Linux/JDSP4Linux"
@@ -10,19 +10,21 @@ depends=('glibmm' 'pipewire' 'qt5-svg')
makedepends=('git')
conflicts=('jdsp4linux' 'jdsp4linux-gui' 'gst-plugin-jamesdsp')
replaces=('jdsp4linux' 'jdsp4linux-gui' 'gst-plugin-jamesdsp')
-_commit=49994d2856b66e6c6a9a8752ac47dd338a45166c
+_commit=49994d2856b66e6c6a9a8752ac47dd338a45166c # tags/2.4^0
source=("git+https://github.com/Audio4Linux/JDSP4Linux.git#commit=$_commit"
'git+https://github.com/ThePBone/EELEditor.git'
'git+https://github.com/ThePBone/GraphicEQWidget.git'
'git+https://github.com/ThePBone/FlatTabWidget.git'
'git+https://github.com/ThePBone/LiquidEqualizerWidget.git'
- 'jamesdsp.desktop')
+ 'jamesdsp.desktop'
+ 'gcc13.patch')
sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'c6496e6981471aa3f8d1593673991e422d243ff3efe595b3230de713588599c3')
+ 'c6496e6981471aa3f8d1593673991e422d243ff3efe595b3230de713588599c3'
+ '55588ee09012aeb3def9f32265b78570a2ffbcbba4a975d43b8d94673ecfb285')
pkgver() {
cd "$srcdir/JDSP4Linux"
@@ -39,6 +41,9 @@ prepare() {
done
mkdir -p build
+
+ # Fix build with GCC 13
+ patch -Np1 -i ../gcc13.patch
}
build() {
diff --git a/gcc13.patch b/gcc13.patch
new file mode 100644
index 000000000000..42e4d3eb003f
--- /dev/null
+++ b/gcc13.patch
@@ -0,0 +1,11 @@
+diff --unified --recursive --text a/src/audio/base/IOutputDevice.h b/src/audio/base/IOutputDevice.h
+--- a/src/audio/base/IOutputDevice.h 2023-05-06 14:33:55.907883751 -0600
++++ b/src/audio/base/IOutputDevice.h 2023-05-06 14:34:50.157103187 -0600
+@@ -1,6 +1,7 @@
+ #ifndef IOUTPUTDEVICE_H
+ #define IOUTPUTDEVICE_H
+
++#include <stdint.h>
+ #include <string>
+
+ class IOutputDevice