summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD22
3 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3b26c4d414a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = japi-compliance-checker
+ pkgdesc = A tool for checking backward API/ABI compatibility of a Java library
+ pkgver = 2.4
+ pkgrel = 1
+ url = https://lvc.github.io/japi-compliance-checker/
+ arch = any
+ license = LGPL
+ depends = perl
+ depends = java-environment
+ source = https://github.com/lvc/japi-compliance-checker/archive/2.4.tar.gz
+ sha256sums = 0fd8ff8539a6f4a2c30379999befc1f9003fbb513f778b018a722360ab8c2229
+
+pkgname = japi-compliance-checker
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a16d3cee5374
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar.xz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a18b29885687
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname=japi-compliance-checker
+pkgver=2.4
+pkgrel=1
+pkgdesc="A tool for checking backward API/ABI compatibility of a Java library"
+url="https://lvc.github.io/japi-compliance-checker/"
+arch=('any')
+license=('LGPL')
+depends=('perl' 'java-environment')
+
+source=("https://github.com/lvc/japi-compliance-checker/archive/${pkgver}.tar.gz")
+sha256sums=('0fd8ff8539a6f4a2c30379999befc1f9003fbb513f778b018a722360ab8c2229')
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make install prefix="${pkgdir}/usr/"
+}
+