summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--00-remove-libgnome-keyring.patch40
-rw-r--r--PKGBUILD17
3 files changed, 56 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b2abdbc724e1..509cd4008a5e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Jan 1 13:23:17 UTC 2016
+# Thu Jan 21 09:50:15 UTC 2016
pkgbase = jaromail
pkgdesc = A commandline tool to easily and privately handle your e-mail
pkgver = 4.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.dyne.org/software/jaro-mail/
arch = x86_64
arch = i686
@@ -21,9 +21,10 @@ pkgbase = jaromail
depends = pinentry
depends = wipe
depends = alot
- depends = libgnome-keyring
source = https://files.dyne.org/jaromail/jaromail-4.1.tar.gz
+ source = 00-remove-libgnome-keyring.patch
sha256sums = 1ace90a24c3f73ceeff7b7e34470a2d7d01894ac63fdec9e16f333f09d94573f
+ sha256sums = 3fa439b8ae02c33005a004c45f246e43fa3642c3eb2540c40ad31975e5ecd2a9
pkgname = jaromail
diff --git a/00-remove-libgnome-keyring.patch b/00-remove-libgnome-keyring.patch
new file mode 100644
index 000000000000..0924e236ebc9
--- /dev/null
+++ b/00-remove-libgnome-keyring.patch
@@ -0,0 +1,40 @@
+*** build-gnu.sh.orig 2016-01-21 10:34:46.466974595 +0100
+--- build-gnu.sh 2016-01-21 10:36:23.261971370 +0100
+***************
+*** 34,40 ****
+ debian)
+ deps=(fetchmail msmtp mutt pinentry-curses)
+ deps+=(wipe notmuch sqlite3 alot abook elinks)
+! deps+=(gcc make libglib2.0-dev libgnome-keyring-dev)
+
+ print "Building on Debian"
+ print "Checking software to install"
+--- 34,40 ----
+ debian)
+ deps=(fetchmail msmtp mutt pinentry-curses)
+ deps+=(wipe notmuch sqlite3 alot abook elinks)
+! deps+=(gcc make libglib2.0-dev)
+
+ print "Building on Debian"
+ print "Checking software to install"
+***************
+*** 126,143 ****
+ print OK
+ }
+
+-
+- { test "$target" = "gnome-keyring" } || {
+- test "$target" = "all" } && {
+- print -n "Compiling gnome-keyring... "
+- pushd src/gnome-keyring
+- ${=cc} jaro-gnome-keyring.c -o jaro-gnome-keyring \
+- `pkg-config --cflags --libs glib-2.0 gnome-keyring-1`
+- popd
+- cp src/gnome-keyring/jaro-gnome-keyring build/gnu/
+- print OK
+- }
+-
+ # build mixmaster only if specified
+ { test "$target" = "mixmaster" } && {
+ print "Compiling Mixmaster (anonymous remailer)"
+--- 126,131 ----
diff --git a/PKGBUILD b/PKGBUILD
index f030fb29343e..78c997b1a597 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,25 @@
# Maintainer: parazyd <parazyd@dyne.org>
pkgname=jaromail
pkgver=4.1
-pkgrel=1
+pkgrel=2
pkgdesc="A commandline tool to easily and privately handle your e-mail"
arch=('x86_64' 'i686')
url="https://www.dyne.org/software/jaro-mail/"
license=('GPL3')
-depends=('zsh' 'mutt' 'fetchmail' 'vim' 'msmtp' 'notmuch' 'abook' 'elinks' 'pinentry' 'wipe' 'alot' 'libgnome-keyring')
+depends=('zsh' 'mutt' 'fetchmail' 'vim' 'msmtp' 'notmuch' 'abook' 'elinks' 'pinentry' 'wipe' 'alot')
makedepends=('gcc' 'glib2')
-source=("https://files.dyne.org/$pkgname/$pkgname-$pkgver.tar.gz")
-sha256sums=("1ace90a24c3f73ceeff7b7e34470a2d7d01894ac63fdec9e16f333f09d94573f")
+source=("https://files.dyne.org/$pkgname/$pkgname-$pkgver.tar.gz"
+ "00-remove-libgnome-keyring.patch")
+sha256sums=("1ace90a24c3f73ceeff7b7e34470a2d7d01894ac63fdec9e16f333f09d94573f"
+ "3fa439b8ae02c33005a004c45f246e43fa3642c3eb2540c40ad31975e5ecd2a9")
# Jaromil https://jaromil.dyne.org/contact
validpgpkeys=('6113D89CA825C5CEDD02C87273B35DA54ACB7D10')
+
+prepare() {
+ patch "$pkgname-$pkgver/build/build-gnu.sh" "00-remove-libgnome-keyring.patch"
+}
+
build() {
cd "$pkgname-$pkgver"
make
@@ -69,7 +76,7 @@ package() {
printf "Jaro Mail installed in: $PREFIX\n"
printf "Executable path: $PREFIX/bin/jaro\n\n"
printf "To initialize your Mail dir use: jaro init\n"
- printf "Default is $HOME/Mail\n"
+ printf "Default is /root/Mail\n"
printf "Change it via environment variable JAROMAILDIR\n"
printf "****************************************************\n\n"