summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--sem.patch14
3 files changed, 22 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9904ae7509b0..d015fadce12e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Mon Jan 15 04:41:50 UTC 2018
+# Mon Jan 15 04:49:18 UTC 2018
pkgbase = jasp-desktop-git
pkgdesc = JASP, a low fat alternative to SPSS, a delicious alternative to R.
pkgver = v0.8.5.r0.g3242143a
@@ -31,8 +31,10 @@ pkgbase = jasp-desktop-git
options = !strip
source = jasp-desktop::git+https://github.com/jasp-stats/jasp-desktop.git#tag=v0.8.5
source = include.patch
+ source = sem.patch
md5sums = SKIP
md5sums = 846d0f24ef877c895ae027aed7588bdc
+ md5sums = bdb0cabaf21cb7b59b75be1cd25b3ec5
pkgname = jasp-desktop-git
diff --git a/PKGBUILD b/PKGBUILD
index 917e8fbb8ca8..b7068e7dc7d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,8 @@ provides=('jasp' 'jasp-desktop')
conflicts=('jasp' 'jasp-desktop')
options=('!strip')
source=("$_pkgname::git+https://github.com/jasp-stats/$_pkgname.git#tag=v0.8.5"
- "include.patch")
+ "include.patch"
+ "sem.patch")
pkgver() {
cd "$srcdir/$_pkgname"
@@ -28,6 +29,7 @@ prepare() {
cd $srcdir/$_pkgname
#Patch the R include path
patch -p1 < $srcdir/include.patch
+ patch -p1 < $srcdir/sem.patch
#Create separate build dir
mkdir -p $srcdir/$_buildname
cd $srcdir/$_buildname
@@ -60,4 +62,5 @@ package() {
ln -s /usr/lib/JASP/jasp $pkgdir/usr/bin/JASP
}
md5sums=('SKIP'
- '846d0f24ef877c895ae027aed7588bdc')
+ '846d0f24ef877c895ae027aed7588bdc'
+ 'bdb0cabaf21cb7b59b75be1cd25b3ec5')
diff --git a/sem.patch b/sem.patch
new file mode 100644
index 000000000000..e5432e72995b
--- /dev/null
+++ b/sem.patch
@@ -0,0 +1,14 @@
+diff --git a/JASP-Desktop/module.cpp b/JASP-Desktop/module.cpp
+index e58ab060..c96fd356 100644
+--- a/JASP-Desktop/module.cpp
++++ b/JASP-Desktop/module.cpp
+@@ -6,9 +6,7 @@ using namespace std;
+
+ map<QString, Module> Module::AllModules = {
+ {"Common", Module("Common")},
+-#ifndef __linux__
+ {"SEM", Module("SEM", 1)},
+-#endif
+ { "ReinforcementLearning", Module("ReinforcementLearning", "Reinforcement Learning", 2, false)},
+ {"SummaryStats", Module("SummaryStats", "Summary Stats", 3)},
+ {"MetaAnalysis", Module("MetaAnalysis", "Meta Analysis", 4)},