summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD13
-rw-r--r--include.patch13
2 files changed, 14 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ed9f0da816c4..45b36dd85347 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=jasp-desktop-git
_pkgname=jasp-desktop
_buildname=jasp-build
-pkgver=r1982.be642be
+pkgver=v0.7.5Beta1.r0.gf8561f9
pkgrel=1
pkgdesc="JASP, a low fat alternative to SPSS, a delicious alternative to R."
arch=('any')
@@ -13,7 +13,8 @@ makedepends=('git' 'qtchooser' 'r' 'gcc-fortran' 'boost')
provides=('jasp' 'jasp-desktop')
conflicts=('jasp' 'jasp-desktop')
install=('jasp-desktop-git.install')
-source=("$_pkgname::git+https://github.com/jasp-stats/$_pkgname.git#branch=development"
+options=('!strip')
+source=("$_pkgname::git+https://github.com/jasp-stats/$_pkgname.git#tag=v0.7.5Beta1"
"jasp-desktop.svg"
"include.patch"
"sem.patch")
@@ -38,7 +39,7 @@ prepare() {
cd $srcdir/$_buildname
echo "Creating Makefile"
- qmake PREFIX=/usr ../$_pkgname
+ qmake R_HOME=/usr/lib/R PREFIX=/usr ../$_pkgname
}
build() {
@@ -50,7 +51,9 @@ package() {
#Install files
cd $srcdir/$_buildname
mkdir -p $pkgdir/usr/share/$_pkgname
- cp -r JASP R JASPEngine Resources $pkgdir/usr/share/$_pkgname/
+ mkdir -p $pkgdir/usr/lib
+ cp -r R $pkgdir/usr/lib/
+ cp -r JASP JASPEngine Resources $pkgdir/usr/share/$_pkgname/
#Install icon
mkdir -p $pkgdir/usr/share/pixmaps/
@@ -71,5 +74,5 @@ EOF
}
md5sums=('SKIP'
'bcaf403001283553bb63b72c268d0290'
- '28606a27e9730789b8d4fe05950ff4d9'
+ 'caf8356566041e51d124707fe44afedc'
'3f5c10570e9a195dc8008a86f72b0e5a')
diff --git a/include.patch b/include.patch
index 0472c00341bf..cea63f8779d6 100644
--- a/include.patch
+++ b/include.patch
@@ -1,13 +1,12 @@
diff --git a/JASP-Engine/JASP-Engine.pro b/JASP-Engine/JASP-Engine.pro
-index f96f944..de486f3 100644
+index 2530063..2efd24d 100644
--- a/JASP-Engine/JASP-Engine.pro
+++ b/JASP-Engine/JASP-Engine.pro
-@@ -65,7 +65,7 @@ QMAKE_CXXFLAGS += -Wno-c++11-extra-semi
- win32:QMAKE_CXXFLAGS += -DBOOST_USE_WINDOWS_H
+@@ -71,6 +71,7 @@ INCLUDEPATH += \
- INCLUDEPATH += \
-- $$_R_HOME/include \
+ linux:INCLUDEPATH += \
+ /usr/share/R/include \
+ /usr/include/R \
- $$_R_HOME/library/RInside/include \
- $$_R_HOME/library/Rcpp/include
+ $$_R_HOME/site-library/RInside/include \
+ $$_R_HOME/site-library/Rcpp/include