summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD8
-rw-r--r--include.patch12
-rw-r--r--sem.patch24
3 files changed, 14 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3f05f7dd8e67..ed9f0da816c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=jasp-desktop-git
_pkgname=jasp-desktop
_buildname=jasp-build
-pkgver=r1868.f1369d8
+pkgver=r1982.be642be
pkgrel=1
pkgdesc="JASP, a low fat alternative to SPSS, a delicious alternative to R."
arch=('any')
@@ -50,7 +50,7 @@ package() {
#Install files
cd $srcdir/$_buildname
mkdir -p $pkgdir/usr/share/$_pkgname
- cp -r JASP R-library JASPEngine Resources $pkgdir/usr/share/$_pkgname/
+ cp -r JASP R JASPEngine Resources $pkgdir/usr/share/$_pkgname/
#Install icon
mkdir -p $pkgdir/usr/share/pixmaps/
@@ -71,5 +71,5 @@ EOF
}
md5sums=('SKIP'
'bcaf403001283553bb63b72c268d0290'
- 'b8e84d0193dd415158df137870148817'
- '9e04c417faac1e36f7ddb9f8350620ab')
+ '28606a27e9730789b8d4fe05950ff4d9'
+ '3f5c10570e9a195dc8008a86f72b0e5a')
diff --git a/include.patch b/include.patch
index 5c679d12713b..0472c00341bf 100644
--- a/include.patch
+++ b/include.patch
@@ -1,13 +1,13 @@
diff --git a/JASP-Engine/JASP-Engine.pro b/JASP-Engine/JASP-Engine.pro
-index a030e79..5bdcdad 100644
+index f96f944..de486f3 100644
--- a/JASP-Engine/JASP-Engine.pro
+++ b/JASP-Engine/JASP-Engine.pro
-@@ -60,7 +60,7 @@ QMAKE_CXXFLAGS += -Wno-c++11-extra-semi
+@@ -65,7 +65,7 @@ QMAKE_CXXFLAGS += -Wno-c++11-extra-semi
win32:QMAKE_CXXFLAGS += -DBOOST_USE_WINDOWS_H
INCLUDEPATH += \
-- $$R_HOME/include \
-+ /usr/include/R \
- $$R_HOME/library/RInside/include \
- $$R_HOME/library/Rcpp/include
+- $$_R_HOME/include \
++ /usr/include/R \
+ $$_R_HOME/library/RInside/include \
+ $$_R_HOME/library/Rcpp/include
diff --git a/sem.patch b/sem.patch
index 531c50c5036e..a87a80338a8b 100644
--- a/sem.patch
+++ b/sem.patch
@@ -1,8 +1,8 @@
diff --git a/JASP-Desktop/mainwindow.cpp b/JASP-Desktop/mainwindow.cpp
-index 80cd705..d8ccc6c 100644
+index 147ee34..fdd4e08 100644
--- a/JASP-Desktop/mainwindow.cpp
+++ b/JASP-Desktop/mainwindow.cpp
-@@ -87,9 +87,7 @@ MainWindow::MainWindow(QWidget *parent) :
+@@ -91,9 +91,7 @@ MainWindow::MainWindow(QWidget *parent) :
ui->tabBar->setFocusPolicy(Qt::NoFocus);
ui->tabBar->addTab("File");
ui->tabBar->addTab("Common");
@@ -12,28 +12,12 @@ index 80cd705..d8ccc6c 100644
ui->tabBar->addHelpTab();
connect(ui->tabBar, SIGNAL(currentChanged(int)), this, SLOT(tabChanged(int)));
-@@ -543,7 +541,6 @@ void MainWindow::tabChanged(int index)
- {
- ui->topLevelWidgets->setCurrentIndex(0);
- }
--#ifndef __linux__
- else if (index == ui->tabBar->count() - 1)
- {
- if (_optionsForm == NULL)
-@@ -555,7 +552,6 @@ void MainWindow::tabChanged(int index)
-
- ui->topLevelWidgets->setCurrentWidget(_optionsForm);
- }
--#endif
- else
- {
- ui->topLevelWidgets->setCurrentIndex(1);
-@@ -789,15 +785,12 @@ void MainWindow::updateMenuEnabledDisabledStatus()
+@@ -918,15 +916,11 @@ void MainWindow::updateMenuEnabledDisabledStatus()
void MainWindow::updateUIFromOptions()
{
-#ifdef __linux__
- ui->tabBar->removeTab("SEM");
+- ui->tabBar->removeTab("SEM");
-#else
QVariant sem = _settings.value("plugins/sem", false);
if (sem.canConvert(QVariant::Bool) && sem.toBool())