summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rw-r--r--include.patch12
-rw-r--r--sem.patch26
4 files changed, 37 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3a739482899..0219bf6244b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Jan 20 20:58:33 UTC 2016
+# Tue Feb 23 20:07:43 UTC 2016
pkgbase = jasp-desktop-git
pkgdesc = JASP, a low fat alternative to SPSS, a delicious alternative to R.
- pkgver = v0.7.5Beta3.r0.g0e28d09
+ pkgver = v0.7.5.r0.g7db237f
pkgrel = 1
url = http://jasp-stats.org
install = jasp-desktop-git.install
@@ -28,14 +28,14 @@ pkgbase = jasp-desktop-git
conflicts = jasp
conflicts = jasp-desktop
options = !strip
- source = jasp-desktop::git+https://github.com/jasp-stats/jasp-desktop.git#tag=v0.7.5Beta3
+ source = jasp-desktop::git+https://github.com/jasp-stats/jasp-desktop.git#tag=v0.7.5
source = jasp-desktop.svg
source = include.patch
source = sem.patch
md5sums = SKIP
md5sums = bcaf403001283553bb63b72c268d0290
- md5sums = caf8356566041e51d124707fe44afedc
- md5sums = 3f5c10570e9a195dc8008a86f72b0e5a
+ md5sums = 55f6dd36a413afa371fd112d3afa038e
+ md5sums = c7381a233ac6c6d7f6ccd85434f93f41
pkgname = jasp-desktop-git
diff --git a/PKGBUILD b/PKGBUILD
index f17c36d51336..f7468776a60e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=jasp-desktop-git
_pkgname=jasp-desktop
_buildname=jasp-build
-pkgver=v0.7.5Beta3.r0.g0e28d09
+pkgver=v0.7.5.r0.g7db237f
pkgrel=1
pkgdesc="JASP, a low fat alternative to SPSS, a delicious alternative to R."
arch=('any')
@@ -12,9 +12,9 @@ depends=('qt5-base' 'r' 'libarchive' 'qt5-webkit' 'qt5-declarative' 'qt5-sensors
makedepends=('git' 'qtchooser' 'r' 'gcc-fortran' 'boost')
provides=('jasp' 'jasp-desktop')
conflicts=('jasp' 'jasp-desktop')
-install=('jasp-desktop-git.install')
+install='jasp-desktop-git.install'
options=('!strip')
-source=("$_pkgname::git+https://github.com/jasp-stats/$_pkgname.git#tag=v0.7.5Beta3"
+source=("$_pkgname::git+https://github.com/jasp-stats/$_pkgname.git#tag=v0.7.5"
"jasp-desktop.svg"
"include.patch"
"sem.patch")
@@ -74,5 +74,5 @@ EOF
}
md5sums=('SKIP'
'bcaf403001283553bb63b72c268d0290'
- 'caf8356566041e51d124707fe44afedc'
- '3f5c10570e9a195dc8008a86f72b0e5a')
+ '55f6dd36a413afa371fd112d3afa038e'
+ 'c7381a233ac6c6d7f6ccd85434f93f41')
diff --git a/include.patch b/include.patch
index cea63f8779d6..376b5a3ef0b5 100644
--- a/include.patch
+++ b/include.patch
@@ -1,12 +1,12 @@
diff --git a/JASP-Engine/JASP-Engine.pro b/JASP-Engine/JASP-Engine.pro
-index 2530063..2efd24d 100644
+index 3bf44d7..6fe7a09 100644
--- a/JASP-Engine/JASP-Engine.pro
+++ b/JASP-Engine/JASP-Engine.pro
-@@ -71,6 +71,7 @@ INCLUDEPATH += \
+@@ -72,6 +72,7 @@ INCLUDEPATH += \
linux:INCLUDEPATH += \
- /usr/share/R/include \
-+ /usr/include/R \
- $$_R_HOME/site-library/RInside/include \
- $$_R_HOME/site-library/Rcpp/include
+ /usr/share/R/include \
++ /usr/include/R \
+ $$_R_HOME/site-library/RInside/include \
+ $$_R_HOME/site-library/Rcpp/include
diff --git a/sem.patch b/sem.patch
index a87a80338a8b..11cb08db4d4b 100644
--- a/sem.patch
+++ b/sem.patch
@@ -1,10 +1,10 @@
diff --git a/JASP-Desktop/mainwindow.cpp b/JASP-Desktop/mainwindow.cpp
-index 147ee34..fdd4e08 100644
+index 14e56a9..5aed19c 100644
--- a/JASP-Desktop/mainwindow.cpp
+++ b/JASP-Desktop/mainwindow.cpp
-@@ -91,9 +91,7 @@ MainWindow::MainWindow(QWidget *parent) :
- ui->tabBar->setFocusPolicy(Qt::NoFocus);
- ui->tabBar->addTab("File");
+@@ -120,9 +120,7 @@ MainWindow::MainWindow(QWidget *parent) :
+ ui->tabBar->addTab("Variables"); // variables view
+ #endif
ui->tabBar->addTab("Common");
-#ifndef __linux__
ui->tabBar->addOptionsTab(); // no SEM under linux for now
@@ -12,7 +12,23 @@ index 147ee34..fdd4e08 100644
ui->tabBar->addHelpTab();
connect(ui->tabBar, SIGNAL(currentChanged(int)), this, SLOT(tabChanged(int)));
-@@ -918,15 +916,11 @@ void MainWindow::updateMenuEnabledDisabledStatus()
+@@ -670,7 +668,6 @@ void MainWindow::tabChanged(int index)
+ ui->topLevelWidgets->setCurrentIndex(1);
+ }
+ #endif
+-#ifndef __linux__
+ else if (index == ui->tabBar->count() - 1)
+ {
+ if (_optionsForm == NULL)
+@@ -682,7 +679,6 @@ void MainWindow::tabChanged(int index)
+
+ ui->topLevelWidgets->setCurrentWidget(_optionsForm);
+ }
+-#endif
+ else
+ {
+ #ifdef QT_DEBUG // if variables tab enabled
+@@ -988,15 +984,11 @@ void MainWindow::updateMenuEnabledDisabledStatus()
void MainWindow::updateUIFromOptions()
{