summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD10
3 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 350095438940..35188720a73f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = jcal-git
pkgdesc = Jalali calendar is a small and portable free software library to manipulate date and time in Jalali calendar system
- pkgver = 69.162c703
+ pkgver = v0.4.1.r1.ge4678be
pkgrel = 1
url = http://www.nongnu.org/jcal/
arch = any
license = GPL3
makedepends = git
provides = jcal
- source = git://github.com/ashkang/jcal.git
+ source = git://github.com/fzerorubigd/jcal.git
md5sums = SKIP
pkgname = jcal-git
diff --git a/.gitignore b/.gitignore
index 0045cadbfc4a..33da012598bf 100644
--- a/.gitignore
+++ b/.gitignore
@@ -9,3 +9,4 @@
/src
*.gz
rc
+jcal/
diff --git a/PKGBUILD b/PKGBUILD
index afc930e25ab7..185575338548 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,27 @@
-# Maintainer: FzerorubigD <Fzerorubigd {AT} GMail {DOT} com>
+# Maintainer: fzerorubigd <fzero{AT}rubi{DOT}gd>
pkgname='jcal-git'
_gitname=jcal
#The real value will be calculated by pkgver() function
-pkgver=69.162c703
+pkgver=v0.4.1.r1.ge4678be
pkgrel=1
pkgdesc="Jalali calendar is a small and portable free software library to manipulate date and time in Jalali calendar system"
url="http://www.nongnu.org/jcal/"
-
+
arch=('any')
license=('GPL3')
provides=('jcal')
depends=()
makedepends=('git')
-source=('git://github.com/ashkang/jcal.git')
+source=('git://github.com/fzerorubigd/jcal.git')
md5sums=('SKIP')
pkgver() {
cd "${srcdir}/${_gitname}"
- echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ git describe --tags | sed 's/-/.r/; s/-/./'
}
build() {