summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD27
-rwxr-xr-xreadme.sh15
3 files changed, 42 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8622c8fb49d..0cd0375e287b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Wed Apr 17 05:00:06 UTC 2019
+# Tue Apr 23 01:15:31 UTC 2019
pkgbase = jdk8
pkgdesc = Oracle Java 8 Development Kit
pkgver = 8u212
@@ -43,23 +43,26 @@ pkgbase = jdk8
backup = etc/java-jdk8/psfontj2d.properties
backup = etc/java-jdk8/sound.properties
source = https://download.oracle.com/otn-pub/java/jce/8/jce_policy-8.zip
- source = https://download.oracle.com/otn-pub/java/jdk/8u212-b10/59066701cf1a433da9770636fbc4c9aa/jdk-8u212-linux-x64.tar.gz
+ source = manual://jdk-8u212-linux-x64.tar.gz
source = jconsole-jdk8.desktop
source = jmc-jdk8.desktop
source = jvisualvm-jdk8.desktop
source = policytool-jdk8.desktop
+ source = readme.sh
md5sums = b3c7031bc65c28c2340302065e7d00d3
md5sums = 62d57a7550c97b534343443475d9afd9
md5sums = 8a66f50efdc867ffd6a27168bc93b210
md5sums = 1cbde70639abd98db4bace284dbf2bc4
md5sums = f0b39865361437f3778ecbe6ffbc0a06
md5sums = 89704501aff8efe859c31968d8d168e6
+ md5sums = 4dda444d58a4d78ca6357228adbde8a2
sha256sums = f3020a3922efd6626c2fff45695d527f34a8020e938a49292561f18ad1320b59
sha256sums = 3160c50aa8d8e081c8c7fe0f859ea452922eca5d2ae8f8ef22011ae87e6fedfb
sha256sums = 65282603bd0804d162f3f7da47bc7f3c91373e87504297d6a6fd6f2f8a1ec4ee
sha256sums = 8f865b52946a9ab98556c56306c7e70ae7aa432b4d005c70df0bba9d2c3111b1
sha256sums = 144e6651fcea08d95f3148d3a8ad17deb93fec4dd9236d37d27d7c648230b870
sha256sums = 635433e9c78ff58af65c316232ac9907d289a324428923788ea0f82ae7f8083b
+ sha256sums = d1b4b3161614d7620365a0528a86f7eec543de30ee756b1ad2dabd386e84f734
pkgname = jdk8
diff --git a/PKGBUILD b/PKGBUILD
index 743a307cb0a7..3114dda1ce6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,9 +21,9 @@ provides=("java-runtime=${_major}" "java-runtime-headless=${_major}" "java-web-s
"java-runtime-jre=${_major}" "java-runtime-headless-jre=${_major}" "java-web-start-jre=${_major}"
"java-openjfx=${_major}")
provides+=("java-environment-jdk=${_major}" "java-environment=${_major}")
-
# Variables
DLAGENTS=("${DLAGENTS[@]//curl -/curl -b 'oraclelicense=a' -}")
+
_jname="${_pkgname}${_major}"
_jvmdir="/usr/lib/jvm/java-${_major}-${_pkgname}"
@@ -44,27 +44,44 @@ backup=("etc/java-${_jname}/amd64/jvm.cfg"
"etc/java-${_jname}/sound.properties")
options=('!strip') # JDK debug-symbols
install="${pkgname}.install"
+_srcfil="${_pkgname}-${pkgver}-linux-x64.tar.gz"
source=(
"https://download.oracle.com/otn-pub/java/jce/${_major}/jce_policy-${_major}.zip"
- "https://download.oracle.com/otn-pub/java/jdk/${pkgver}-${_build}/${_hash}/${_pkgname}-${pkgver}-linux-x64.tar.gz"
+ "https://download.oracle.com/otn-pub/java/jdk/${pkgver}-${_build}/${_hash}/${_srcfil}"
"jconsole-${_jname}.desktop"
"jmc-${_jname}.desktop"
"jvisualvm-${_jname}.desktop"
"policytool-${_jname}.desktop"
+ 'readme.sh'
)
+# from oracle-sqldeveloper
+DLAGENTS+=("manual::${startdir:-}/readme.sh %o %u")
+source[1]="manual://${_srcfil}"
+if [ -s ~/"Downloads/${_srcfil}" ] && [ ! -e "${_srcfil}" ]; then
+ if type msg > /dev/null 2>&1; then
+ set +u
+ msg "Scooping files from ~/Downloads"
+ msg2 "${_srcfil}"
+ set -u
+ ln -sr ~/"Downloads/${_srcfil}"
+ fi
+fi
+unset _srcfil
md5sums=('b3c7031bc65c28c2340302065e7d00d3'
'62d57a7550c97b534343443475d9afd9'
'8a66f50efdc867ffd6a27168bc93b210'
'1cbde70639abd98db4bace284dbf2bc4'
'f0b39865361437f3778ecbe6ffbc0a06'
- '89704501aff8efe859c31968d8d168e6')
+ '89704501aff8efe859c31968d8d168e6'
+ '4dda444d58a4d78ca6357228adbde8a2')
sha256sums=('f3020a3922efd6626c2fff45695d527f34a8020e938a49292561f18ad1320b59'
'3160c50aa8d8e081c8c7fe0f859ea452922eca5d2ae8f8ef22011ae87e6fedfb'
'65282603bd0804d162f3f7da47bc7f3c91373e87504297d6a6fd6f2f8a1ec4ee'
'8f865b52946a9ab98556c56306c7e70ae7aa432b4d005c70df0bba9d2c3111b1'
'144e6651fcea08d95f3148d3a8ad17deb93fec4dd9236d37d27d7c648230b870'
- '635433e9c78ff58af65c316232ac9907d289a324428923788ea0f82ae7f8083b')
-#PKGEXT='.pkg.tar.gz'
+ '635433e9c78ff58af65c316232ac9907d289a324428923788ea0f82ae7f8083b'
+ 'd1b4b3161614d7620365a0528a86f7eec543de30ee756b1ad2dabd386e84f734')
+PKGEXT='.pkg.tar.gz' # much faster than .xz
## Alternative mirror, if your local one is throttled:
## Posting new sites does no good. They get taken down by the admin
## from too much traffic or complaints from Oracle.
diff --git a/readme.sh b/readme.sh
new file mode 100755
index 000000000000..b9aaf2237f82
--- /dev/null
+++ b/readme.sh
@@ -0,0 +1,15 @@
+#!/usr/bin/bash
+
+echo 'The source file for this package needs to be downloaded manually'
+echo 'since it requires a login and is not redistributable.'
+echo 'Please visit'
+echo ' https://www.oracle.com/technetwork/java/javase/downloads/'
+echo ' Java SE ... JDK, Download v'
+echo 'and download'
+echo " ${1%.part}"
+echo 'to your ~/Downloads folder or in with the PKGBUILD.'
+echo ''
+echo 'Please do not post alternate sources. They are not legal. Advertising'
+echo 'will get them taken down by Oracle or too much traffic. Keep it a'
+echo 'secret.'
+exit 1