summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--LICENSE22
-rw-r--r--PKGBUILD35
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..183c03ee5b3e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Wed Feb 3 10:18:40 UTC 2016
+pkgbase = jdupes-git
+ pkgdesc = jdupes is a program for identifying duplicate files residing within specified directories
+ pkgver = 1.0.1.r182.552dd62
+ pkgrel = 1
+ url = https://github.com/jbruchon/jdupes/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = glibc
+ provides = jdupes
+ conflicts = fdupes-jody-git
+ source = jdupes-git::git+https://github.com/jbruchon/jdupes.git
+ source = LICENSE
+ sha256sums = SKIP
+ sha256sums = ff95e2262ce1dd788e66c6c8763354e350a46044b8532d92146b7b03a319481a
+
+pkgname = jdupes-git
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..25684fd3b8de
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,22 @@
+jdupes is Copyright (C) 2015-2016 by Jody Bruchon
+Derived from the original 'fdupes' (C) 1999-2016 by Adrian Lopez
+Includes jody_hash (C) 2015-2016 Jody Bruchon <jody@jodybruchon.com>
+
+Permission is hereby granted, free of charge, to any person
+obtaining a copy of this software and associated documentation files
+(the "Software"), to deal in the Software without restriction,
+including without limitation the rights to use, copy, modify, merge,
+publish, distribute, sublicense, and/or sell copies of the Software,
+and to permit persons to whom the Software is furnished to do so,
+subject to the following conditions:
+
+The above copyright notice and this permission notice shall be
+included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
+OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
+TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f048d6b79bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Arnoud Willemsen <mail at lynthium dot com>
+
+pkgname=jdupes-git
+pkgver=1.0.1.r182.552dd62
+pkgrel=1
+pkgdesc="jdupes is a program for identifying duplicate files residing within specified directories"
+arch=('i686' 'x86_64')
+url="https://github.com/jbruchon/jdupes/"
+license=('MIT')
+depends=('glibc')
+provides=('jdupes')
+conflicts=('fdupes-jody-git')
+source=("${pkgname}::git+https://github.com/jbruchon/jdupes.git"
+ "LICENSE")
+sha256sums=('SKIP'
+ 'ff95e2262ce1dd788e66c6c8763354e350a46044b8532d92146b7b03a319481a')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ printf "%s.r%s.%s" "$(git describe --abbrev=0 --tags)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" | sed 's/^v//;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ make
+}
+
+package(){
+ cd "${srcdir}/${pkgname}"
+ install -d "${pkgdir}"/usr/{share/man/man1,bin}
+ make PREFIX="/usr" DESTDIR="${pkgdir}" install
+ install -D -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim: set ts=2 sw=2 et: