summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD35
-rw-r--r--jesc-configurator.desktop8
-rw-r--r--jesc-configurator.install4
4 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0fe7386c6832
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = jesc-configurator-bin
+ pkgdesc = Application for JESC BLHeli firmware flashing and configuration.
+ pkgver = 1.2.6
+ pkgrel = 1
+ url = https://github.com/jflight-public/jesc-configurator
+ install = jesc-configurator.install
+ arch = x86_64
+ license = GPL3
+ options = !strip
+ source = https://github.com/jflight-public/jesc-configurator/releases/download/v1.2.6/JESC-Configurator_linux64_1.2.6.zip
+ source = https://raw.githubusercontent.com/jflight-public/jesc-configurator/master/images/icon_128.png
+ source = https://raw.githubusercontent.com/jflight-public/jesc-configurator/master/LICENSE
+ source = jesc-configurator.desktop
+ sha256sums = 1620f6d932570f7ac333a8478501cf8af4204e0674c906110bec1be73f8cfc49
+ sha256sums = 0356279bd144225c42ad1605b02913ea013762d3de19e78e27281f966e4da947
+ sha256sums = SKIP
+ sha256sums = f514db9961d673825c381775fd0ef69e4a59ea0613d64b565a348c295be9fc19
+
+pkgname = jesc-configurator-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..75125cc9ac67
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: neo2001 <neo2001 at posteo dot net>
+
+pkgname=jesc-configurator-bin
+_pkgname=jesc-configurator
+pkgver=1.2.6
+pkgrel=1
+pkgdesc="Application for JESC BLHeli firmware flashing and configuration."
+arch=('x86_64')
+url="https://github.com/jflight-public/jesc-configurator"
+source=(
+"https://github.com/jflight-public/jesc-configurator/releases/download/v${pkgver}/JESC-Configurator_linux64_${pkgver}.zip"
+"https://raw.githubusercontent.com/jflight-public/jesc-configurator/master/images/icon_128.png"
+"https://raw.githubusercontent.com/jflight-public/jesc-configurator/master/LICENSE"
+"jesc-configurator.desktop"
+)
+
+sha256sums=('1620f6d932570f7ac333a8478501cf8af4204e0674c906110bec1be73f8cfc49'
+ '0356279bd144225c42ad1605b02913ea013762d3de19e78e27281f966e4da947'
+ '589ed823e9a84c56feb95ac58e7cf384626b9cbf4fda2a907bc36e103de1bad2'
+ '507f26e8e54f6097e43a9b9cb6de6d231393a4ce18308745a29e1a605ac77ec7')
+
+install="${_pkgname}.install"
+options=(!strip)
+license=('GPL3')
+#conflicts=('jesc-configurator')
+
+package() {
+ mkdir -p "${pkgdir}/opt/${_pkgname}"
+ mkdir -p "${pkgdir}/usr/bin"
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ install -Dm644 "${srcdir}/jesc-configurator.desktop" "${pkgdir}/usr/share/applications/jesc-configurator.desktop"
+ install -Dm644 "${srcdir}/icon_128.png" "${pkgdir}/opt/${_pkgname}/jesc_icon_128.png"
+ cp -r --preserve=all "${srcdir}/JESC Configurator/." "${pkgdir}/opt/${_pkgname}/"
+ ln -s "/opt/${_pkgname}/jesc-configurator" "${pkgdir}/usr/bin/jesc-configurator"
+}
diff --git a/jesc-configurator.desktop b/jesc-configurator.desktop
new file mode 100644
index 000000000000..7f9c536127ac
--- /dev/null
+++ b/jesc-configurator.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=JESC Configurator
+Comment=Application for JESC ESC firmware flashing and configuration.
+Exec=/opt/jesc-configurator/jesc-configurator
+Icon=/opt/jesc-configurator/jesc_icon_128.png
+Terminal=false
+Type=Application
+Categories=Utility;Electronics;RemoteAccess;
diff --git a/jesc-configurator.install b/jesc-configurator.install
new file mode 100644
index 000000000000..1ed1e6b54865
--- /dev/null
+++ b/jesc-configurator.install
@@ -0,0 +1,4 @@
+## arg 1: the new package version
+post_install() {
+ printf "\nVisit https://jflight.net, to purchase the required Telemetry licenses.\n\n"
+}