summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--CHANGELOG19
-rw-r--r--PKGBUILD6
3 files changed, 20 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28d88d58ce1f..d20820f2cb4e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = jetuml
pkgdesc = A desktop application for fast UML diagramming
- pkgver = 3.3
- pkgrel = 3
+ pkgver = 3.4
+ pkgrel = 0
url = https://github.com/prmr/JetUML
changelog = CHANGELOG
arch = any
@@ -9,10 +9,10 @@ pkgbase = jetuml
makedepends = gendesk
depends = java-runtime-openjdk=18
depends = java-openjfx
- noextract = JetUML-3.3.jar
- source = https://github.com/prmr/JetUML/releases/download/v3.3/JetUML-3.3.jar
- source = jetuml.png::https://raw.githubusercontent.com/prmr/JetUML/v3.3/icons/jet.png
- md5sums = e79f44d3983cacd57d71003b7a551ff3
+ noextract = JetUML-3.4.jar
+ source = https://github.com/prmr/JetUML/releases/download/v3.4/JetUML-3.4.jar
+ source = jetuml.png::https://raw.githubusercontent.com/prmr/JetUML/v3.4/icons/jet.png
+ md5sums = 901a95241b74c31e9e122fdc91719213
md5sums = 3b8e71028b14563205716aeb592e0803
pkgname = jetuml
diff --git a/CHANGELOG b/CHANGELOG
index 99bb88cf132f..40fdb92ce784 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,10 +1,13 @@
-# New Features and Improvements
-See the [User Guide](https://www.jetuml.org/docs/user-guide.html) for details.
+# New and Improved Features
-It is now possible to change the size of the text in diagrams (#426)
-Using the shortcut key combination Ctrl-Q inserts UML stereotype delimiters (#434)
-Field nodes in object diagrams have a tighter visual layout (#428)
+- This release features new layout algorithms for the class diagram (#375). The algorithms leverage a number of heuristics to keep diagram clears by avoiding overlap and edge crossings, while selecting intuitive-looking paths and more effective label placement (#446).
+- In sequence diagrams, we no longer delete the implicit parameter when a constructor call is deleted (#437);
-# Refactorings
-Node position is no longer stored as a property (#427)
-Enums are now used to define property values (#429)
+# Bug Fixes
+
+- Cannot select overlapped implicit parameters in sequence diagram (#438);
+- Drag package content to bottom of viewport. Subsequence dragging misbehaves (#445)
+- Code Refactorings
+- Refactor the PersistenceTests (#439)
+- Update Checkstyle style file to 8.44 (#440)
+- Code Modernization and Cleanup (#456). JetUML now runs on Java 17.
diff --git a/PKGBUILD b/PKGBUILD
index f417b397c51c..9758056ea2e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Bent Hillerkus <benthillerkus+aur@gmail.com>
-pkgrel=3
-pkgver=3.3
+pkgrel=0
+pkgver=3.4
pkgname=jetuml
_gitname=JetUML
@@ -19,7 +19,7 @@ makedepends=('gendesk')
source=("https://github.com/prmr/$_gitname/releases/download/v$pkgver/$_jarname.jar"
"$pkgname.png::https://raw.githubusercontent.com/prmr/$_gitname/v$pkgver/icons/$_iconname.png")
noextract=("$_jarname.jar")
-md5sums=('e79f44d3983cacd57d71003b7a551ff3'
+md5sums=('901a95241b74c31e9e122fdc91719213'
'3b8e71028b14563205716aeb592e0803')
prepare() {