summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD28
3 files changed, 28 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 179d01fd8e6e..e4e1a91bd740 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,25 @@
pkgbase = jfbview
pkgdesc = PDF and image viewer for the Linux framebuffer
pkgver = 0.6.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/jichu4n/jfbview
arch = i686
+ arch = pentium4
arch = x86_64
arch = armv6h
arch = armv7h
arch = aarch64
license = Apache
makedepends = cmake
- depends = ncurses
+ makedepends = git
+ depends = freetype2
+ depends = harfbuzz
depends = imlib2
depends = libjpeg-turbo
- conflicts = jfbpdf
- replaces = jfbpdf
- source = https://github.com/jichu4n/jfbview/releases/download/0.6.0/jfbview-0.6.0-full-source.zip
- md5sums = ac41da35a97c008424662d7dc489b841
+ depends = ncurses
+ depends = openjpeg2
+ depends = zlib
+ source = git+https://github.com/jichu4n/jfbview.git#tag=0.6.0
+ sha512sums = SKIP
pkgname = jfbview
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..aa4aab8fba57
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*/
+*.log
diff --git a/PKGBUILD b/PKGBUILD
index b17bda799350..2d1630d73354 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,26 @@
-# Maintainer: farseerfc <farseerfc@archlinuxcn.org>
-# Contributor: Chuan Ji <ji@chu4n.com>
+# Maintainer: Chuan Ji <chuan@jichu4n.com>
+# Contributor: farseerfc <farseerfc@archlinuxcn.org>
pkgname=jfbview
pkgver=0.6.0
-pkgrel=2
+pkgrel=3
pkgdesc="PDF and image viewer for the Linux framebuffer"
-arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
+arch=('i686' 'pentium4' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/jichu4n/jfbview"
license=('Apache')
-makedepends=('cmake')
-depends=('ncurses' 'imlib2' 'libjpeg-turbo')
-conflicts=('jfbpdf')
-replaces=('jfbpdf')
-source=("https://github.com/jichu4n/jfbview/releases/download/${pkgver}/jfbview-${pkgver}-full-source.zip")
-md5sums=('ac41da35a97c008424662d7dc489b841')
+makedepends=('cmake' 'git')
+depends=('freetype2' 'harfbuzz' 'imlib2' 'libjpeg-turbo' 'ncurses' 'openjpeg2' 'zlib')
+source=("git+${url}.git#tag=${pkgver}")
+sha512sums=('SKIP')
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ git submodule update --init --recursive
+}
build(){
- cd "${srcdir}/${pkgname}-${pkgver}-full-source"
+ cd "${srcdir}/${pkgname}"
+ LDFLAGS='-lImlib2' \
cmake -H. -Bbuild \
-DBUILD_TESTING=OFF \
-DCMAKE_BUILD_TYPE=Release \
@@ -25,7 +29,7 @@ build(){
}
package(){
- cd "${srcdir}/${pkgname}-${pkgver}-full-source/build"
+ cd "${srcdir}/${pkgname}/build"
make DESTDIR="${pkgdir}" install
}