summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
-rw-r--r--jflap-beta.desktop2
3 files changed, 20 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ed5ffbad521..4a83b96e6771 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,20 @@
pkgbase = jflap-beta
pkgdesc = Software for learning the basic concepts of Formal Languages and Automata Theory, latest version with custom SVG icon and GTK theming.
- pkgver = 8.0
- pkgrel = 3
- url = http://www.jflap.org/
+ pkgver = 7.1
+ pkgrel = 4
+ url = https://jflap.org/jflaptmp/
install = jflap.install
arch = any
license = CCPL
depends = java-runtime
- noextract = JFLAP8_beta.jar, JFLAP.jar
- source = http://www.jflap.org/jflaptmp/jan24-15/JFLAP8_beta.jar
+ noextract = JFLAP7.1.jar, JFLAP.jar
+ source = https://jflap.org/jflaptmp/july27-18/JFLAP7.1.jar
source = jflap-beta.sh
source = jflap-beta.desktop
source = swyter-jflap-icon.svg
- md5sums = 61f817d40e813176dc09b4aa0f5d6370
+ md5sums = 25a862c1dd2f07ffdb0ad602ab3ae2a0
md5sums = 2fc85ec1b403128a6e806ee42ecd3f51
- md5sums = d492591086c0d565bebaa5621777aa58
+ md5sums = 6e3534e28f17b79f99e59afca71bc29c
md5sums = 6925236e7c32342045a7ad1b31984cfb
pkgname = jflap-beta
-
diff --git a/PKGBUILD b/PKGBUILD
index c710b34cc466..9803d05b5a2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,31 @@
# Maintainers: TheConfuZzledDude, swyter, M0Rf30
pkgname=jflap-beta
-pkgver=8.0
-pkgrel=3
+pkgver=7.1
+pkgrel=4
pkgdesc="Software for learning the basic concepts of Formal Languages and Automata Theory, latest version with custom SVG icon and GTK theming."
arch=('any')
-url="http://www.jflap.org/"
+url="https://jflap.org/jflaptmp/"
license=('CCPL')
# conflicts=('')
depends=('java-runtime')
install=jflap.install
-# there's also the less complete v8.0 version: http://www.jflap.org/jflaptmp/jan24-15/JFLAP8_beta.jar
-source=('http://www.jflap.org/jflaptmp/jan24-15/JFLAP8_beta.jar'
+# swy: there's also the less complete (and older, from 2015) v8.0 version:
+# http://www.jflap.org/jflaptmp/jan24-15/JFLAP8_beta.jar
+source=("https://jflap.org/jflaptmp/july27-18/JFLAP${pkgver}.jar"
'jflap-beta.sh' 'jflap-beta.desktop' 'swyter-jflap-icon.svg')
-noextract=('JFLAP8_beta.jar, JFLAP.jar')
+noextract=('JFLAP7.1.jar, JFLAP.jar')
package()
{
#cd $srcdir
- install -Dm 644 'JFLAP8_beta.jar' "$pkgdir/opt/jflap-beta/JFLAP.jar"
- install -Dm 755 'jflap-beta.sh' "$pkgdir/usr/bin/jflap-beta"
- install -Dm 755 'jflap-beta.desktop' "$pkgdir/usr/share/applications/jflap-beta.desktop"
+ install -Dm 644 "JFLAP${pkgver}.jar" "$pkgdir/opt/jflap-beta/JFLAP.jar"
+ install -Dm 755 'jflap-beta.sh' "$pkgdir/usr/bin/jflap-beta"
+ install -Dm 755 'jflap-beta.desktop' "$pkgdir/usr/share/applications/jflap-beta.desktop"
install -Dm 644 'swyter-jflap-icon.svg' "$pkgdir/usr/share/icons/hicolor/scalable/apps/swyter-jflap-icon.svg"
}
-md5sums=('61f817d40e813176dc09b4aa0f5d6370'
+md5sums=('25a862c1dd2f07ffdb0ad602ab3ae2a0'
'2fc85ec1b403128a6e806ee42ecd3f51'
- 'd492591086c0d565bebaa5621777aa58'
+ '6e3534e28f17b79f99e59afca71bc29c'
'6925236e7c32342045a7ad1b31984cfb')
diff --git a/jflap-beta.desktop b/jflap-beta.desktop
index 3c9eac268613..184b14ced68b 100644
--- a/jflap-beta.desktop
+++ b/jflap-beta.desktop
@@ -1,6 +1,6 @@
[Desktop Entry]
Type=Application
-Name=JFLAP Beta
+Name=JFLAP (beta)
Comment=JFLAP is software for experimenting with formal languages topics including nondeterministic finite automata, nondeterministic pushdown automata, multi-tape Turing machines, several types of grammars, parsing, and L-systems.
Exec=jflap-beta
Icon=swyter-jflap-icon