summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD28
-rw-r--r--config1
-rw-r--r--service13
4 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d5d07868e178
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = jicofo
+ pkgdesc = JItsi Meet COnference FOcus
+ pkgver = 554
+ pkgrel = 1
+ url = https://github.com/jitsi/jicofo
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ makedepends = unzip
+ makedepends = maven
+ depends = java-runtime-headless
+ backup = etc/jicofo/jicofo.conf
+ source = jicofo-554.tar.gz::https://github.com/jitsi/jicofo/archive/554.tar.gz
+ source = service
+ source = config
+ sha256sums = e62e54a42046fd42ce00ada071a35b1982dded26b0e1faee779fd1d76afa913a
+ sha256sums = c1e17cf1de2274d375d08afee1853e1314d74763ec600b7bba740cfb7df09258
+ sha256sums = fea884f52b5c91b7514212d989fae36fd2113967c2617fae1b686ac6c774a7f8
+
+pkgname = jicofo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6dc75f1f39c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=jicofo
+pkgver=554
+pkgrel=1
+pkgdesc="JItsi Meet COnference FOcus"
+arch=("x86_64")
+url="https://github.com/jitsi/jicofo"
+license=("Apache")
+depends=("java-runtime-headless")
+makedepends=("git" "unzip" "maven")
+backup=("etc/jicofo/jicofo.conf")
+source=($pkgname-$pkgver.tar.gz::https://github.com/jitsi/jicofo/archive/${pkgver}.tar.gz
+ service config)
+sha256sums=('e62e54a42046fd42ce00ada071a35b1982dded26b0e1faee779fd1d76afa913a'
+ 'c1e17cf1de2274d375d08afee1853e1314d74763ec600b7bba740cfb7df09258'
+ 'fea884f52b5c91b7514212d989fae36fd2113967c2617fae1b686ac6c774a7f8')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ mvn package -DskipTests -Dassembly.skipAssembly=false
+ unzip -o target/jicofo-1.1-SNAPSHOT-archive.zip
+}
+
+package() {
+ install -d "${pkgdir}/opt"
+ cp -R "${srcdir}/${pkgname}-${pkgver}/jicofo-1.1-SNAPSHOT/" "${pkgdir}/opt/jicofo"
+ install -Dm644 service "$pkgdir"/usr/lib/systemd/system/jicofo.service
+ install -Dm644 config "$pkgdir"/etc/jicofo/jicofo.conf
+}
diff --git a/config b/config
new file mode 100644
index 000000000000..de0b6edd4184
--- /dev/null
+++ b/config
@@ -0,0 +1 @@
+flags="--host=localhost --domain=jitsi.example.com --secret=YOURSECRET2 --user_domain=auth.jitsi.example.com --user_name=focus --user_password=YOURSECRET3"
diff --git a/service b/service
new file mode 100644
index 000000000000..902fd8b5995c
--- /dev/null
+++ b/service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Jicofo
+Wants=network-online.target
+After=network-online.target
+
+[Service]
+Type=simple
+EnvironmentFile=/etc/jicofo/jicofo.conf
+ExecStart=/opt/jicofo/jicofo.sh ${flags}
+Restart=on-failure
+
+[Install]
+WantedBy=multi-user.target