summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD13
-rw-r--r--config17
-rw-r--r--install41
-rw-r--r--service2
-rw-r--r--sip-communicator.properties1
6 files changed, 34 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2035cf2a2f85..510f684531a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jicofo
pkgdesc = JItsi Meet COnference FOcus
- pkgver = 1.0.940
+ pkgver = 1.0.954
pkgrel = 1
url = https://jitsi.org/jitsi-meet/
install = install
@@ -16,18 +16,15 @@ pkgbase = jicofo
options = !strip
backup = etc/jicofo/config
backup = etc/jicofo/logging.properties
- backup = etc/jicofo/sip-communicator.properties
backup = etc/jicofo/jicofo.conf
- source = jicofo::git+https://github.com/jitsi/jicofo#tag=940
+ source = jicofo::git+https://github.com/jitsi/jicofo#tag=954
source = config
- source = sip-communicator.properties
source = service
source = sysusers.conf
source = tmpfiles.conf
sha256sums = SKIP
- sha256sums = f3928f382fbfd5bc40bd0c2a9553d2480b4fa7cf2fd04109257cdac535ed3d9f
- sha256sums = f295f5f8ee13edd019defc037c60e04c6ea2d30e69cc4a896c010b8570f5efab
- sha256sums = 21d9596eba7342cc02cb37f6c1bb651792e2c79df0374b4fd850e4fbad4cfaec
+ sha256sums = b69f9485ba55b53fe6d1a8b5e4a37c542641cb205c6f5c0b2cf89d236cc6b562
+ sha256sums = 0b28a97f02b21991c46e05a3546d466a73492c88218121e68aa3ea28f848091b
sha256sums = 0681e97ca1e06d8ea7bdec0a874c6fc7a6ea84628923005130cd444547a1b440
sha256sums = 9f6fb4759099feefaee6fd44cac5854401e58f7ce929949cbc3994faaa3487d3
diff --git a/PKGBUILD b/PKGBUILD
index 8a83f231c217..fa20511382f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Celogeek <arch-aur-f5d67e@celogeek.com>
_basename=jicofo
-_tag=940
-_version=1.0.940
+_tag=954
+_version=1.0.954
pkgname=${_basename}
pkgver=${_version}
@@ -22,13 +22,11 @@ options=('!strip')
backup=(
"etc/${pkgname}/config"
"etc/${pkgname}/logging.properties"
- "etc/${pkgname}/sip-communicator.properties"
"etc/${pkgname}/jicofo.conf"
)
source=(
"$pkgname::git+https://github.com/jitsi/jicofo#tag=${_tag}"
"config"
- "sip-communicator.properties"
"service"
"sysusers.conf"
"tmpfiles.conf"
@@ -59,15 +57,14 @@ package() {
sed -i 's@/var/log/jitsi@/var/log/'${pkgname}'@' "${CONFDIR}/logging.properties"
cd "$srcdir"
- install -Dm600 -t "${CONFDIR}" "config" "sip-communicator.properties"
+ install -Dm600 -t "${CONFDIR}" "config"
install -Dm644 "service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
install -Dm644 "sysusers.conf" "${pkgdir}/usr/lib/sysusers.d/$pkgname.conf"
install -Dm644 "tmpfiles.conf" "${pkgdir}/usr/lib/tmpfiles.d/$pkgname.conf"
}
sha256sums=('SKIP'
- 'f3928f382fbfd5bc40bd0c2a9553d2480b4fa7cf2fd04109257cdac535ed3d9f'
- 'f295f5f8ee13edd019defc037c60e04c6ea2d30e69cc4a896c010b8570f5efab'
- '21d9596eba7342cc02cb37f6c1bb651792e2c79df0374b4fd850e4fbad4cfaec'
+ 'b69f9485ba55b53fe6d1a8b5e4a37c542641cb205c6f5c0b2cf89d236cc6b562'
+ '0b28a97f02b21991c46e05a3546d466a73492c88218121e68aa3ea28f848091b'
'0681e97ca1e06d8ea7bdec0a874c6fc7a6ea84628923005130cd444547a1b440'
'9f6fb4759099feefaee6fd44cac5854401e58f7ce929949cbc3994faaa3487d3')
diff --git a/config b/config
index f559774cd4ea..2d50829b893b 100644
--- a/config
+++ b/config
@@ -1,21 +1,4 @@
# Jitsi Conference Focus settings
-# sets the host name of the XMPP server
-JICOFO_HOST=localhost
-
-# sets the XMPP domain (default: none)
-JICOFO_HOSTNAME=jitsi-meet.example.org
-
-# sets the XMPP domain name to use for XMPP user logins
-JICOFO_AUTH_DOMAIN=auth.jitsi-meet.example.org
-
-# sets the username to use for XMPP user logins
-JICOFO_AUTH_USER=focus
-
-# sets the password to use for XMPP user logins
-JICOFO_AUTH_PASSWORD=__PASSWORD_FOR_USER_focus@auth.jitsi-meet.example.org__
-
-# extra options to pass to the jicofo daemon
-JICOFO_OPTS=""
# adds java system props that are passed to jicofo (default are for home and logging config file)
JAVA_SYS_PROPS="\
diff --git a/install b/install
index 34bb78149a7e..7ba8ace045ef 100644
--- a/install
+++ b/install
@@ -1,20 +1,27 @@
+post_install() {
+ cat << __EOF__
+The configs are located here:
+ - /etc/jicofo
+__EOF__
+}
post_upgrade() {
-cat << __EOF__
-
-*** Warning: ***
-
-In order to uniformize all jitsi-meet package, we have changes the config directory from "/etc/jitsi/jicofo" to "/etc/jicofo".
-
-Please compare your old config with the new one and apply the changes. Do not blindy copy your old config!
-
-Jicofo don't need secret anymore.
-Please check the wiki: https://wiki.archlinux.org/index.php/Jitsi-meet
-
-You have to:
- - update jicofo config
- - update jicofo jicofo.conf with focus proxy
- - update prosody config for jicofo
- - run prosodyctl roster
-
+ cat <<__EOF__
+Jicofo config is now set in jicofo.conf.
+You need to set:
+jicofo {
+ xmpp: {
+ client: {
+ client-proxy: "focus.YOUR_DOMAIN"
+ xmpp-domain: "YOUR_DOMAIN"
+ domain: "auth.YOUR_DOMAIN"
+ username: "focus"
+ password: "FOCUS_PASSWORD"
+ }
+ trusted-domains: [ "recorder.YOUR_DOMAIN" ]
+ }
+ bridge: {
+ brewery-jid: "JvbBrewery@internal.auth.YOUR_DOMAIN"
+ }
+}
__EOF__
}
diff --git a/service b/service
index d901e530b349..c42b0870d196 100644
--- a/service
+++ b/service
@@ -6,7 +6,7 @@ After=network-online.target
Environment=PATH=/usr/lib/jvm/java-11-openjdk/bin:/bin:/usr/bin:/usr/local/bin
EnvironmentFile=/etc/jicofo/config
User=jicofo
-ExecStart=/usr/lib/jicofo/jicofo.sh --host=${JICOFO_HOST} --domain=${JICOFO_HOSTNAME} --user_name=${JICOFO_AUTH_USER} --user_domain=${JICOFO_AUTH_DOMAIN} ${JICOFO_OPTS}
+ExecStart=/usr/lib/jicofo/jicofo.sh ${JICOFO_OPTS}
WorkingDirectory=/var/lib/jicofo
StateDirectory=jicofo
StateDirectoryMode=0750
diff --git a/sip-communicator.properties b/sip-communicator.properties
deleted file mode 100644
index 8ee505952520..000000000000
--- a/sip-communicator.properties
+++ /dev/null
@@ -1 +0,0 @@
-org.jitsi.jicofo.BRIDGE_MUC=JvbBrewery@internal.auth.jitsi-meet.example.org