summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
-rw-r--r--config19
-rw-r--r--service2
4 files changed, 17 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 860039952f5c..05beb201c3e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = jitsi-videobridge-git
pkgdesc = Jitsi Meet Videobridge git build
- pkgver = 2.1+481+g114f91856
+ pkgver = 2.2+81+g99b20c621
pkgrel = 1
url = https://jitsi.org/jitsi-meet/
install = install
arch = any
license = Apache
- makedepends = java-environment
+ makedepends = git
+ makedepends = java-environment-openjdk=11
makedepends = unzip
makedepends = maven
- depends = java-runtime
+ depends = java-runtime-openjdk=11
depends = bash
optdepends = prosody
options = !strip
backup = etc/jitsi-videobridge-git/config
- backup = etc/jitsi-videobridge-git/log4j2.xml
backup = etc/jitsi-videobridge-git/logging.properties
backup = etc/jitsi-videobridge-git/sip-communicator.properties
backup = etc/jitsi-videobridge-git/jvb.conf
@@ -25,11 +25,10 @@ pkgbase = jitsi-videobridge-git
source = sysusers.conf
source = tmpfiles.conf
sha256sums = SKIP
- sha256sums = e60e7002db2d73da87b0399eb39973a91ea43d99ce6d8c20b75e5ed1090f5a5f
+ sha256sums = ce0b5f8bbbdf8a8eca1ba2e918447e13974ca26dc96558a6856df157417d67d2
sha256sums = cc9fbf77497bce3c9673b2d144928f11cdd0c0823940c2b60c8369a2f086b9b7
- sha256sums = f9fcbe1e297afb4bad27e2a9dc0fff60d16dd1d232086d793246ee5c2d9fed68
+ sha256sums = e5c2a0eaa67dc7cf0a97ba51c62d616d6b0acdb266218e9d53f9b877c335fe35
sha256sums = 998cbc64def56ab98080ff7150dd0913a5e10325cd2b038cf3db14baf8cb19fc
sha256sums = 54318c8c90b4b519b05f80a3241f0bae3da8a4478f68e47ba268355ff6ddf383
pkgname = jitsi-videobridge-git
-
diff --git a/PKGBUILD b/PKGBUILD
index f1efc092ed25..039a1a1eb058 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
# Maintainer: Celogeek <arch-aur-f5d67e@celogeek.com>
pkgname=jitsi-videobridge-git
-pkgver=2.1+481+g114f91856
+pkgver=2.2+81+g99b20c621
pkgrel=1
pkgdesc="Jitsi Meet Videobridge git build"
arch=('any')
url="https://jitsi.org/jitsi-meet/"
license=('Apache')
-depends=("java-runtime" "bash")
+depends=("java-runtime-openjdk=11" "bash")
optdepends=("prosody")
makedepends=(
- "java-environment"
+ "git"
+ "java-environment-openjdk=11"
"unzip" "maven"
)
options=('!strip')
backup=(
"etc/${pkgname}/config"
- "etc/${pkgname}/log4j2.xml"
"etc/${pkgname}/logging.properties"
"etc/${pkgname}/sip-communicator.properties"
"etc/${pkgname}/jvb.conf"
@@ -38,6 +38,8 @@ pkgver() {
build() {
cd "$pkgname"
+ export JAVA_HOME=/usr/lib/jvm/java-11-openjdk
+ export PATH=$JAVA_HOME/bin:$PATH
mvn clean
mvn package -DskipTests -Dassembly.skipAssembly=true install
mvn dependency:copy-dependencies -DincludeScope=runtime
@@ -57,10 +59,8 @@ package() {
install -Dm755 -t "${DESTDIR}" "jvb/resources/jvb.sh"
install -dm700 "${CONFDIR}"
- install -Dm600 -t "${CONFDIR}" "jvb/lib/logging.properties" "config/log4j2.xml" "config/callstats-java-sdk.properties"
+ install -Dm600 -t "${CONFDIR}" "jvb/lib/logging.properties"
install -Dm600 "jvb/src/main/resources/reference.conf" "${CONFDIR}/jvb.conf"
- sed -i 's@logs@/var/log/'$pkgname'@' "${CONFDIR}/log4j2.xml"
-
install -Dm644 "config/20-jvb-udp-buffers.conf" "${pkgdir}/etc/sysctl.d/${pkgname}.conf"
cd "$srcdir"
@@ -70,8 +70,8 @@ package() {
install -Dm644 "tmpfiles.conf" "${pkgdir}/usr/lib/tmpfiles.d/$pkgname.conf"
}
sha256sums=('SKIP'
- 'e60e7002db2d73da87b0399eb39973a91ea43d99ce6d8c20b75e5ed1090f5a5f'
+ 'ce0b5f8bbbdf8a8eca1ba2e918447e13974ca26dc96558a6856df157417d67d2'
'cc9fbf77497bce3c9673b2d144928f11cdd0c0823940c2b60c8369a2f086b9b7'
- 'f9fcbe1e297afb4bad27e2a9dc0fff60d16dd1d232086d793246ee5c2d9fed68'
+ 'e5c2a0eaa67dc7cf0a97ba51c62d616d6b0acdb266218e9d53f9b877c335fe35'
'998cbc64def56ab98080ff7150dd0913a5e10325cd2b038cf3db14baf8cb19fc'
'54318c8c90b4b519b05f80a3241f0bae3da8a4478f68e47ba268355ff6ddf383')
diff --git a/config b/config
index 77acd6d6d372..3b635d14375c 100644
--- a/config
+++ b/config
@@ -1,21 +1,5 @@
# Jitsi Videobridge settings
-# sets the XMPP domain (default: none)
-JVB_HOSTNAME=jitsi-meet.example.org
-
-# sets the hostname of the XMPP server (default: domain if set, localhost otherwise)
-JVB_HOST=
-
-# sets the port of the XMPP server (default: 5275)
-JVB_PORT=5347
-
-# sets the shared secret used to authenticate to the XMPP server
-JVB_SECRET=__PASSWORD_FOR_USER_jvb@auth.jitsi-meet.example.org__
-
-# extra options to pass to the JVB daemon
-JVB_OPTS="--apis=,"
-
-
# adds java system props that are passed to jvb (default are for home and logging config file)
JAVA_SYS_PROPS="\
-Dnet.java.sip.communicator.SC_HOME_DIR_LOCATION=/etc\
@@ -26,6 +10,3 @@ JAVA_SYS_PROPS="\
-Djava.util.prefs.userRoot=/var/lib/jitsi-videobridge-git\
"
-# JDK15
-# You can try this if you use JDK15
-# VIDEOBRIDGE_GC_TYPE=G1GC
diff --git a/service b/service
index a8684a3ee04a..b8de425194ef 100644
--- a/service
+++ b/service
@@ -3,6 +3,7 @@ Description=Jitsi-Meet Videobridge
After=network-online.target
[Service]
+Environment=PATH=/usr/lib/jvm/java-11-openjdk/bin:/bin:/usr/bin:/usr/local/bin
EnvironmentFile=/etc/jitsi-videobridge-git/config
User=jvb
ExecStart=/usr/lib/jitsi-videobridge-git/jvb.sh ${JVB_OPTS}
@@ -18,6 +19,7 @@ Restart=on-failure
RestartSec=2
SuccessExitStatus=143
+RestartPreventExitStatus=78
# more threads for this process
TasksMax=65000