summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a037e146bd1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = jmtpfs
+ pkgdesc = mtpfs with better support for Android
+ pkgver = 0.5
+ pkgrel = 1
+ url = http://research.jacquette.com/jmtpfs-exchanging-files-between-android-devices-and-linux/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = fuse
+ depends = libmtp
+ source = https://github.com/JasonFerrara/jmtpfs/archive/v0.5.tar.gz
+ sha256sums = c0cacc4751c586a3b2b0fcd9c98dae4810a5d44f3eb9d2870868a15eeb696883
+
+pkgname = jmtpfs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83e6448cea77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Philipp 'TamCore' B. <philipp [at] tamcore [dot] eu>
+pkgname=jmtpfs
+pkgver=0.5
+pkgrel=1
+license=('GPL3')
+pkgdesc="mtpfs with better support for Android"
+arch=('i686' 'x86_64')
+url="http://research.jacquette.com/jmtpfs-exchanging-files-between-android-devices-and-linux/"
+depends=('fuse' 'libmtp')
+source=("https://github.com/JasonFerrara/jmtpfs/archive/v${pkgver}.tar.gz")
+sha256sums=('c0cacc4751c586a3b2b0fcd9c98dae4810a5d44f3eb9d2870868a15eeb696883')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure CXXFLAGS=-lpthread --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}