summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD17
2 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b83ce4c958ca..2c3f7d75595d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = jointris
pkgdesc = Joinable tetris blocks with bombs
- pkgver = 0.14
+ pkgver = 0.32
pkgrel = 1
- url = https://www.efanomars.com/games/jointris
+ url = https://efanomars.com/games/jointris
arch = x86_64
+ arch = aarch64
license = GPL3
makedepends = cmake
- makedepends = gcc
makedepends = doxygen
makedepends = graphviz
makedepends = python
- depends = stmm-games
- depends = stmm-input
+ depends = stmm-games>=0.32
+ depends = stmm-input>=0.17
depends = gtkmm3
- source = https://efanomars.com/sources/jointris-0.14.tar.gz
- sha256sums = 8dd709cb201899ef6083fb9b2a0072b5f0bae56a0ec74fc2a7f3d61930f6b62a
+ source = https://efanomars.com/sources/jointris-0.32.tar.gz
+ sha256sums = e82c08a7a50639ef07446fab4bdcb7bd56421df2c03e25c9dfb63ab56ebc0c23
pkgname = jointris
diff --git a/PKGBUILD b/PKGBUILD
index 6bb92dfceb31..d08e58a2802a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,26 @@
# Maintainer: Stefano Marsili <efanomars@gmx.ch>
pkgname=jointris
-pkgver=0.14
+pkgver=0.32
pkgrel=1
pkgdesc="Joinable tetris blocks with bombs"
-url='https://www.efanomars.com/games/jointris'
-arch=('x86_64')
+url='https://efanomars.com/games/jointris'
+arch=('x86_64' 'aarch64')
license=('GPL3')
-depends=('stmm-games' 'stmm-input' 'gtkmm3')
-makedepends=('cmake' 'gcc' 'doxygen' 'graphviz' 'python')
+depends=(
+ 'stmm-games>=0.32'
+ 'stmm-input>=0.17'
+ 'gtkmm3')
+makedepends=('cmake' 'doxygen' 'graphviz' 'python')
optdepends=()
#provides=("jointris")
#replaces=("jointris")
#conflicts=("jointris")
-source=('https://efanomars.com/sources/jointris-0.14.tar.gz')
-sha256sums=('8dd709cb201899ef6083fb9b2a0072b5f0bae56a0ec74fc2a7f3d61930f6b62a')
+source=('https://efanomars.com/sources/jointris-0.32.tar.gz')
+sha256sums=('e82c08a7a50639ef07446fab4bdcb7bd56421df2c03e25c9dfb63ab56ebc0c23')
build() {
cd "${srcdir}/jointris"