summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bf86fcb10867
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = journal-notify
+ pkgdesc = Notify about journal log entries
+ pkgver = 0.0.8
+ pkgrel = 2
+ url = https://github.com/eworm-de/journal-notify
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = markdown
+ depends = libnotify
+ depends = systemd
+ depends = gnome-icon-theme
+ source = http://www.eworm.de/download/journal-notify/journal-notify-0.0.8.tar.xz
+ source = http://www.eworm.de/download/journal-notify/journal-notify-0.0.8.tar.xz.asc
+ sha256sums = a03cb460921ee6530929406c50e823ee6fab703b663433d038e91195d627f927
+ sha256sums = SKIP
+
+pkgname = journal-notify
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..62e2931139cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+
+pkgname=journal-notify
+pkgver=0.0.8
+pkgrel=2
+pkgdesc='Notify about journal log entries'
+arch=('i686' 'x86_64')
+url='https://github.com/eworm-de/journal-notify'
+depends=('libnotify' 'systemd' 'gnome-icon-theme')
+makedepends=('markdown')
+license=('GPL')
+source=("http://www.eworm.de/download/${pkgname}/${pkgname}-${pkgver}.tar.xz"{,.asc})
+validpgpkeys=('BD84DE71F493DF6814B0167254EDC91609BC9183')
+
+build() {
+ cd ${pkgname}-${pkgver}/
+
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}/
+
+ make DESTDIR="${pkgdir}" install
+}
+
+sha256sums=('a03cb460921ee6530929406c50e823ee6fab703b663433d038e91195d627f927'
+ 'SKIP')