summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8fd2e61201b3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = journal-watch-git
+ pkgdesc = Like journalctl -f but with username prefixed
+ pkgver = 7.91f43f4
+ pkgrel = 1
+ url = https://github.com/sandsmark/journal-watch
+ arch = x86_64
+ arch = i686
+ license = GPL2
+ makedepends = gcc
+ makedepends = git
+ depends = systemd-libs
+ source = git+https://github.com/sandsmark/journal-watch.git
+ md5sums = SKIP
+
+pkgname = journal-watch-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ec16c19e023
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+pkgname=journal-watch-git
+pkgver=7.91f43f4
+pkgrel=1
+pkgdesc='Like journalctl -f but with username prefixed'
+url='https://github.com/sandsmark/journal-watch'
+arch=('x86_64' 'i686')
+license=('GPL2')
+makedepends=('gcc' 'git')
+depends=('systemd-libs')
+source=("git+https://github.com/sandsmark/journal-watch.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd journal-watch
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd journal-watch
+ make
+}
+
+package() {
+ cd journal-watch
+ install -D -m4755 journal-watch -t "${pkgdir}/usr/bin"
+}