summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD43
-rw-r--r--joyce.desktop10
-rw-r--r--type_cast_fix.patch21
4 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..467e3c51dc6b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = joyce
+ pkgdesc = Emulates the Amstrad PCW on Unix
+ pkgver = 2.2.9
+ pkgrel = 1
+ url = http://www.seasip.info/Unix/Joyce/index.html
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = libpng
+ depends = libxml2
+ depends = sdl
+ source = http://www.seasip.info/Unix/Joyce/joyce-2.2.9.tar.gz
+ source = joyce.desktop
+ source = type_cast_fix.patch
+ sha256sums = 99fd200052c9ec1445fc1f4802c6276e1adecb3d714f469c6403fe78bb931a40
+ sha256sums = ac4f54be832ff4c3bf434f36c0b28298742b20e4b6051db0a66e57ba636c5a98
+ sha256sums = 8826963da9770c7fec014a477210febcc51cd7c72106b8a69bf45b59221fef0f
+
+pkgname = joyce
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a47950a05db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Thomas Ascher <thomas.ascher@gmx.at>
+# Contributor: Thomas Ascher <thomas.ascher@gmx.at>
+pkgname=joyce
+pkgrel=1
+pkgver=2.2.9
+pkgdesc="Emulates the Amstrad PCW on Unix"
+arch=('i686' 'x86_64')
+url="http://www.seasip.info/Unix/Joyce/index.html"
+license=('LGPL')
+depends=('libpng'
+ 'libxml2'
+ 'sdl')
+source=("http://www.seasip.info/Unix/Joyce/${pkgname}-${pkgver}.tar.gz"
+ "${pkgname}.desktop"
+ "type_cast_fix.patch")
+sha256sums=('99fd200052c9ec1445fc1f4802c6276e1adecb3d714f469c6403fe78bb931a40'
+ 'ac4f54be832ff4c3bf434f36c0b28298742b20e4b6051db0a66e57ba636c5a98'
+ '8826963da9770c7fec014a477210febcc51cd7c72106b8a69bf45b59221fef0f')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ patch -Np1 -i "${srcdir}/type_cast_fix.patch"
+ ./configure --prefix=/usr --enable-shared
+ make -j $(cat /proc/cpuinfo | grep processor | wc -l)
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}/" install
+ install -D -m644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+}
+
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
diff --git a/joyce.desktop b/joyce.desktop
new file mode 100644
index 000000000000..67269e07d7ec
--- /dev/null
+++ b/joyce.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Name=JOYCE
+Comment=Emulates the Amstrad PCW on Unix
+Exec=/usr/bin/xjoyce
+Icon=/usr/share/Joyce/pcw.bmp
+Terminal=false
+StartupNotify=false
+Categories=Application;Game;
diff --git a/type_cast_fix.patch b/type_cast_fix.patch
new file mode 100644
index 000000000000..c8478e9df405
--- /dev/null
+++ b/type_cast_fix.patch
@@ -0,0 +1,21 @@
+diff -crB joyce-2.2.9_pristine/bin/JoyceDaisy.cxx joyce-2.2.9/bin/JoyceDaisy.cxx
+*** joyce-2.2.9_pristine/bin/JoyceDaisy.cxx 2016-01-30 00:32:03.000000000 +0100
+--- joyce-2.2.9/bin/JoyceDaisy.cxx 2016-08-07 19:38:21.642374244 +0200
+***************
+*** 61,67 ****
+ // This is for the default "Prestige Pica 10" wheel
+ // It can be configured by editing joycehw.xml (no UI is provided, as
+ // it is very unlikely that one will be needed).
+! static unsigned char gl_wheel[128] =
+ {
+ '#', '.', '<', '[', '=', '9', '8', '7', // 00-07
+ '6', '5', '0', '4', '3', '2', '1', ',', // 08-0F
+--- 61,67 ----
+ // This is for the default "Prestige Pica 10" wheel
+ // It can be configured by editing joycehw.xml (no UI is provided, as
+ // it is very unlikely that one will be needed).
+! static char gl_wheel[128] =
+ {
+ '#', '.', '<', '[', '=', '9', '8', '7', // 00-07
+ '6', '5', '0', '4', '3', '2', '1', ',', // 08-0F
+