summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD91
-rw-r--r--changelog273
-rw-r--r--jsignpdf.desktop10
-rw-r--r--jsignpdf.pngbin20474 -> 0 bytes
-rw-r--r--jsignpdf.sh5
-rw-r--r--supplementary.tar.zstbin0 -> 223456 bytes
7 files changed, 338 insertions, 70 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d81cfa7f5347..0102a0aca476 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,26 @@
pkgbase = jsignpdf
- pkgdesc = Digital sign PDF files with X.509 certificates.
- pkgver = 1.6.4
+ pkgdesc = Digitally sign PDF files with X.509 certificates in GUI and CLI.
+ pkgver = 2.2.2
pkgrel = 1
url = http://jsignpdf.sourceforge.net/
+ changelog = changelog
arch = any
license = LGPL
license = MPL
+ license = CCPL
+ license = Apache
+ license = custom
depends = java-runtime>=8
- provides = jsignpdf
- source = https://downloads.sourceforge.net/project/jsignpdf/stable/JSignPdf%201.6.4/JSignPdf-1.6.4.zip
- source = jsignpdf.sh
- source = jsignpdf.png
- source = jsignpdf.desktop
- md5sums = a459876cba8e2d30abcf9baaf16ff986
- md5sums = 84b680dbdc61784f05d94a66a012c51d
- md5sums = 8ea58c7a94f615d15a5f736a9e0b100d
- md5sums = 8a242f0bc9cfda5f77f53f644d44000b
+ depends = bash
+ optdepends = hicolor-icon-theme: icon for launcher
+ optdepends = desktop-file-utils: MIME cache update
+ backup = usr/share/java/jsignpdf/conf/conf.properties
+ backup = usr/share/java/jsignpdf/conf/pkcs11.cfg
+ source = jsignpdf-2.2.2.zip::https://github.com/intoolswetrust/jsignpdf/releases/download/JSignPdf_2_2_2/JSignPdf-2.2.2.zip
+ source = jsignpdf_48.png::https://raw.githubusercontent.com/intoolswetrust/jsignpdf/master/distribution/doc/icon/iconverticons.com/signedpdf_48x48x32.png
+ source = jsignpdf_128.png::https://raw.githubusercontent.com/intoolswetrust/jsignpdf/master/distribution/doc/icon/iconverticons.com/signedpdf_128x128x32.png
+ md5sums = 7c66f5a9f5e7e35b601725414491a867
+ md5sums = a44ef91da28d94fb949e361d19adbbd5
+ md5sums = bf2d11e38c706fe183900cce1fab0e38
pkgname = jsignpdf
-
diff --git a/PKGBUILD b/PKGBUILD
index 7adb189690f9..f9318ede1532 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,52 +3,57 @@
#
pkgname=jsignpdf
-pkgver=1.6.4
+pkgver=2.2.2
+_releasedate="2023-08-14"
pkgrel=1
-pkgdesc="Digital sign PDF files with X.509 certificates."
+pkgdesc="Digitally sign PDF files with X.509 certificates in GUI and CLI."
arch=('any')
url="http://jsignpdf.sourceforge.net/"
-license=('LGPL' 'MPL')
-depends=('java-runtime>=8')
-provides=('jsignpdf')
-source=("https://downloads.sourceforge.net/project/jsignpdf/stable/JSignPdf%20${pkgver}/JSignPdf-${pkgver}.zip"
- "jsignpdf.sh"
- "jsignpdf.png"
- "jsignpdf.desktop")
-md5sums=('a459876cba8e2d30abcf9baaf16ff986'
- '84b680dbdc61784f05d94a66a012c51d'
- '8ea58c7a94f615d15a5f736a9e0b100d'
- '8a242f0bc9cfda5f77f53f644d44000b')
+license=('LGPL' 'MPL' 'CCPL' 'Apache' 'custom')
+depends=('java-runtime>=8'
+ 'bash')
+optdepends=('hicolor-icon-theme: icon for launcher'
+ 'desktop-file-utils: MIME cache update')
+source=(
+ ${pkgname}-${pkgver}.zip::"https://github.com/intoolswetrust/jsignpdf/releases/download/JSignPdf_${pkgver//./_}/JSignPdf-${pkgver}.zip"
+ jsignpdf_48.png::"https://raw.githubusercontent.com/intoolswetrust/jsignpdf/master/distribution/doc/icon/iconverticons.com/signedpdf_48x48x32.png"
+ jsignpdf_128.png::"https://raw.githubusercontent.com/intoolswetrust/jsignpdf/master/distribution/doc/icon/iconverticons.com/signedpdf_128x128x32.png"
+ supplementary.tar.zst)
+md5sums=('7c66f5a9f5e7e35b601725414491a867'
+ 'a44ef91da28d94fb949e361d19adbbd5'
+ 'bf2d11e38c706fe183900cce1fab0e38'
+ 'e45374c55c83559e1f66f09e8fd0cd1a')
+changelog=changelog
+backup=('usr/share/java/jsignpdf/conf/conf.properties'
+ 'usr/share/java/jsignpdf/conf/pkcs11.cfg')
+
+build() {
+ sed -i "s/<pkgver>/$pkgver/g" ${srcdir}/manpages/de/man1/*
+ sed -i "s/<pkgver>/$pkgver/g" ${srcdir}/manpages/man1/*
+ sed -i "s/<date>/$_releasedate/g" ${srcdir}/manpages/de/man1/*
+ sed -i "s/<date>/$_releasedate/g" ${srcdir}/manpages/man1/*
+}
package() {
- mkdir -p ${pkgdir}/usr/share/java/jsignpdf/
- cd ${srcdir}/${pkgname}-${pkgver}
- cp -R * ${pkgdir}/usr/share/java/jsignpdf/
- find ${pkgdir}/usr/share/java/jsignpdf/* -type f -exec chmod 644 {} \;
- find ${pkgdir}/usr/share/java/jsignpdf/* -type d -exec chmod 755 {} \;
- chown -R root.root ${pkgdir}/usr/share/java/jsignpdf/* || return 1
- # The executable script
- mkdir -p ${pkgdir}/usr/bin/
- install -Dm755 ${srcdir}/jsignpdf.sh \
- ${pkgdir}/usr/bin/jsignpdf || return 1
- # Force Java 8
- # sed -i 's@exec java@exec /usr/lib/jvm/java-8-openjdk/jre/bin/java@' \
- # ${pkgdir}/usr/bin/jsignpdf
- # .icon and .desktop files
- install -Dm644 ${srcdir}/jsignpdf.png \
- ${pkgdir}/usr/share/icons/hicolor/scalable/apps/jsignpdf.png || return 1
- install -Dm644 ${srcdir}/jsignpdf.desktop \
- ${pkgdir}/usr/share/applications/jsignpdf.desktop || return 1
- # Docs and License
- mkdir -p ${pkgdir}/usr/share/docs/${pkgname}
- mkdir -p ${pkgdir}/usr/share/license/${pkgname}
- cp ${pkgdir}/usr/share/java/jsignpdf/docs/ChangeLog.txt ${pkgdir}/usr/share/docs/${pkgname}/
- cp ${pkgdir}/usr/share/java/jsignpdf/docs/JSignPdf.pdf ${pkgdir}/usr/share/docs/${pkgname}/
- cp ${pkgdir}/usr/share/java/jsignpdf/docs/JSignPdf_signed.pdf ${pkgdir}/usr/share/docs/${pkgname}/
- cp ${pkgdir}/usr/share/java/jsignpdf/docs/ReleaseNotes.txt ${pkgdir}/usr/share/docs/${pkgname}/
- cp ${pkgdir}/usr/share/java/jsignpdf/docs/lgpl-2.1.txt ${pkgdir}/usr/share/license/${pkgname}/
- cp ${pkgdir}/usr/share/java/jsignpdf/docs/MPL-1.1.txt ${pkgdir}/usr/share/license/${pkgname}/
- cp -R ${pkgdir}/usr/share/java/jsignpdf/docs/ThirdPartyLicenses/ ${pkgdir}/usr/share/license/${pkgname}/
- # Removing unneeded files
- rm -rf ${pkgdir}/usr/share/java/jsignpdf/docs/ || return 1
+ ## file and directory permissions for mv and cp: u=rwx,g=rx,o=rx
+ umask 022
+ ## licenses
+ install -d "${pkgdir}"/usr/share/licenses/"${pkgname}"
+ mv "${srcdir}/${pkgname}-${pkgver}"/licenses/ThirdPartyLicenses/* "${pkgdir}"/usr/share/licenses/"${pkgname}"
+ ## documentation
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}"/docs/JSignPdf.pdf "${pkgdir}"/usr/share/doc/"${pkgname}"/Quickstart.pdf
+ #install -Dm644 "${srcdir}/${pkgname}-${pkgver}"/docs/ReleaseNotes.txt "${pkgdir}"/usr/share/doc/"${pkgname}"/ReleaseNotes
+ install -d "${pkgdir}"/usr/share/man
+ mv "${srcdir}"/manpages/* "${pkgdir}"/usr/share/man
+ ## programm files
+ install -Dm644 "${srcdir}"/pictures/splash1.png "${pkgdir}"/usr/share/java/"${pkgname}"/splash.png
+ rm -r "${srcdir}/${pkgname}-${pkgver}"/docs
+ mv "${srcdir}/${pkgname}-${pkgver}"/* "${pkgdir}"/usr/share/java/"${pkgname}"
+ ## executable scripts
+ install -Dm755 "${srcdir}"/launchers/jsignpdf.sh "${pkgdir}"/usr/bin/jsignpdf
+ install -Dm755 "${srcdir}"/launchers/jsignpdf-installcert.sh "${pkgdir}"/usr/bin/jsignpdf-installcert
+ ## .icon and .desktop files
+ install -Dm644 "${srcdir}"/jsignpdf_48.png "${pkgdir}"/usr/share/icons/hicolor/48x48/apps/"${pkgname}".png
+ install -Dm644 "${srcdir}"/jsignpdf_128.png "${pkgdir}"/usr/share/icons/hicolor/128x128/apps/"${pkgname}".png
+ install -Dm644 "${srcdir}"/launchers/jsignpdf.desktop "${pkgdir}"/usr/share/applications/"${pkgname}".desktop
}
diff --git a/changelog b/changelog
new file mode 100644
index 000000000000..8a90b8fc235c
--- /dev/null
+++ b/changelog
@@ -0,0 +1,273 @@
+Version 2.2.1 + 2.2.2
+-------------
+ * Custom OpenPdf build replaced by the official one which should contain all the previous customizations
+ * JRE update in Windows installers
+ * New and updated translations
+ * Thanks all the contributors!
+
+Version 2.2.0
+-------------
+ * Added QPIN support in JSignPKCS11 provider (i.e. using two different PINs in newer hardware tokens)
+ * Added ECDSA signature algorithm support
+ * Added command line argument --gui for partial settings from the command line (beta feature)
+ * Bug fixes and translation updates; Thanks all the contributors!
+
+Version 2.1.0
+-------------
+ * Extended L2 text options with DN (${certificate}) and custom signer name (-sn, --signer-name)
+ * Drag&drop and output filename suggestion
+ * Spanish and Norwegian translations (through Weblate)
+ * Fixed ClassCastException in OpenPDF
+ * Updated project dependencies
+
+Version 2.0.0
+-------------
+ * Added JSignPKCS11 security provider
+ * Moved from a self-managed iText fork (jsign-itxt) to OpenPDF
+ * Updated project dependencies
+ * Removed log4j dependency
+
+Version 1.6.5
+-------------
+ * Fix SunPKCS11 initialization on newer Java versions
+ * Add bash startup script
+
+Version 1.6.4
+-------------
+ * Integration with FoxyProxy (https://gitlab.com/cloudfoxy/foxyproxy) for (eIDAS) external signatures
+ * Upgrade Java runtime in Windows distributions to Java 8 (u181)
+
+Version 1.6.3
+-------------
+ * Allow loading truststore specified by "javax.net.ssl.trustStore" System property
+
+Version 1.6.2
+-------------
+ * BouncyCastle library updated to version 1.49 (due to http://www.bouncycastle.org/jira/browse/BJA-351)
+
+Version 1.6.1
+-------------
+ * page number out of the range means the last page in the visible signatures (contrary to the first one used in previous versions)
+
+Version 1.6.0
+-------------
+ * Added support for changing TSA hash algorithm - default value can be configured in conf/conf.properties
+ - new GUI input field added to TSA configuration dialog
+ - new CLI option "-tsh" added to batch mode
+
+Version 1.5.4
+-------------
+ * No code change!
+ * Recompiled 1.5.3 - a wrong jsignpdf-itxt library version was used there (=> Broken TSA support)
+
+Version 1.5.3
+-------------
+ * Fixed PKCS11 - It didn't work in GUI because of a bug in unregistering SunPKCS11 provider (It was called too early.)
+ * Verifier - added exit code 10 when no signature field is present in the PDF
+
+Version 1.5.2
+-------------
+ * Exit codes and usage of -ff option fixed in Verifier
+ * Disable fallbacks for key alias lookup in JSignPdf. Originally if the alias name was given
+ and the alias didn't exist in the keystore, then the first key in the selected keystore was used.
+
+Version 1.5.1
+-------------
+ * Added support for signature field placeholders in custom signature text (L2 text). Possible values are
+ - ${signer}
+ - ${timestamp}
+ - ${location}
+ - ${reason}
+ - ${contact}
+
+Version 1.5.0
+-------------
+ * Improved Preview functionality
+ * Fixed certificates handling in signature verification - make the OCSP verification more robust
+
+Version 1.4.5
+-------------
+ * Fixed non-working --crl option when using CLI (batch mode)
+
+Version 1.4.4
+-------------
+ * Newly registered SunPKCS11 security provider is removed at the end of the program
+ (to avoid hangs in accessing security tokens second time)
+
+Version 1.4.3
+-------------
+ * Fixed NullPointerException occuring when signing encrypted PDFs in batch mode
+
+Version 1.4.2
+-------------
+ * Fixed signing of password protected PDFs
+
+Version 1.4.1
+-------------
+ * CLI improvements and bug-fixes for TSA authentication
+
+Version 1.4.0
+-------------
+ * certificate based encryption
+ * certificate based authentication (TSA servers)
+ * GUI components visibility improved
+ * Greek translation from Vassilis Michalitsis
+
+Version 1.3.0
+-------------
+ * reporting (status messages) are logged by Log4J appenders
+ * GUI components visibility improved (e.g. for WINDOWS-MY keystore)
+ * wildcard (*,?) support in PDF names when using batch signing
+ * Updated dependencies (Java runtime for Windows version 6u30, Apache commons libraries)
+ * Mac OS X test support (dmg)
+ * documentation updates
+
+Version 1.2.6
+-------------
+ * fixed bug in handling CLI option "-pr DISALLOW_PRINTING"
+
+Version 1.2.5
+-------------
+ * fix for removing existing signatures
+
+Version 1.2.4
+-------------
+ * Verifier and SignatureCounter tools description added to documentatio
+ * SignatureCounter exit codes improved in CLI (codes described in documentation)
+ * Verifier updates for OCSP validation
+ * signing fails if PDF version update is not possible (prints only an eror message)
+
+Version 1.2.3
+-------------
+ * fix signatures "append mode" processing in command-line version
+
+Version 1.2.2
+-------------
+ * program exit codes improved in CLI (codes described in documentation)
+
+Version 1.2.1
+-------------
+ * updated French translation (David Ruelle)
+ * fixed handling of misconfigured keystore
+ * chapter "Changing the application language" added to the documentation
+
+Version 1.2.0
+-------------
+ * added French (David Ruelle) and Polish (Zbig Wittmann) translations
+ * contact field can be specified from command line
+ * other improvements introduced in beta versions (see for 1.1.9, 1.1.10)
+
+Version 1.1.10 test (1.2.0 beta2)
+--------------
+ * Bigger Verifier improvements (from A. Stojsavljevic)
+ * new command line tool added: SignatureCounter
+ * fixed wrong spelling of RenderMode.DESCRIPTION_ONLY enum instance (thanks to Jiri Lisicky for reporting)
+
+Version 1.1.9 test (1.2.0 beta)
+-------------
+ * Support for PKCS11 initialization (additional configuration in conf.properties)
+ * Verifier improvements
+ * Added option to control which layers will be generated in visible signature (Acrobat 6 layer mode)
+ * Font size setting applied also for "Signature name and description" display mode as a maximal allowed size
+ * Java Runtime Environment update (6u24)
+ * setting default OCSP server URL
+
+Version 1.1.1
+-------------
+ * checking known critical extensions is disabled by default in conf.properties
+ * added some "well-known" certificate critical extension OIDs
+ * created l4j.ini files for exe launchers - JRE options are configurable now
+
+Version 1.1.0
+-------------
+ * fine grained control of certificate display through conf.properties file
+ * support for setting custom Policy OID in TSA requests
+ * fixed setting hash algorithm from command line
+
+Version 1.0.3
+-------------
+ * additional windows launchers JSignPdfC.exe and Verify.exe
+ * Append mode is the default for not-encrypted PDF documents
+ * added previous/next buttons for changing the page in PDF preview window
+ * fixed page numbering in PDF preview
+
+Version 1.0.2
+-------------
+ * added command line option --load-properties-file (-lpf) added
+ * embedded JRE for Windows (Java 6, 32-bit)
+ * improvements of Install Cert Tool
+
+Version 1.0.1
+-------------
+ * fixes keystore handling in simple view
+
+Version 1.0.0
+-------------
+ * implements PDF preview & selecting position of visible signature using mouse
+ * adds support for Certificate Revocation Lists (CRL)
+ * provides support for selecting hash algorithm (depends on cryptographic provider for selected keystore type)
+ * adds keystore types provided by BouncyCastle cryptographic library
+ * checks if a certificates are valid and if they're intended for signing
+ * includes proxy support for TSA, OCSP and CRL
+ * font used in visible signatures can be changed (using conf/conf.properties file)
+ * fixes removing old signatures in non-append mode
+ * fixes embedding font of visible signature if the input PDF is in version 1.2
+ * adds tool for installing trusted certificate to default Java keystore (InstallCert Tool)
+
+Version 0.9.8
+-------------
+ * output prefix and suffix can be empty in batch mode - can use the same filename if output goes to different directory
+
+Version 0.9.7 (bugfix release)
+-------------
+ * fixes password handling in simple view (caused *KeyException for PKCS#12 keystores)
+ * Output PDF filename field can be left empty in a GUI, then is automatically used the value from Input PDF suffixed with "_signed" (e.g. test.pdf->test_signed.pdf)
+
+Version 0.9.6
+-------------
+ * it's version 0.9.5 with small fixes
+ * TSA & OCSP command line switches
+
+Version 0.9.5 (not public)
+-------------
+ * support for timestamp server
+ * OCSP support
+ * Contact field added
+ * fix non-unique key aliases in WINDOWS-MY keystore
+ * improvements in command-line version:
+ - possibility to load default property file (-lp parameter)
+ - selecting key by index (e.g. because of national character in key alias, -ki parameter)
+
+Version 0.9
+-------------
+ * embedded Unicode font for Layer 2 texts in visible signature (fix for i18n and PDF/A specification)
+ * additional option for setting font size in visible signature
+
+Version 0.8
+-------------
+ * command line support (batch mode)
+ * upgraded libraries (iText 2.1.5, Apache Commons CLI 1.2)
+ * new launcher for windows with splash screen (using launch4j)
+ * bug fixies
+
+Version 0.7
+-------------
+ * support for visible signatures
+
+Version 0.5.1
+-------------
+ * fix for Java 5 (version 0.5 used feature available only in Java 6)
+
+Version 0.5
+-----------
+ * support for PDF security (encryption, rights)
+ * certification level support
+ * "append signature" support
+ * windows installer (with bundled JRE)
+
+Version 0.2
+-----------
+ * initial release
+ * Adding digitally signatures to (not encrypted) PDFs
+ * OpenOffice.org Add-On
+ * Swing UI
diff --git a/jsignpdf.desktop b/jsignpdf.desktop
deleted file mode 100644
index f3db848ed255..000000000000
--- a/jsignpdf.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Terminal=false
-Exec=jsignpdf
-Icon=/usr/share/icons/hicolor/scalable/apps/jsignpdf.png
-Type=Application
-Categories=Application;Office
-StartupNotify=false
-Name=JSignPdf
-Comment=Digital sign PDF files with X.509 certificates
diff --git a/jsignpdf.png b/jsignpdf.png
deleted file mode 100644
index 77ea122ac271..000000000000
--- a/jsignpdf.png
+++ /dev/null
Binary files differ
diff --git a/jsignpdf.sh b/jsignpdf.sh
deleted file mode 100644
index b772ae258e1d..000000000000
--- a/jsignpdf.sh
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-PROGDIR=/usr/share/java/jsignpdf/
-IFS='
-'
-exec java -cp $PROGDIR -jar $PROGDIR/JSignPdf.jar $*
diff --git a/supplementary.tar.zst b/supplementary.tar.zst
new file mode 100644
index 000000000000..b8b0ce6e4374
--- /dev/null
+++ b/supplementary.tar.zst
Binary files differ