summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..84d7ec1aed68
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = jsimugate
+ pkgdesc = Simulate standard logic and more
+ pkgver = 0.70
+ pkgrel = 1
+ url = https://github.com/innovation-plantation/jsimugate
+ arch = any
+ license = MIT
+ makedepends = gendesk
+ depends = java-environment>=8
+ depends = bash
+ source = jsimugate-0.70.tar.gz::https://github.com/innovation-plantation/jsimugate/archive/0.70.tar.gz
+ sha256sums = 37a217c4d775b00565c8a5c5808dd83d13399da64f626e19a8773a81d6c08f76
+
+pkgname = jsimugate
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..27c667d42a3a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=jsimugate
+pkgver=0.70
+pkgrel=1
+pkgdesc='Simulate standard logic and more'
+arch=('any')
+url="https://github.com/innovation-plantation/jsimugate"
+license=('MIT')
+depends=('java-environment>=8' 'bash')
+makedepends=('gendesk')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/innovation-plantation/jsimugate/archive/${pkgver}.tar.gz")
+sha256sums=('37a217c4d775b00565c8a5c5808dd83d13399da64f626e19a8773a81d6c08f76')
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ install -Dm644 jsimugate.jar "${pkgdir}/usr/share/java/${pkgname}/${pkgname}-${pkgver}.jar"
+ echo "#!/usr/bin/env bash
+ java -jar /usr/share/java/${pkgname}/${pkgname}-${pkgver}.jar \$\@" > jsimugate.sh
+ install -Dm755 jsimugate.sh "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 src/jsimugate/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 classes/artifacts/jsimugate_jar/innovation-plantation.png "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ gendesk -f -n --pkgname "${pkgname}" \
+ --pkgdesc "$pkgdesc" \
+ --name "jSimuGate" \
+ --comment "$pkgdesc" \
+ --exec "${pkgname}" \
+ --categories 'Utility;Application;' \
+ --icon "${pkgname}"
+ install -Dm644 "${pkgname}.desktop" -t "${pkgdir}/usr/share/applications"
+} \ No newline at end of file