summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7faeadb541f5..a1669e6c0353 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,12 @@
pkgbase = json-simple
pkgdesc = JSON.simple - Simple, fast, extensible JSON encoder/decoder for Java
- pkgver = 1.1.1
- pkgrel = 2
- url = http://code.google.com/p/json-simple
- arch = i686
- arch = x86_64
+ pkgver = 4.0.0
+ pkgrel = 1
+ url = https://cliftonlabs.github.io/json-simple/
+ arch = any
license = APACHE
depends = java-runtime
- source = https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/json-simple/json-simple-1.1.1.jar
- sha1sums = 5d6f9b6a9ddca2a28c0216cc44efb2e20d9c23b5
+ source = https://cliftonlabs.github.io/json-simple/target/json-simple-4.0.0.jar
+ sha256sums = e8001c79a89dae597ec3e5cce480a81c7ff3773d6f62a7861288e90c67eb361c
pkgname = json-simple
-
diff --git a/PKGBUILD b/PKGBUILD
index 296c24da94f7..c6efa1ed645f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Xunhua Guo <xunhua.guo@gmail.com>
pkgname=json-simple
-pkgver=1.1.1
-pkgrel=2
+pkgver=4.0.0
+pkgrel=1
pkgdesc="JSON.simple - Simple, fast, extensible JSON encoder/decoder for Java"
-arch=('i686' 'x86_64')
-url='http://code.google.com/p/json-simple'
+arch=("any")
+url="https://cliftonlabs.github.io/json-simple/"
license=('APACHE')
depends=('java-runtime')
-source=("https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/${pkgname}/${pkgname}-${pkgver}.jar")
-sha1sums=('5d6f9b6a9ddca2a28c0216cc44efb2e20d9c23b5')
+source=("https://cliftonlabs.github.io/json-simple/target/${pkgname}-${pkgver}.jar")
+sha256sums=('e8001c79a89dae597ec3e5cce480a81c7ff3773d6f62a7861288e90c67eb361c')
package() {
install -d -m755 "${pkgdir}/usr/share/java/${pkgname}/"