summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 15 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b4bc76784f53..fa2d0ff4e5f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Dec 20 08:11:50 UTC 2015
+# Sun Dec 20 08:23:29 UTC 2015
pkgbase = jucipp-git
pkgdesc = A lightweight platform-independent C++ IDE
pkgver = r1134.0837f6c
@@ -16,9 +16,13 @@ pkgbase = jucipp-git
depends = clang
depends = aspell
source = jucipp::git+https://github.com/cppit/jucipp.git
+ source = git+https://github.com/cppit/libclangmm.git
+ source = git+https://github.com/eidheim/tiny-process-library
source = CMakeLists.patch
sha1sums = SKIP
sha1sums = SKIP
+ sha1sums = SKIP
+ sha1sums = 64ac5afbe9a3a8b92cc3001897529834cda501a5
pkgname = jucipp-git
diff --git a/PKGBUILD b/PKGBUILD
index c70f96e04f43..c600ada6d807 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,8 +13,11 @@ license=('MIT')
depends=('gtksourceviewmm' 'clang' 'aspell')
makedepends=('git' 'cmake' 'pkg-config' 'boost')
-source=("$_pkgbase::git+https://github.com/cppit/jucipp.git" "CMakeLists.patch")
-sha1sums=('SKIP' 'SKIP')
+source=("$_pkgbase::git+https://github.com/cppit/jucipp.git"
+ "git+https://github.com/cppit/libclangmm.git"
+ "git+https://github.com/eidheim/tiny-process-library"
+ "CMakeLists.patch")
+sha1sums=('SKIP' 'SKIP' 'SKIP' '64ac5afbe9a3a8b92cc3001897529834cda501a5')
pkgver() {
cd "$srcdir/$_pkgbase"
@@ -23,7 +26,11 @@ pkgver() {
prepare() {
cd "$srcdir/$_pkgbase"
- git submodule update --init
+
+ git submodule init
+ git config submodule.libclangmm.url "$srcdir/libclangmm"
+ git config submodule.tiny-process-library.url "$srcdir/tiny-process-library"
+ git submodule update
git apply "$srcdir/CMakeLists.patch"
mkdir -p build