summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD4
-rw-r--r--jupyter_stata_kernel.install11
3 files changed, 13 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 273bfa89e454..765b839b7904 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,6 +3,7 @@ pkgbase = jupyter_stata_kernel
pkgver = 1.10.5
pkgrel = 1
url = https://kylebarron.github.io/stata_kernel/
+ install = jupyter_stata_kernel.install
arch = any
license = GPL3
makedepends = python-setuptools
diff --git a/PKGBUILD b/PKGBUILD
index bd956fd963fa..e42120d20323 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,6 +15,7 @@ url="https://kylebarron.github.io/stata_kernel/"
license=('GPL3')
source=("https://files.pythonhosted.org/packages/67/86/5979c2b683851f9e6a0a672ceaee3171fe7e18e152554deb0d62101c9879/stata_kernel-1.10.5.tar.gz")
sha256sums=('a57d8520c4aa9c5dfc625033bdfe3530a155a60e2e54c7c39065cb971c1b7c98')
+install=jupyter_stata_kernel.install
package() {
cd "${srcdir}/${_pyname}-${pkgver}"
@@ -23,6 +24,3 @@ package() {
install -Dm 644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README"
}
-post_install() {
- python -m stata_kernel.install
-}
diff --git a/jupyter_stata_kernel.install b/jupyter_stata_kernel.install
new file mode 100644
index 000000000000..c743c805c910
--- /dev/null
+++ b/jupyter_stata_kernel.install
@@ -0,0 +1,11 @@
+post_install() {
+ python3 -m stata_kernel.install
+}
+
+post_upgrade() {
+ python -m stata_kernel.install
+}
+
+post_remove() {
+ jupyter kernelspec uninstall stata -f
+}