summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..121408954763
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = jupyterlab
+ pkgdesc = JupyterLab computational environment
+ pkgver = 0.13.1
+ pkgrel = 1
+ url = https://github.com/jupyterlab/jupyterlab
+ arch = any
+ license = custom
+ depends = jupyter-notebook
+ source = jupyterlab-0.13.1::https://github.com/jupyterlab/jupyterlab/archive/v0.13.1.tar.gz
+ sha256sums = 4d95b6ef7383e747a1c24cf417c8397916ec4c44e11d371fb55b8441355fb8f7
+
+pkgname = jupyterlab
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9bc88b64399
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Antonio Rojas <arojas@archlinux.org>
+
+pkgname=jupyterlab
+pkgver=0.13.1
+pkgrel=1
+pkgdesc="JupyterLab computational environment"
+arch=(any)
+url="https://github.com/jupyterlab/jupyterlab"
+license=(custom)
+depends=(jupyter-notebook)
+source=($pkgname-$pkgver::"https://github.com/jupyterlab/jupyterlab/archive/v$pkgver.tar.gz")
+sha256sums=('4d95b6ef7383e747a1c24cf417c8397916ec4c44e11d371fb55b8441355fb8f7')
+
+build() {
+ cd $pkgname-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd $pkgname-$pkgver
+ python setup.py install --skip-build --root="$pkgdir" --optimize=1
+
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}