summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b9d71d38541..a28fb94b5683 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
+# Generated by mksrcinfo v8
+# Fri Mar 23 18:22:12 UTC 2018
pkgbase = jupyterlab
pkgdesc = JupyterLab computational environment
- pkgver = 0.31.10
+ pkgver = 0.31.12
pkgrel = 1
url = https://github.com/jupyterlab/jupyterlab
arch = any
license = custom
depends = jupyterlab_launcher
- source = jupyterlab-0.31.10.tar.gz::https://github.com/jupyterlab/jupyterlab/archive/v0.31.10.tar.gz
- sha256sums = 448393b9d36fe4178e66d33e246905ce7a2737aba93a069e71b8029ca1e3816e
+ source = jupyterlab-0.31.12.tar.gz::https://github.com/jupyterlab/jupyterlab/archive/v0.31.12.tar.gz
+ sha256sums = cc42993203d318e76af28759cb84dc9ce96aa779bca4e2059d0e841e25ea861d
pkgname = jupyterlab
diff --git a/PKGBUILD b/PKGBUILD
index fe3a89b50149..22d58cebc902 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,5 @@
-# Maintainer: Antonio Rojas <arojas@archlinux.org>
-
pkgname=jupyterlab
-pkgver=0.31.10
+pkgver=0.31.12
pkgrel=1
pkgdesc="JupyterLab computational environment"
arch=(any)
@@ -9,7 +7,7 @@ url="https://github.com/jupyterlab/jupyterlab"
license=(custom)
depends=(jupyterlab_launcher)
source=($pkgname-$pkgver.tar.gz::"https://github.com/jupyterlab/jupyterlab/archive/v$pkgver.tar.gz")
-sha256sums=('448393b9d36fe4178e66d33e246905ce7a2737aba93a069e71b8029ca1e3816e')
+sha256sums=('cc42993203d318e76af28759cb84dc9ce96aa779bca4e2059d0e841e25ea861d')
build() {
cd $pkgname-$pkgver
@@ -21,4 +19,8 @@ package() {
python setup.py install --skip-build --root="$pkgdir" --optimize=1
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+
+ # symlink to fix assets
+ install -d "$pkgdir"/usr/share/jupyter
+ ln -s "$pkgdir"/usr/lib/python3.6/site-packages/jupyterlab "$pkgdir"/usr/share/jupyter/lab
}