summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD25
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f6ce8d9aeaec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = jupyterlab-desktop-bin
+ pkgdesc = JupyterLab desktop application, based on Electron.
+ pkgver = 3.2.1
+ pkgrel = 1
+ url = https://github.com/jupyterlab/jupyterlab-desktop
+ arch = x86_64
+ license = MIT
+ source = https://github.com/jupyterlab/jupyterlab-desktop/releases/download/3.2.1-1/JupyterLab-Setup-Debian.deb
+ md5sums = SKIP
+
+pkgname = jupyterlab-desktop-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0b9c37cbb572
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.xz
+*.deb
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc851c747900
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: mnabila nblid48[at]gmail[dot]com
+
+pkgname=jupyterlab-desktop-bin
+pkgver=3.2.1
+pkgrel=1
+pkgdesc="JupyterLab desktop application, based on Electron."
+
+url="https://github.com/jupyterlab/jupyterlab-desktop"
+license=("MIT")
+
+arch=('x86_64')
+source=("https://github.com/jupyterlab/jupyterlab-desktop/releases/download/$pkgver-$pkgrel/JupyterLab-Setup-Debian.deb")
+
+md5sums=('SKIP')
+
+prepare(){
+ cd $srcdir
+ tar -xf data.tar.xz
+}
+
+package() {
+ cd $srcdir
+ mv usr $pkgdir/
+ mv opt $pkgdir/
+}