summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD75
-rwxr-xr-xjupyter-lab.desktop10
4 files changed, 57 insertions, 60 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 021332d50e28..abb1dda29623 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,21 @@
-# Generated by mksrcinfo v8
-# Wed Feb 21 22:24:41 UTC 2018
pkgbase = jupyterlab-git
- pkgdesc = JupyterLab computational environment.
- pkgver = 0.31.6.r21.g97e1decaf
+ pkgdesc = JupyterLab computational environment
+ pkgver = 18290.git.83d8388
pkgrel = 1
- url = https://jupyter.org
- install = jupyterlab-git.install
+ url = https://github.com/jupyterlab/jupyterlab
arch = any
- license = BSD
- makedepends = python3
- makedepends = npm
- makedepends = typescript
- makedepends = yarn
- depends = python
- depends = jupyter>=4.1.0-5
- provides = jupyterlab
- conflicts = jupyterlab
+ license = custom
+ makedepends = python-setuptools
+ makedepends = nodejs
+ makedepends = python-recommonmark
+ makedepends = jsx-lexer
+ depends = jupyterlab_server
source = git+https://github.com/jupyterlab/jupyterlab.git
- source = git+https://github.com/jupyterlab/jupyterlab_launcher.git
source = jupyterlab-git.install
- sha256sums = SKIP
+ source = jupyter-lab.desktop
sha256sums = SKIP
sha256sums = ad628adfa2aa6997ffc05352b86e75f1fe23f60b5e056cc0bd23f5d6f87ad4e9
+ sha256sums = d7ed2287b823a78b7fe05194180ad9b4602657d5e32b8ed548418039451c0434
pkgname = jupyterlab-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f751a868693b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.xz
+jupyterlab
+src
+pkg
diff --git a/PKGBUILD b/PKGBUILD
index e728857355e8..36ca90393539 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,58 +1,47 @@
-# Maintainer: Fabian Zaremba <fabian@youremail.eu>
+# Maintainer: Brenton Horne <brentonhorne77@gmail.com>
pkgname=jupyterlab-git
-pkgver=0.31.6.r21.g97e1decaf
+pkgver=18290.git.83d8388
pkgrel=1
-pkgdesc="JupyterLab computational environment."
-url="https://jupyter.org"
-depends=('python' 'jupyter>=4.1.0-5')
-makedepends=('python3' 'npm' 'typescript' 'yarn')
-license=('BSD')
-conflicts=('jupyterlab')
-provides=('jupyterlab')
-arch=('any')
-install='jupyterlab-git.install'
-source=('git+https://github.com/jupyterlab/jupyterlab.git'
- 'git+https://github.com/jupyterlab/jupyterlab_launcher.git'
- 'jupyterlab-git.install')
+pkgdesc="JupyterLab computational environment"
+arch=(any)
+url="https://github.com/jupyterlab/jupyterlab"
+license=(custom)
+makedepends=(python-setuptools nodejs python-recommonmark jsx-lexer)
+depends=(jupyterlab_server)
+source=("git+https://github.com/jupyterlab/jupyterlab.git"
+jupyterlab-git.install
+jupyter-lab.desktop)
sha256sums=('SKIP'
- 'SKIP'
- 'ad628adfa2aa6997ffc05352b86e75f1fe23f60b5e056cc0bd23f5d6f87ad4e9')
+ 'ad628adfa2aa6997ffc05352b86e75f1fe23f60b5e056cc0bd23f5d6f87ad4e9'
+ 'd7ed2287b823a78b7fe05194180ad9b4602657d5e32b8ed548418039451c0434')
pkgver() {
- cd "$srcdir/jupyterlab"
- git describe --match "v*" --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd $srcdir/jupyterlab
+ no=$(git rev-list --count HEAD)
+ hash=$(git log | head -n 1 | cut -d ' ' -f 2 | head -c 7)
+ printf "${no}.git.${hash}"
}
build() {
- cd "$srcdir"
-
- mkdir path
- export PATH="$PATH:$(pwd)/path"
- ln -s /usr/bin/yarn path/jlpm
-
- cd "$srcdir/jupyterlab"
- yarn install
- yarn run build
- yarn run build:core
-
- # How to build app dir assets when jupyterlab is not installed yet?
- # Optional according to wiki
- jupyter lab build || true
+ cd $srcdir/jupyterlab
+ python setup.py build
+ cd docs
+ make html
}
+package() {
+ cd $srcdir/jupyterlab
+ python setup.py install --skip-build --root="$pkgdir" --optimize=1
-check() {
- echo "Skipping tests.."
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
- #cd "$srcdir/jupyterlab"
- #yarn run build:test
- #yarn test
-}
+ # symlink to fix assets
+ install -d "$pkgdir"/usr/share/jupyter
+ ln -s `python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())"`/jupyterlab "$pkgdir"/usr/share/jupyter/lab
-package() {
- cd "$srcdir/jupyterlab_launcher"
- python setup.py install --root="$pkgdir" --optimize=1
- cd "$srcdir/jupyterlab"
- python setup.py install --root="$pkgdir" --optimize=1
+ install -d "$pkgdir"/usr/share/{pixmaps,doc/${pkgname}}
+ install -Dm644 jupyterlab/staging/node_modules/@jupyterlab/ui-components/style/icons/jupyter/jupyter.svg "$pkgdir"/usr/share/pixmaps/jupyter.svg
+ install -Dm755 $srcdir/jupyter-lab.desktop "$pkgdir"/usr/share/applications/jupyter-lab.desktop
+ cp -r docs/build/html/* ${pkgdir}/usr/share/doc/${pkgname}
}
diff --git a/jupyter-lab.desktop b/jupyter-lab.desktop
new file mode 100755
index 000000000000..670b9b8e67dc
--- /dev/null
+++ b/jupyter-lab.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=JupyterLab
+Type=Application
+Version=1.0
+Categories=Development;Science;Math;
+Comment=An extensible environment for interactive and reproducible computing, based on the Jupyter Notebook and Architecture
+Icon=jupyter
+Exec=jupyter-lab
+Terminal=true
+MimeType=application/x-ipynb+json;