summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..683130dbd286
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = jupyterthemes
+ pkgdesc = Select and install a Jupyter notebook theme
+ pkgver = 0.17.3
+ pkgrel = 1
+ url = https://github.com/dunovank/jupyter-themes
+ arch = any
+ license = MIT
+ makedepends = python3
+ depends = python
+ depends = python-matplotlib
+ depends = jupyter-notebook
+ depends = python-lesscpy
+ source = https://pypi.python.org/packages/99/c6/0c5e58bdc3a3f1042e88bb35435e04d346c862745ec2ffe2004bd030ebb3/jupyterthemes-0.17.3.tar.gz
+ md5sums = 01cbc565f6b2170afd1a5151b57274b8
+
+pkgname = jupyterthemes
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0eb13c53e94f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Renato Candido <renatocan@gmail.com>
+
+pkgname=jupyterthemes
+pkgver=0.17.3
+pkgrel=1
+pkgdesc="Select and install a Jupyter notebook theme"
+url="https://github.com/dunovank/jupyter-themes"
+depends=('python' 'python-matplotlib' 'jupyter-notebook' 'python-lesscpy')
+makedepends=('python3' )
+license=('MIT')
+arch=('any')
+source=('https://pypi.python.org/packages/99/c6/0c5e58bdc3a3f1042e88bb35435e04d346c862745ec2ffe2004bd030ebb3/jupyterthemes-0.17.3.tar.gz')
+md5sums=('01cbc565f6b2170afd1a5151b57274b8')
+
+build() {
+ cd $srcdir/jupyterthemes-0.17.3
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/jupyterthemes-0.17.3
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+
+md5sums=('01cbc565f6b2170afd1a5151b57274b8')