summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD24
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..349e7a2c8343
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = just
+ pkgdesc = Just a command runner, like make.
+ pkgver = 0.3.10
+ pkgrel = 1
+ url = https://github.com/casey/just
+ arch = x86_64
+ arch = i686
+ license = custom:WTFPL
+ license = custom:MIT
+ license = APACHE
+ license = https://github.com/casey//blob/master/LICENSE
+ makedepends = cargo
+ depends = gcc-libs
+ source = just-0.3.10.tar.gz::https://github.com/casey/just/archive/v0.3.10.tar.gz
+ sha256sums = b1b73609799883500bf57060ef48d056cc191662d67e18b300bbcc6e644d1529
+
+pkgname = just
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5daa8be5fe40
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Fredy GarcĂ­a <frealgagu at gmail dot com>
+
+pkgname=just
+pkgver=0.3.10
+pkgrel=1
+pkgdesc="Just a command runner, like make."
+arch=("x86_64" "i686")
+url="https://github.com/casey/${pkgname}"
+license=("custom:WTFPL" "custom:MIT" "APACHE" "https://github.com/casey/${pgkname}/blob/master/LICENSE")
+depends=("gcc-libs")
+makedepends=("cargo")
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/casey/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=("b1b73609799883500bf57060ef48d056cc191662d67e18b300bbcc6e644d1529")
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ cargo build --release
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -Dm755 "${srcdir}/${pkgname}-${pkgver}/target/release/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}