summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD29
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..acc7920d73d0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sat Nov 5 03:14:37 UTC 2016
+pkgbase = just-git
+ pkgdesc = Just a command runner, like make.
+ pkgver = 0.2.15.173
+ pkgrel = 1
+ url = https://github.com/casey/just
+ arch = x86_64
+ arch = i686
+ license = WTFPL
+ license = MIT
+ license = Apache-2.0
+ makedepends = cargo
+ provides = just
+ conflicts = just
+ source = just-git::git+https://github.com/casey/just.git
+ sha256sums = SKIP
+
+pkgname = just-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e93edb28a6e7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=just-git
+pkgver=0.2.15.173
+pkgrel=1
+pkgdesc="Just a command runner, like make."
+arch=('x86_64' 'i686')
+url="https://github.com/casey/just"
+license=('WTFPL' 'MIT' 'Apache-2.0')
+depends=()
+makedepends=('cargo')
+optdepends=()
+provides=('just')
+conflicts=('just')
+source=($pkgname::git+https://github.com/casey/just.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ echo $(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2).$(git rev-list --count HEAD)
+}
+
+build() {
+ cd $pkgname
+ cargo build --release
+}
+
+package() {
+ cd $pkgname
+ install -D -m755 "$srcdir/$pkgname/target/release/just" "$pkgdir/usr/bin/just"
+}