summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD12
3 files changed, 17 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 60e3721fb300..d752dcb7495f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = just-git
- pkgdesc = Just a command runner, like make.
- pkgver = latest
+ pkgdesc = A handy way to save and run project-specific commands
+ pkgver = 0.3.10.r0.ef45b02
pkgrel = 1
url = https://github.com/casey/just
- arch = x86_64
arch = i686
- license = custom:WTFPL
- license = custom:MIT
+ arch = x86_64
license = APACHE
+ license = custom:MIT
+ license = custom:WTFPL
makedepends = cargo
+ makedepends = git
depends = gcc-libs
provides = just
conflicts = just
- source = git+https://github.com/casey/just.git
+ source = just::git+https://github.com/casey/just.git
sha256sums = SKIP
pkgname = just-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1c8d3e57d932
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+just-git-*.pkg.tar.xz
+just/
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
index d6ba1f65724f..26af181af697 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=just-git
-pkgver=latest
+pkgver=0.3.10.r0.ef45b02
pkgrel=1
-pkgdesc="Just a command runner, like make."
-arch=("x86_64" "i686")
+pkgdesc="A handy way to save and run project-specific commands"
+arch=("i686" "x86_64")
url="https://github.com/casey/${pkgname%-git}"
-license=("custom:WTFPL" "custom:MIT" "APACHE")
+license=("APACHE" "custom:MIT" "custom:WTFPL")
depends=("gcc-libs")
-makedepends=("cargo")
+makedepends=("cargo" "git")
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=("git+https://github.com/casey/${pkgname%-git}.git")
+source=("${pkgname%-git}::git+https://github.com/casey/${pkgname%-git}.git")
sha256sums=("SKIP")
pkgver() {