summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD8
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c4b834edf7d..22d97311284f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = just-git
pkgdesc = Just a command runner, like make.
- pkgver = 0.3.3.334
- pkgrel = 1
+ pkgver = 0.3.3.1.gfcc27a9.335
+ pkgrel = 2
url = https://github.com/casey/just
arch = x86_64
arch = i686
- license = WTFPL
- license = MIT
- license = Apache-2.0
+ license = custom:WTFPL
+ license = custom:MIT
+ license = APACHE
makedepends = cargo
+ depends = gcc-libs
provides = just
conflicts = just
source = git+https://github.com/casey/just.git
diff --git a/PKGBUILD b/PKGBUILD
index 3f9bf3c8a765..f4b555841464 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=just-git
-pkgver=0.3.3.334
-pkgrel=1
+pkgver=0.3.3.1.gfcc27a9.335
+pkgrel=2
pkgdesc="Just a command runner, like make."
arch=('x86_64' 'i686')
url="https://github.com/casey/just"
-license=('WTFPL' 'MIT' 'Apache-2.0')
+license=('custom:WTFPL' 'custom:MIT' 'APACHE')
+depends=('gcc-libs')
makedepends=('cargo')
provides=('just')
conflicts=('just')
@@ -26,4 +27,5 @@ build() {
package() {
cd ${pkgname%-git}
install -Dm755 "$srcdir"/${pkgname%-git}/target/release/just "$pkgdir"/usr/bin/just
+ install -Dm644 "$srcdir"/${pkgname%-git}/LICENSE.md "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.md
}