summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
-rw-r--r--ffmpeg3andgcc6.patch74
3 files changed, 84 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 710b50516ef9..024c77d9e698 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Sun Dec 20 07:47:47 UTC 2015
pkgbase = k9copy-kde4
pkgdesc = A small utility to copy DVD
pkgver = 3.0.3
- pkgrel = 2
+ pkgrel = 1
url = http://sourceforge.net/projects/k9copy-reloaded/
install = k9copy.install
arch = x86_64
@@ -18,8 +16,12 @@ pkgbase = k9copy-kde4
depends = libdvdnav
optdepends = libdvdcss: for decoding encrypted DVDs
provides = k9copy-reloaded
+ conflicts = k9copy
+ conflicts = k9copy-frameworks
source = http://sourceforge.net/projects/k9copy-reloaded/files/k9copy-3.0.3.tar.gz
+ source = ffmpeg3andgcc6.patch
md5sums = 53158282e23a4aa4fb8f4336f1424521
+ md5sums = 3a7bf5dd2affedf83e41b2ecdca47630
pkgname = k9copy-kde4
diff --git a/PKGBUILD b/PKGBUILD
index 816077631a83..5fbfa28d64d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
# Maintainer: timcowchip <timcowchip@gmail>
pkgname=k9copy-kde4
+_pkgname=k9copy
pkgver=3.0.3
pkgrel=1
pkgdesc="A small utility to copy DVD"
@@ -12,11 +13,13 @@ makedepends=('automoc4' 'cmake')
provides=('k9copy-reloaded')
conflicts=('k9copy' 'k9copy-frameworks')
install=k9copy.install
-source=("http://sourceforge.net/projects/k9copy-reloaded/files/$pkgname-$pkgver.tar.gz")
-md5sums=('53158282e23a4aa4fb8f4336f1424521')
+source=("http://sourceforge.net/projects/k9copy-reloaded/files/$_pkgname-$pkgver.tar.gz" "ffmpeg3andgcc6.patch")
+md5sums=('53158282e23a4aa4fb8f4336f1424521' '3a7bf5dd2affedf83e41b2ecdca47630')
build(){
cd "$srcdir/k9copy"
+
+ patch -Np1 -i ../ffmpeg3andgcc6.patch
# Fix desktop files
sed -e 's|Name=k9copy|Name=K9copy|g' \
diff --git a/ffmpeg3andgcc6.patch b/ffmpeg3andgcc6.patch
new file mode 100644
index 000000000000..68218a20a372
--- /dev/null
+++ b/ffmpeg3andgcc6.patch
@@ -0,0 +1,74 @@
+--- k9copy/src/core/k9tools.cpp.orig 2016-07-04 03:37:07.537698816 +0100
++++ k9copy/src/core/k9tools.cpp 2016-07-04 03:37:15.044797764 +0100
+@@ -88,7 +88,7 @@ bool k9Tools::checkProgram(QString _prog
+ #if QT_VERSION >= 0x050000
+ bool res=QStandardPaths::findExecutable( _progName) !=NULL ;
+ #else // Qt4 Code
+- bool res= KStandardDirs::findExe( _progName,NULL,false) !=NULL ;
++ bool res= KStandardDirs::findExe( _progName,NULL,0) !=NULL ;
+ #endif
+ if (_msg && !res)
+ k9Dialogs::error(i18n("Error starting program %1").arg(_progName),i18n("Running program"));
+--- k9copy/src/backup/k9dvdbackup.cpp.orig 2016-07-04 03:45:28.518294176 +0100
++++ k9copy/src/backup/k9dvdbackup.cpp 2016-07-04 03:48:20.856559514 +0100
+@@ -33,6 +33,7 @@
+ #include <stdarg.h>
+ #include <errno.h>
+ #include <string.h>
++#include <math.h>
+ #include <qdir.h>
+
+ #include <kmessagebox.h>
+@@ -907,7 +908,8 @@ k9Vobu * k9DVDBackup::remapOffset(uint32
+
+
+ if ((vobu1 !=NULL) && (vobu2!=NULL)) {
+- *_offset = abs(vobu1->newSector - vobu2->newSector) | maskOffset1 ;
++ *_offset = fabs(vobu1->newSector - vobu2->newSector);
++ *_offset |= maskOffset1;
+ *_offset |= maskOffset2;
+ return vobu2;
+ }
+--- k9copy/src/import/k9avidecode.cpp.orig 2016-07-04 03:53:55.963959712 +0100
++++ k9copy/src/import/k9avidecode.cpp 2016-07-04 04:09:58.766458043 +0100
+@@ -26,7 +26,6 @@ static int sws_flags = SWS_BICUBIC;
+ void av_free_packet_internal(AVPacket *pkt)
+ {
+ if (pkt) {
+- if (pkt->destruct) pkt->destruct(pkt);
+ pkt->data = NULL; pkt->size = 0;
+ }
+ }
+@@ -238,14 +237,14 @@ bool k9AviDecode::open(const QString & _
+
+ int numBytes;
+ // Determine required buffer size and allocate buffer
+- numBytes=avpicture_get_size(PIX_FMT_RGB24, m_CodecCtx->width,
++ numBytes=avpicture_get_size(AV_PIX_FMT_RGB24, m_CodecCtx->width,
+ m_CodecCtx->height);
+ m_buffer=(uint8_t *)av_malloc(numBytes*sizeof(uint8_t));
+
+ // Assign appropriate parts of buffer to image planes in pFrameRGB
+ // Note that pFrameRGB is an AVFrame, but AVFrame is a superset
+ // of AVPicture
+- avpicture_fill((AVPicture *)m_FrameRGB, m_buffer, PIX_FMT_RGB24,
++ avpicture_fill((AVPicture *)m_FrameRGB, m_buffer, AV_PIX_FMT_RGB24,
+ m_CodecCtx->width, m_CodecCtx->height);
+
+
+@@ -317,13 +316,13 @@ void k9AviDecode::readFrame(double _seco
+ bFound=true;
+ #ifndef HAVE_SWSCALE
+ // Convert the image from its native format to RGB
+- img_convert((AVPicture *)m_FrameRGB, PIX_FMT_RGB24,
++ img_convert((AVPicture *)m_FrameRGB, AV_PIX_FMT_RGB24,
+ (AVPicture*)m_Frame, m_CodecCtx->pix_fmt,
+ m_CodecCtx->width, m_CodecCtx->height);
+ SaveFrame(m_FrameRGB, m_CodecCtx->width,
+ m_CodecCtx->height);
+ #else
+- toRGB_convert_ctx=sws_getContext(m_CodecCtx->width, m_CodecCtx->height, m_CodecCtx->pix_fmt, m_CodecCtx->width, m_CodecCtx->height, PIX_FMT_RGB24, sws_flags,NULL,NULL,NULL);
++ toRGB_convert_ctx=sws_getContext(m_CodecCtx->width, m_CodecCtx->height, m_CodecCtx->pix_fmt, m_CodecCtx->width, m_CodecCtx->height, AV_PIX_FMT_RGB24, sws_flags,NULL,NULL,NULL);
+ sws_scale(toRGB_convert_ctx, m_Frame->data, m_Frame->linesize, 0, m_CodecCtx->height, m_FrameRGB->data,m_FrameRGB->linesize);
+ // convert frame to QImage
+ SaveFrame(m_FrameRGB, m_CodecCtx->width,