summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
-rw-r--r--kafka-manager.conf53
-rw-r--r--kafka-manager.service2
4 files changed, 61 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 500fdfbd96be..148526f674ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,22 @@
pkgbase = kafka-manager
- pkgdesc = A tool for managing Apache Kafka.
- pkgver = 1.3.3.17
+ pkgdesc = A tool for managing Apache Kafka. Also known as CMAK.
+ pkgver = 3.0.0.4
pkgrel = 1
- url = https://github.com/yahoo/kafka-manager
+ url = https://github.com/yahoo/CMAK
install = kafka-manager.install
arch = any
license = Apache
makedepends = sbt
makedepends = unzip
- depends = java-environment=8
+ depends = java-environment>=11
depends = bash
backup = etc/kafka-manager.conf
- source = https://github.com/yahoo/kafka-manager/archive/1.3.3.17.tar.gz
+ source = kafka-manager-3.0.0.4.tar.gz::https://github.com/yahoo/kafka-manager/archive/3.0.0.4.tar.gz
source = kafka-manager.conf
source = kafka-manager.service
- md5sums = cf9a82bc684bbdebe5820d50d67053f8
- md5sums = 8ee7f7d85857bfad3ad087678a47d270
- md5sums = 22db3c3ad6b7772fad5513b5438b707b
+ md5sums = d19a1ba3fcc81ddba18ac0533d073183
+ md5sums = ce078e82f517feb2ba27db7d52e79324
+ md5sums = a5307a86a62d2689c11e9ef5d9619b1c
pkgname = kafka-manager
diff --git a/PKGBUILD b/PKGBUILD
index 1e043688c12f..31901d12c362 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Cedric Meury <cedric@meury.com>
# Maintainer: Michael Louis Thaler <michael.louis.thaler@gmail.com>
pkgname=kafka-manager
-pkgver=1.3.3.17
+pkgver=3.0.0.4
pkgrel=1
-pkgdesc="A tool for managing Apache Kafka."
+pkgdesc="A tool for managing Apache Kafka. Also known as CMAK."
arch=('any')
-url="https://github.com/yahoo/kafka-manager"
+url="https://github.com/yahoo/CMAK"
license=('Apache')
groups=()
-# running kafka-manager requires java8
-depends=('java-environment=8'
+# running kafka-manager requires java11+
+depends=('java-environment>=11'
'bash')
makedepends=('sbt'
'unzip')
@@ -21,22 +21,22 @@ backup=('etc/kafka-manager.conf')
options=()
install=$pkgname.install
changelog=
-source=(https://github.com/yahoo/$pkgname/archive/$pkgver.tar.gz
+source=($pkgname-$pkgver.tar.gz::https://github.com/yahoo/$pkgname/archive/$pkgver.tar.gz
${pkgname}.conf
${pkgname}.service)
-md5sums=('cf9a82bc684bbdebe5820d50d67053f8'
- '8ee7f7d85857bfad3ad087678a47d270'
- '22db3c3ad6b7772fad5513b5438b707b')
+md5sums=('d19a1ba3fcc81ddba18ac0533d073183'
+ 'ce078e82f517feb2ba27db7d52e79324'
+ 'a5307a86a62d2689c11e9ef5d9619b1c')
build() {
- cd "$pkgname-$pkgver"
+ cd "CMAK-$pkgver"
./sbt clean dist
}
package() {
mkdir $pkgdir/opt
- unzip -q $srcdir/$pkgname-$pkgver/target/universal/$pkgname-$pkgver.zip -d $pkgdir/opt
- ln -s "/opt/$pkgname-$pkgver" "${pkgdir}/opt/$pkgname"
+ unzip -q $srcdir/CMAK-$pkgver/target/universal/cmak-$pkgver.zip -d $pkgdir/opt
+ ln -s "/opt/cmak-$pkgver" "${pkgdir}/opt/$pkgname"
install -D -m644 "${srcdir}/$pkgname.conf" "${pkgdir}/etc/${pkgname}.conf"
install -D -m644 "${srcdir}/$pkgname.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
}
diff --git a/kafka-manager.conf b/kafka-manager.conf
index c8819a7d4d08..8ee6c61e4a0e 100644
--- a/kafka-manager.conf
+++ b/kafka-manager.conf
@@ -8,37 +8,64 @@
# ~~~~~
# The secret key is used to secure cryptographics functions.
# If you deploy your application to several instances be sure to use the same key!
-
-# CAUTION:
-# "Anyone that can get access to the secret will be able to generate any session they please,
-# effectively allowing them to log in to your system as any user they please. Hence it is
-# strongly recommended that you do not check your application secret into source control."
-# Source: https://www.playframework.com/documentation/2.5.x/ApplicationSecret
-
play.crypto.secret="^<csmm5Fx4d=r2HEX8pelM3iBkFVv?k[mc;IZE<_Qoq8EkX_/7@Zt6dP05Pzea3U"
play.crypto.secret=${?APPLICATION_SECRET}
+play.http.session.maxAge="1h"
# The application languages
# ~~~~~
play.i18n.langs=["en"]
play.http.requestHandler = "play.http.DefaultHttpRequestHandler"
-
+play.http.context = "/"
play.application.loader=loader.KafkaManagerLoader
-kafka-manager.zkhosts="localhost:2181"
-kafka-manager.zkhosts=${?ZK_HOSTS}
+cmak.zkhosts="localhost:2181"
+cmak.zkhosts=${?ZK_HOSTS}
+
pinned-dispatcher.type="PinnedDispatcher"
pinned-dispatcher.executor="thread-pool-executor"
-application.features=["KMClusterManagerFeature","KMTopicManagerFeature","KMPreferredReplicaElectionFeature","KMReassignPartitionsFeature"]
+application.features=["KMClusterManagerFeature","KMTopicManagerFeature","KMPreferredReplicaElectionFeature","KMReassignPartitionsFeature", "KMScheduleLeaderElectionFeature"]
akka {
- loggers = ["akka.event.slf4j.Slf4jLogger"]
- loglevel = "INFO"
+ loggers = ["akka.event.slf4j.Slf4jLogger"]
+ loglevel = "INFO"
}
+akka.logger-startup-timeout = 60s
+
basicAuthentication.enabled=false
+basicAuthentication.enabled=${?KAFKA_MANAGER_AUTH_ENABLED}
+
+basicAuthentication.ldap.enabled=false
+basicAuthentication.ldap.enabled=${?KAFKA_MANAGER_LDAP_ENABLED}
+basicAuthentication.ldap.server=""
+basicAuthentication.ldap.server=${?KAFKA_MANAGER_LDAP_SERVER}
+basicAuthentication.ldap.port=389
+basicAuthentication.ldap.port=${?KAFKA_MANAGER_LDAP_PORT}
+basicAuthentication.ldap.username=""
+basicAuthentication.ldap.username=${?KAFKA_MANAGER_LDAP_USERNAME}
+basicAuthentication.ldap.password=""
+basicAuthentication.ldap.password=${?KAFKA_MANAGER_LDAP_PASSWORD}
+basicAuthentication.ldap.search-base-dn=""
+basicAuthentication.ldap.search-base-dn=${?KAFKA_MANAGER_LDAP_SEARCH_BASE_DN}
+basicAuthentication.ldap.search-filter="(uid=$capturedLogin$)"
+basicAuthentication.ldap.search-filter=${?KAFKA_MANAGER_LDAP_SEARCH_FILTER}
+basicAuthentication.ldap.group-filter=""
+basicAuthentication.ldap.group-filter=${?KAFKA_MANAGER_LDAP_GROUP_FILTER}
+basicAuthentication.ldap.connection-pool-size=10
+basicAuthentication.ldap.connection-pool-size=${?KAFKA_MANAGER_LDAP_CONNECTION_POOL_SIZE}
+basicAuthentication.ldap.ssl=false
+basicAuthentication.ldap.ssl=${?KAFKA_MANAGER_LDAP_SSL}
+
basicAuthentication.username="admin"
+basicAuthentication.username=${?KAFKA_MANAGER_USERNAME}
basicAuthentication.password="password"
+basicAuthentication.password=${?KAFKA_MANAGER_PASSWORD}
+
basicAuthentication.realm="Kafka-Manager"
+basicAuthentication.excluded=["/api/health"] # ping the health of your instance without authentification
+
+
+kafka-manager.consumer.properties.file=${?CONSUMER_PROPERTIES_FILE}
diff --git a/kafka-manager.service b/kafka-manager.service
index d2b74c0422cc..1f8d4a969e10 100644
--- a/kafka-manager.service
+++ b/kafka-manager.service
@@ -7,7 +7,7 @@ Type=simple
PIDFile=/var/lib/kafka-manager/kafka-manager.pid
ExecStartPre=-/usr/bin/mkdir -p /var/lib/kafka-manager
ExecStartPre=/usr/bin/chown -R kafka-manager:kafka-manager /var/lib/kafka-manager/
-ExecStart=/opt/kafka-manager/bin/kafka-manager -Dconfig.file=/etc/kafka-manager.conf -Dpidfile.path=/var/lib/kafka-manager/kafka-manager.pid -Dapplication.home=/var/lib/kafka-manager
+ExecStart=/opt/kafka-manager/bin/cmak -Dconfig.file=/etc/kafka-manager.conf -Dpidfile.path=/var/lib/kafka-manager/kafka-manager.pid -Dapplication.home=/var/lib/kafka-manager
PermissionsStartOnly=true
ExecStop=/bin/kill $MAINPID
User=kafka-manager